summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2015-07-07 17:47:10 +0000
committerManuel Rüger <mrueg@gentoo.org>2015-07-07 17:47:10 +0000
commitd68beb2d60dba910795bcbbde35eef0ec160a4ac (patch)
treeb58a6f80b7f605d5043757994d4b214758b1df86 /x11-apps
parentNMU: Version bump. See bug #529218. (diff)
downloadgentoo-2-d68beb2d60dba910795bcbbde35eef0ec160a4ac.tar.gz
gentoo-2-d68beb2d60dba910795bcbbde35eef0ec160a4ac.tar.bz2
gentoo-2-d68beb2d60dba910795bcbbde35eef0ec160a4ac.zip
Version bump. Remove old.
(Portage version: 2.2.20/cvs/Linux x86_64, signed Manifest commit with key )
Diffstat (limited to 'x11-apps')
-rw-r--r--x11-apps/intel-gpu-tools/ChangeLog8
-rw-r--r--x11-apps/intel-gpu-tools/intel-gpu-tools-1.11.ebuild58
-rw-r--r--x11-apps/intel-gpu-tools/intel-gpu-tools-1.2.ebuild16
-rw-r--r--x11-apps/intel-gpu-tools/intel-gpu-tools-1.3.ebuild24
4 files changed, 65 insertions, 41 deletions
diff --git a/x11-apps/intel-gpu-tools/ChangeLog b/x11-apps/intel-gpu-tools/ChangeLog
index 2bbbe0e11972..c4f21679e8dd 100644
--- a/x11-apps/intel-gpu-tools/ChangeLog
+++ b/x11-apps/intel-gpu-tools/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for x11-apps/intel-gpu-tools
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-apps/intel-gpu-tools/ChangeLog,v 1.25 2015/05/30 03:41:38 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-apps/intel-gpu-tools/ChangeLog,v 1.26 2015/07/07 17:47:10 mrueg Exp $
+
+*intel-gpu-tools-1.11 (07 Jul 2015)
+
+ 07 Jul 2015; Manuel Rüger <mrueg@gentoo.org> +intel-gpu-tools-1.11.ebuild,
+ -intel-gpu-tools-1.2.ebuild, -intel-gpu-tools-1.3.ebuild:
+ Version bump. Remove old.
30 May 2015; Mike Frysinger <vapier@gentoo.org> intel-gpu-tools-1.7.ebuild:
Add clang patch to older version too.
diff --git a/x11-apps/intel-gpu-tools/intel-gpu-tools-1.11.ebuild b/x11-apps/intel-gpu-tools/intel-gpu-tools-1.11.ebuild
new file mode 100644
index 000000000000..3edcaf483e72
--- /dev/null
+++ b/x11-apps/intel-gpu-tools/intel-gpu-tools-1.11.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-apps/intel-gpu-tools/intel-gpu-tools-1.11.ebuild,v 1.1 2015/07/07 17:47:10 mrueg Exp $
+
+EAPI=5
+
+PYTHON_COMPAT=( python{3_3,3_4} )
+
+inherit python-single-r1 xorg-2
+
+DESCRIPTION="Intel GPU userland tools"
+KEYWORDS="~amd64 ~x86"
+IUSE="python test-programs video_cards_nouveau"
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+RESTRICT="test"
+
+DEPEND="dev-libs/glib:2
+ >=x11-libs/cairo-1.12.0
+ >=x11-libs/libdrm-2.4.52[video_cards_intel,video_cards_nouveau?]
+ >=x11-libs/libpciaccess-0.10
+ python? ( ${PYTHON_DEPS} )"
+RDEPEND="${DEPEND}"
+
+pkg_setup() {
+ use python && python-single-r1_pkg_setup
+}
+
+src_configure() {
+ XORG_CONFIGURE_OPTIONS=(
+ $(use_enable python dumper)
+ $(use_enable video_cards_nouveau nouveau)
+ $(use_enable test-programs tests)
+ )
+ xorg-2_src_configure
+}
+
+src_install() {
+ xorg-2_src_install
+ if use test-programs; then
+ local testprogram
+ pushd "${AUTOTOOLS_BUILD_DIR}"/tests || die
+ for testprogram in $(<multi-tests.txt) $(<single-tests.txt); do
+ if [[ -f ${testprogram} ]]; then
+ dobin "${testprogram}"
+ fi
+ done
+ popd
+ fi
+}
+
+pkg_postinst() {
+ xorg-2_pkg_postinst
+ if use test-programs; then
+ elog "Test programs for DRM driver development were installed. These are not"
+ elog "designed to run outside their source tree, so may or may not work as"
+ elog "intended."
+ fi
+}
diff --git a/x11-apps/intel-gpu-tools/intel-gpu-tools-1.2.ebuild b/x11-apps/intel-gpu-tools/intel-gpu-tools-1.2.ebuild
deleted file mode 100644
index 4668141bdddd..000000000000
--- a/x11-apps/intel-gpu-tools/intel-gpu-tools-1.2.ebuild
+++ /dev/null
@@ -1,16 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-apps/intel-gpu-tools/intel-gpu-tools-1.2.ebuild,v 1.5 2012/06/24 18:42:55 ago Exp $
-
-EAPI=4
-inherit xorg-2
-
-DESCRIPTION="intel gpu userland tools"
-KEYWORDS="amd64 x86"
-IUSE=""
-RESTRICT="test"
-
-DEPEND="x11-libs/cairo
- >=x11-libs/libdrm-2.4.31[video_cards_intel]
- >=x11-libs/libpciaccess-0.10"
-RDEPEND="${DEPEND}"
diff --git a/x11-apps/intel-gpu-tools/intel-gpu-tools-1.3.ebuild b/x11-apps/intel-gpu-tools/intel-gpu-tools-1.3.ebuild
deleted file mode 100644
index fdc2029ad03a..000000000000
--- a/x11-apps/intel-gpu-tools/intel-gpu-tools-1.3.ebuild
+++ /dev/null
@@ -1,24 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-apps/intel-gpu-tools/intel-gpu-tools-1.3.ebuild,v 1.5 2012/11/18 12:07:31 ago Exp $
-
-EAPI=4
-inherit xorg-2
-
-DESCRIPTION="intel gpu userland tools"
-KEYWORDS="amd64 x86"
-IUSE="video_cards_nouveau"
-RESTRICT="test"
-
-DEPEND="dev-libs/glib:2
- x11-libs/cairo
- >=x11-libs/libdrm-2.4.31[video_cards_intel,video_cards_nouveau?]
- >=x11-libs/libpciaccess-0.10"
-RDEPEND="${DEPEND}"
-
-src_configure() {
- XORG_CONFIGURE_OPTIONS=(
- $(use_enable video_cards_nouveau nouveau)
- )
- xorg-2_src_configure
-}