summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2008-02-21 19:08:34 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2008-02-21 19:08:34 +0000
commitbfb5f3b5fae8adf9423e821a2741d351b4e7a6d2 (patch)
tree5c96e15177253d838446f8e2b0dfe88880c6834f /x11-apps
parentFix parallel make, bug #210939 (diff)
downloadgentoo-2-bfb5f3b5fae8adf9423e821a2741d351b4e7a6d2.tar.gz
gentoo-2-bfb5f3b5fae8adf9423e821a2741d351b4e7a6d2.tar.bz2
gentoo-2-bfb5f3b5fae8adf9423e821a2741d351b4e7a6d2.zip
New revision that uses pambase. It also properly depend om PAM when pam USE flag is enabled, and moves sessreg and xrdb into RDEPEND only.
(Portage version: 2.1.4.4)
Diffstat (limited to 'x11-apps')
-rw-r--r--x11-apps/xdm/ChangeLog8
-rw-r--r--x11-apps/xdm/xdm-1.1.6-r1.ebuild63
2 files changed, 70 insertions, 1 deletions
diff --git a/x11-apps/xdm/ChangeLog b/x11-apps/xdm/ChangeLog
index 25b804f35fa7..291969e9b449 100644
--- a/x11-apps/xdm/ChangeLog
+++ b/x11-apps/xdm/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for x11-apps/xdm
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-apps/xdm/ChangeLog,v 1.78 2008/02/05 11:32:12 corsair Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-apps/xdm/ChangeLog,v 1.79 2008/02/21 19:08:34 flameeyes Exp $
+
+*xdm-1.1.6-r1 (21 Feb 2008)
+
+ 21 Feb 2008; Diego Pettenò <flameeyes@gentoo.org> +xdm-1.1.6-r1.ebuild:
+ New revision that uses pambase. It also properly depend om PAM when pam USE
+ flag is enabled, and moves sessreg and xrdb into RDEPEND only.
05 Feb 2008; Markus Rothe <corsair@gentoo.org> xdm-1.1.6.ebuild:
Stable on ppc64
diff --git a/x11-apps/xdm/xdm-1.1.6-r1.ebuild b/x11-apps/xdm/xdm-1.1.6-r1.ebuild
new file mode 100644
index 000000000000..e4032006b2e6
--- /dev/null
+++ b/x11-apps/xdm/xdm-1.1.6-r1.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-apps/xdm/xdm-1.1.6-r1.ebuild,v 1.1 2008/02/21 19:08:34 flameeyes Exp $
+
+# Must be before x-modular eclass is inherited
+#SNAPSHOT="yes"
+
+inherit multilib x-modular pam
+
+DEFAULTVT="vt7"
+
+DESCRIPTION="X.Org xdm application"
+
+KEYWORDS=""
+IUSE="xprint ipv6 pam"
+
+RDEPEND="x11-libs/libXdmcp
+ x11-libs/libXaw
+ >=x11-apps/xinit-1.0.2-r3
+ x11-libs/libXinerama
+ x11-libs/libX11
+ x11-libs/libXt
+ pam? ( virtual/pam )"
+DEPEND="${RDEPEND}
+ x11-proto/xineramaproto
+ x11-proto/xproto"
+
+RDEPEND="${RDEPEND}
+ x11-apps/xrdb
+ x11-apps/sessreg
+ pam? ( sys-auth/pambase )"
+
+PATCHES="${FILESDIR}/wtmp.patch
+ ${FILESDIR}/xwilling-hang.patch"
+
+CONFIGURE_OPTIONS="$(use_enable xprint)
+ $(use_enable ipv6)
+ $(use_with pam)
+ --with-default-vt=${DEFAULTVT}
+ --with-xdmconfigdir=/etc/X11/xdm"
+
+pkg_setup() {
+ if use xprint && ! built_with_use x11-libs/libXaw xprint; then
+ die "Build x11-libs/libXaw with USE=xprint."
+ fi
+}
+
+src_install() {
+ x-modular_src_install
+ exeinto /usr/$(get_libdir)/X11/xdm
+ doexe ${FILESDIR}/Xsession
+ pamd_mimic system-local-login xdm auth account session
+}
+
+pkg_preinst() {
+ x-modular_pkg_preinst
+
+ # Check for leftover /usr/lib/X11/xdm symlink
+ if [[ -L "/usr/lib/X11/xdm" ]]; then
+ ewarn "/usr/lib/X11/xdm is a symlink; deleting."
+ rm /usr/lib/X11/xdm
+ fi
+}