summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergey Popov <pinkbyte@gentoo.org>2014-01-23 08:08:39 +0000
committerSergey Popov <pinkbyte@gentoo.org>2014-01-23 08:08:39 +0000
commitbe99c1cffd731331df2912bb1e036b55578a81a5 (patch)
treebbd94a8fe19a14a0f8d51b88c9d8125f6516b58c /x11-apps
parentVersion bump. (diff)
downloadgentoo-2-be99c1cffd731331df2912bb1e036b55578a81a5.tar.gz
gentoo-2-be99c1cffd731331df2912bb1e036b55578a81a5.tar.bz2
gentoo-2-be99c1cffd731331df2912bb1e036b55578a81a5.zip
Revision bump: add workaround for bug #487106, patch by Small_Penguin <dark.shadow AT gmx.at>
(Portage version: 2.2.8/cvs/Linux x86_64, signed Manifest commit with key 0x1F357D42)
Diffstat (limited to 'x11-apps')
-rw-r--r--x11-apps/ccsm/ChangeLog11
-rw-r--r--x11-apps/ccsm/ccsm-0.8.4-r5.ebuild54
-rw-r--r--x11-apps/ccsm/files/ccsm-0.8.4-pygobject-glib-fix.patch16
3 files changed, 79 insertions, 2 deletions
diff --git a/x11-apps/ccsm/ChangeLog b/x11-apps/ccsm/ChangeLog
index d92287a9a53c..83ed2fd2b3b9 100644
--- a/x11-apps/ccsm/ChangeLog
+++ b/x11-apps/ccsm/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for x11-apps/ccsm
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-apps/ccsm/ChangeLog,v 1.30 2013/08/25 15:01:19 pinkbyte Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/x11-apps/ccsm/ChangeLog,v 1.31 2014/01/23 08:08:38 pinkbyte Exp $
+
+*ccsm-0.8.4-r5 (23 Jan 2014)
+
+ 23 Jan 2014; Sergey Popov <pinkbyte@gentoo.org> +ccsm-0.8.4-r5.ebuild,
+ +files/ccsm-0.8.4-pygobject-glib-fix.patch:
+ Revision bump: add workaround for bug #487106, patch by Small_Penguin
+ <dark.shadow AT gmx.at>
25 Aug 2013; Sergey Popov <pinkbyte@gentoo.org> -ccsm-0.8.4-r2.ebuild:
Drop old revision
diff --git a/x11-apps/ccsm/ccsm-0.8.4-r5.ebuild b/x11-apps/ccsm/ccsm-0.8.4-r5.ebuild
new file mode 100644
index 000000000000..8bfe76d903d7
--- /dev/null
+++ b/x11-apps/ccsm/ccsm-0.8.4-r5.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-apps/ccsm/ccsm-0.8.4-r5.ebuild,v 1.1 2014/01/23 08:08:38 pinkbyte Exp $
+
+EAPI="5"
+
+PYTHON_COMPAT=( python2_{6,7} )
+DISTUTILS_IN_SOURCE_BUILD=1
+inherit distutils-r1
+
+DESCRIPTION="Compizconfig Settings Manager"
+HOMEPAGE="http://www.compiz.org/"
+SRC_URI="http://releases.compiz.org/${PV}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+
+RDEPEND="
+ >=dev-python/compizconfig-python-${PV}[${PYTHON_USEDEP}]
+ >=dev-python/pygtk-2.12:2[${PYTHON_USEDEP}]
+ gnome-base/librsvg
+"
+
+# missing icons and text fix, bug #487106
+PATCHES=( "${FILESDIR}/${P}-pygobject-glib-fix.patch" )
+
+DOCS=( AUTHORS )
+
+python_prepare_all() {
+ # return error if wrong arguments passed to setup.py
+ sed -i -e 's/raise SystemExit/\0(1)/' setup.py || die 'sed on setup.py failed'
+ # fix desktop file
+ sed -i \
+ -e '/Categories/s/Compiz/X-\0/' \
+ -e '/Encoding/d' \
+ ccsm.desktop.in || die 'sed on ccsm.desktop.in failed'
+
+ # correct gettext behavior
+ if [[ -n "${LINGUAS+x}" ]] ; then
+ for i in $(cd po ; echo *po | sed 's/\.po//g') ; do
+ if ! has ${i} ${LINGUAS} ; then
+ rm po/${i}.po || die
+ fi
+ done
+ fi
+
+ distutils-r1_python_prepare_all
+}
+
+python_configure_all() {
+ #set prefix
+ mydistutilsargs=( build --prefix=/usr )
+}
diff --git a/x11-apps/ccsm/files/ccsm-0.8.4-pygobject-glib-fix.patch b/x11-apps/ccsm/files/ccsm-0.8.4-pygobject-glib-fix.patch
new file mode 100644
index 000000000000..9b325af7f341
--- /dev/null
+++ b/x11-apps/ccsm/files/ccsm-0.8.4-pygobject-glib-fix.patch
@@ -0,0 +1,16 @@
+Fix missing icon and text with new PyGObject
+Gentoo bugreport - https://bugs.gentoo.org/show_bug.cgi?id=487106
+Patch by Small_Penguin <dark.shadow AT gmx.at>
+
+diff -Naur ccsm-0.8.4~/ccm/Utils.py ccsm-0.8.4/ccm/Utils.py
+--- ccsm-0.8.4~/ccm/Utils.py 2009-10-14 03:05:30.000000000 +0200
++++ ccsm-0.8.4/ccm/Utils.py 2013-10-05 10:16:10.050030522 +0200
+@@ -184,7 +184,7 @@
+ if has_focus:
+ self.unset_flags (gtk.HAS_FOCUS)
+
+- ret = super (PrettyButton, self).do_expose_event (self, event)
++ ret = gtk.Button.do_expose_event (self, event)
+
+ if has_focus:
+ self.set_flags (gtk.HAS_FOCUS)