summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJorge Manuel B. S. Vicetto <jmbsvicetto@gentoo.org>2010-04-03 05:28:03 +0000
committerJorge Manuel B. S. Vicetto <jmbsvicetto@gentoo.org>2010-04-03 05:28:03 +0000
commit573a30b11133c228483be4984f1c69587b1814f1 (patch)
tree2d93dba7066dc44c821e4e5aee4c487fd0677fb2 /x11-apps
parentReplaced compiz ~ deps with >= deps to support the new compiz-0.8.6 release a... (diff)
downloadgentoo-2-573a30b11133c228483be4984f1c69587b1814f1.tar.gz
gentoo-2-573a30b11133c228483be4984f1c69587b1814f1.tar.bz2
gentoo-2-573a30b11133c228483be4984f1c69587b1814f1.zip
Replaced compiz ~ deps with >= deps to support the new compiz-0.8.6 release and to avoid future dep issues.
Did a revbump to avoid issues with installed packages. (Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'x11-apps')
-rw-r--r--x11-apps/simple-ccsm/ChangeLog12
-rw-r--r--x11-apps/simple-ccsm/simple-ccsm-0.8.4-r1.ebuild35
2 files changed, 45 insertions, 2 deletions
diff --git a/x11-apps/simple-ccsm/ChangeLog b/x11-apps/simple-ccsm/ChangeLog
index edfd5c7a1e8a..ceded4ae055e 100644
--- a/x11-apps/simple-ccsm/ChangeLog
+++ b/x11-apps/simple-ccsm/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for x11-apps/simple-ccsm
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-apps/simple-ccsm/ChangeLog,v 1.9 2009/12/11 17:21:21 scarabeus Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/x11-apps/simple-ccsm/ChangeLog,v 1.10 2010/04/03 05:28:03 jmbsvicetto Exp $
+
+*simple-ccsm-0.8.4-r1 (03 Apr 2010)
+
+ 03 Apr 2010; Jorge Manuel B. S. Vicetto <jmbsvicetto@gentoo.org>
+ +simple-ccsm-0.8.4-r1.ebuild:
+ Replaced compiz ~ deps with >= deps to support the new compiz-0.8.6
+ release and to avoid future dep issues.
+ Did a revbump to avoid issues with installed packages.
11 Dec 2009; Tomáš Chvátal <scarabeus@gentoo.org>
-simple-ccsm-0.8.2.ebuild:
diff --git a/x11-apps/simple-ccsm/simple-ccsm-0.8.4-r1.ebuild b/x11-apps/simple-ccsm/simple-ccsm-0.8.4-r1.ebuild
new file mode 100644
index 000000000000..0496c15fc804
--- /dev/null
+++ b/x11-apps/simple-ccsm/simple-ccsm-0.8.4-r1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-apps/simple-ccsm/simple-ccsm-0.8.4-r1.ebuild,v 1.1 2010/04/03 05:28:03 jmbsvicetto Exp $
+
+inherit distutils gnome2-utils
+
+DESCRIPTION="Simplified Compizconfig Settings Manager"
+HOMEPAGE="http://www.compiz.org/"
+SRC_URI="http://releases.compiz.org/${PV}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE="gtk"
+
+RDEPEND="
+ >=dev-python/compizconfig-python-${PV}
+ >=dev-python/pygtk-2.10
+ >=x11-apps/ccsm-${PV}
+"
+
+src_compile() {
+ distutils_src_compile --prefix=/usr
+}
+
+src_install() {
+ distutils_src_install --prefix=/usr
+}
+
+pkg_postinst() {
+ if use gtk; then
+ gnome2_icon_savelist
+ gnome2_icon_cache_update
+ fi
+}