summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomas Chvatal <scarabeus@gentoo.org>2011-03-10 16:15:28 +0000
committerTomas Chvatal <scarabeus@gentoo.org>2011-03-10 16:15:28 +0000
commite8350e1c1b38ef44b61b17f89c7c1fa995e06034 (patch)
treec36be1cab917ad5e24ee33346bb1cdb873ba5628 /x11-apps/xinput_calibrator
parentAdd new version 7.5.3 (diff)
downloadgentoo-2-e8350e1c1b38ef44b61b17f89c7c1fa995e06034.tar.gz
gentoo-2-e8350e1c1b38ef44b61b17f89c7c1fa995e06034.tar.bz2
gentoo-2-e8350e1c1b38ef44b61b17f89c7c1fa995e06034.zip
Initial commit. Fixes bug #338816. Ebuild written by me.
(Portage version: 2.2.0_alpha26/cvs/Linux x86_64)
Diffstat (limited to 'x11-apps/xinput_calibrator')
-rw-r--r--x11-apps/xinput_calibrator/ChangeLog10
-rw-r--r--x11-apps/xinput_calibrator/metadata.xml11
-rw-r--r--x11-apps/xinput_calibrator/xinput_calibrator-0.7.5.ebuild30
3 files changed, 51 insertions, 0 deletions
diff --git a/x11-apps/xinput_calibrator/ChangeLog b/x11-apps/xinput_calibrator/ChangeLog
new file mode 100644
index 000000000000..16f982bbb1ab
--- /dev/null
+++ b/x11-apps/xinput_calibrator/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for x11-apps/xinput_calibrator
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/x11-apps/xinput_calibrator/ChangeLog,v 1.1 2011/03/10 16:15:28 scarabeus Exp $
+
+*xinput_calibrator-0.7.5 (10 Mar 2011)
+
+ 10 Mar 2011; Tomáš Chvátal <scarabeus@gentoo.org>
+ +xinput_calibrator-0.7.5.ebuild, +metadata.xml:
+ Initial commit. Fixes bug #338816. Ebuild written by me.
+
diff --git a/x11-apps/xinput_calibrator/metadata.xml b/x11-apps/xinput_calibrator/metadata.xml
new file mode 100644
index 000000000000..8f15b004c4ed
--- /dev/null
+++ b/x11-apps/xinput_calibrator/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>x11</herd>
+ <use>
+ <flag name='minimal'>
+ Control dependencies on legacy apps (xterm, twm, ...). Safe to
+ enable if you use a modern desktop environment.
+ </flag>
+ </use>
+</pkgmetadata>
diff --git a/x11-apps/xinput_calibrator/xinput_calibrator-0.7.5.ebuild b/x11-apps/xinput_calibrator/xinput_calibrator-0.7.5.ebuild
new file mode 100644
index 000000000000..b9119b85a286
--- /dev/null
+++ b/x11-apps/xinput_calibrator/xinput_calibrator-0.7.5.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-apps/xinput_calibrator/xinput_calibrator-0.7.5.ebuild,v 1.1 2011/03/10 16:15:28 scarabeus Exp $
+
+EAPI=4
+inherit autotools-utils
+
+DESCRIPTION="A generic touchscreen calibration program for X.Org"
+HOMEPAGE="http://www.freedesktop.org/wiki/Software/xinput_calibrator"
+SRC_URI="http://cloud.github.com/downloads/tias/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="gtk"
+
+DEPEND="x11-libs/libX11
+ x11-libs/libXext
+ x11-libs/libXi
+ x11-libs/libXrandr
+ x11-proto/inputproto
+ gtk? ( dev-cpp/gtkmm:2.4 )"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ local myeconfargs=(
+ --with-gui=$(use gtk && echo "gtkmm" || echo "x11")
+ )
+ autotools-utils_src_configure
+}