summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFabio Erculiani <lxnay@gentoo.org>2011-01-22 15:35:49 +0000
committerFabio Erculiani <lxnay@gentoo.org>2011-01-22 15:35:49 +0000
commite2fbbc42dd428b8cf8b0ba4c3e19d758194dd761 (patch)
tree7971504eed07097f950f9b8cbebb54c5a321f918 /x11-apps/xinit
parentadd lxdm support, see bug #330355 (diff)
downloadgentoo-2-e2fbbc42dd428b8cf8b0ba4c3e19d758194dd761.tar.gz
gentoo-2-e2fbbc42dd428b8cf8b0ba4c3e19d758194dd761.tar.bz2
gentoo-2-e2fbbc42dd428b8cf8b0ba4c3e19d758194dd761.zip
add lxdm support (changes required in order to load lxdm with --background), see bug #330355
(Portage version: 2.2.0_alpha13/cvs/Linux x86_64)
Diffstat (limited to 'x11-apps/xinit')
-rw-r--r--x11-apps/xinit/ChangeLog8
-rw-r--r--x11-apps/xinit/files/startDM.sh7
2 files changed, 10 insertions, 5 deletions
diff --git a/x11-apps/xinit/ChangeLog b/x11-apps/xinit/ChangeLog
index 97263f8b2372..6decc9c5216b 100644
--- a/x11-apps/xinit/ChangeLog
+++ b/x11-apps/xinit/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for x11-apps/xinit
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-apps/xinit/ChangeLog,v 1.199 2010/12/31 20:27:50 jer Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/x11-apps/xinit/ChangeLog,v 1.200 2011/01/22 15:35:49 lxnay Exp $
+
+ 22 Jan 2011; Fabio Erculiani <lxnay@gentoo.org> files/startDM.sh:
+ add lxdm support (changes required in order to load lxdm with
+ --background), see bug #330355
31 Dec 2010; Jeroen Roovers <jer@gentoo.org> xinit-1.3.0-r1.ebuild:
Stable for HPPA (bug #344827).
diff --git a/x11-apps/xinit/files/startDM.sh b/x11-apps/xinit/files/startDM.sh
index 9775b07ff7a5..ebb7970400b6 100644
--- a/x11-apps/xinit/files/startDM.sh
+++ b/x11-apps/xinit/files/startDM.sh
@@ -1,7 +1,7 @@
#!/bin/sh
-# Copyright 1999-2006 Gentoo Foundation
+# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License, v2
-# $Header: /var/cvsroot/gentoo-x86/x11-apps/xinit/files/startDM.sh,v 1.4 2007/04/05 15:30:19 uberlord Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-apps/xinit/files/startDM.sh,v 1.5 2011/01/22 15:35:49 lxnay Exp $
# We need to source /etc/profile for stuff like $LANG to work
# bug #10190.
@@ -22,9 +22,10 @@ export SVCNAME=xdm
EXEC="$(get_options service)"
NAME="$(get_options name)"
PIDFILE="$(get_options pidfile)"
+START_STOP_ARGS="$(get_options start_stop_args)"
start-stop-daemon --start --exec ${EXEC} \
-${NAME:+--name} ${NAME} ${PIDFILE:+--pidfile} ${PIDFILE} || \
+${NAME:+--name} ${NAME} ${PIDFILE:+--pidfile} ${PIDFILE} ${START_STOP_ARGS} || \
eerror "ERROR: could not start the Display Manager"
# vim:ts=4