summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDonnie Berkholz <spyderous@gentoo.org>2005-10-20 00:45:25 +0000
committerDonnie Berkholz <spyderous@gentoo.org>2005-10-20 00:45:25 +0000
commitcb65bb7016c0361820004c26bd52575a6cf5c0a7 (patch)
tree76d4bacb7f60f793b28ddb765173cf0287a6868b /x11-apps/xinit
parentUpdate SRC_URI to look in 7.0 RC1 location first, then RC0. Also only active ... (diff)
downloadgentoo-2-cb65bb7016c0361820004c26bd52575a6cf5c0a7.tar.gz
gentoo-2-cb65bb7016c0361820004c26bd52575a6cf5c0a7.tar.bz2
gentoo-2-cb65bb7016c0361820004c26bd52575a6cf5c0a7.zip
Bump for 7.0 RC1.
(Portage version: 2.0.53_rc5)
Diffstat (limited to 'x11-apps/xinit')
-rw-r--r--x11-apps/xinit/ChangeLog7
-rw-r--r--x11-apps/xinit/files/digest-xinit-0.99.21
-rw-r--r--x11-apps/xinit/xinit-0.99.2.ebuild37
3 files changed, 44 insertions, 1 deletions
diff --git a/x11-apps/xinit/ChangeLog b/x11-apps/xinit/ChangeLog
index f167605f87cc..6b409cb01042 100644
--- a/x11-apps/xinit/ChangeLog
+++ b/x11-apps/xinit/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-apps/xinit
# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-apps/xinit/ChangeLog,v 1.18 2005/10/19 02:35:36 geoman Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-apps/xinit/ChangeLog,v 1.19 2005/10/20 00:45:23 spyderous Exp $
+
+*xinit-0.99.2 (20 Oct 2005)
+
+ 20 Oct 2005; Donnie Berkholz <spyderous@gentoo.org>; +xinit-0.99.2.ebuild:
+ Bump for 7.0 RC1.
19 Oct 2005; Stephen P. Becker <geoman@gentoo.org>
xinit-0.99.1_pre20050905-r3.ebuild:
diff --git a/x11-apps/xinit/files/digest-xinit-0.99.2 b/x11-apps/xinit/files/digest-xinit-0.99.2
new file mode 100644
index 000000000000..4bd0eecd551d
--- /dev/null
+++ b/x11-apps/xinit/files/digest-xinit-0.99.2
@@ -0,0 +1 @@
+MD5 c1934c751cd949c1a9afa3104a7ef357 xinit-0.99.2.tar.bz2 88529
diff --git a/x11-apps/xinit/xinit-0.99.2.ebuild b/x11-apps/xinit/xinit-0.99.2.ebuild
new file mode 100644
index 000000000000..90ccbfbe6c0d
--- /dev/null
+++ b/x11-apps/xinit/xinit-0.99.2.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-apps/xinit/xinit-0.99.2.ebuild,v 1.1 2005/10/20 00:45:23 spyderous Exp $
+
+# Must be before x-modular eclass is inherited
+#SNAPSHOT="yes"
+
+inherit x-modular
+
+DESCRIPTION="X.Org xinit application"
+KEYWORDS="~amd64 ~arm ~mips ~ppc ~s390 ~sh ~sparc ~x86"
+RDEPEND="x11-libs/libX11"
+DEPEND="${RDEPEND}"
+
+PATCHES="${FILESDIR}/nolisten-tcp-and-black-background.patch
+ ${FILESDIR}/gentoo-startx-customization.patch"
+
+src_unpack() {
+ x-modular_unpack_source
+ x-modular_patch_source
+
+ sed -i -e "s:^XINITDIR.*:XINITDIR = \$(sysconfdir)/X11/xinit:g" ${S}/Makefile.am
+
+ x-modular_reconf_source
+}
+
+src_install() {
+ x-modular_src_install
+ exeinto /etc/X11
+ doexe ${FILESDIR}/chooser.sh ${FILESDIR}/startDM.sh
+ exeinto /etc/X11/Sessions
+ doexe ${FILESDIR}/Xsession
+ exeinto /etc/X11/xinit
+ doexe ${FILESDIR}/xinitrc
+ newinitd ${FILESDIR}/xdm.start xdm
+ newpamd ${FILESDIR}/xserver.pamd xserver
+}