summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomas Chvatal <scarabeus@gentoo.org>2010-03-17 14:32:02 +0000
committerTomas Chvatal <scarabeus@gentoo.org>2010-03-17 14:32:02 +0000
commitda853c7486bbefdf04d1656dfcd170791d56c280 (patch)
tree364d472bc4256d059c3342d750f356f6fa2e39a5 /x11-apps/xdriinfo
parentFix eclassdoc. Add new variable to allow disabling of static-libs useflag. (diff)
downloadgentoo-2-da853c7486bbefdf04d1656dfcd170791d56c280.tar.gz
gentoo-2-da853c7486bbefdf04d1656dfcd170791d56c280.tar.bz2
gentoo-2-da853c7486bbefdf04d1656dfcd170791d56c280.zip
Migrate to xorg-2 eclass. Move to eapi3. Work with eselect-opengl properly.
(Portage version: 2.2_rc65/cvs/Linux x86_64)
Diffstat (limited to 'x11-apps/xdriinfo')
-rw-r--r--x11-apps/xdriinfo/ChangeLog7
-rw-r--r--x11-apps/xdriinfo/xdriinfo-1.0.3.ebuild21
2 files changed, 20 insertions, 8 deletions
diff --git a/x11-apps/xdriinfo/ChangeLog b/x11-apps/xdriinfo/ChangeLog
index 0841f2d1a5aa..8b3229ea30ad 100644
--- a/x11-apps/xdriinfo/ChangeLog
+++ b/x11-apps/xdriinfo/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-apps/xdriinfo
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-apps/xdriinfo/ChangeLog,v 1.46 2010/01/23 18:52:33 scarabeus Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-apps/xdriinfo/ChangeLog,v 1.47 2010/03/17 14:32:02 scarabeus Exp $
+
+ 17 Mar 2010; Tomáš Chvátal <scarabeus@gentoo.org>
+ xdriinfo-1.0.3.ebuild:
+ Migrate to xorg-2 eclass. Move to eapi3. Work with eselect-opengl
+ properly.
23 Jan 2010; Tomáš Chvátal <scarabeus@gentoo.org>
-xdriinfo-1.0.2.ebuild:
diff --git a/x11-apps/xdriinfo/xdriinfo-1.0.3.ebuild b/x11-apps/xdriinfo/xdriinfo-1.0.3.ebuild
index 0ab9ede9af4c..68df1351291b 100644
--- a/x11-apps/xdriinfo/xdriinfo-1.0.3.ebuild
+++ b/x11-apps/xdriinfo/xdriinfo-1.0.3.ebuild
@@ -1,8 +1,11 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-apps/xdriinfo/xdriinfo-1.0.3.ebuild,v 1.9 2010/01/18 19:10:52 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-apps/xdriinfo/xdriinfo-1.0.3.ebuild,v 1.10 2010/03/17 14:32:02 scarabeus Exp $
-inherit x-modular
+EAPI=3
+
+XORG_STATIC="no"
+inherit xorg-2
DESCRIPTION="query configuration information of DRI drivers"
@@ -16,13 +19,17 @@ DEPEND="${RDEPEND}
x11-proto/glproto"
pkg_setup() {
- # Bug #138920
- ewarn "Forcing on xorg-x11 for header sanity..."
OLD_IMPLEM="$(eselect opengl show)"
- eselect opengl set --impl-headers xorg-x11
+
+ if [[ ${OLD_IMPLEM} != xorg-x11 ]]; then
+ # Bug #138920
+ ewarn "Forcing on xorg-x11 for header sanity..."
+ einfo "If compilation fails run:"
+ einfo "# eselect opengl set ${OLD_IMPLEM}"
+ eselect opengl set xorg-x11
+ fi
}
pkg_postinst() {
- echo
- eselect opengl set ${OLD_IMPLEM}
+ [[ ${OLD_IMPLEM} != xorg-x11 ]] && eselect opengl set ${OLD_IMPLEM}
}