summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2012-12-07 18:10:39 +0000
committerMichał Górny <mgorny@gentoo.org>2012-12-07 18:10:39 +0000
commite51f557b896caf0f1d4dd63cc4c2e747c9aac144 (patch)
tree7cbcf0d471582bbddd9f7c467173d31911feba6b /x11-apps/xdm
parentFix malformed file lists. (diff)
downloadgentoo-2-e51f557b896caf0f1d4dd63cc4c2e747c9aac144.tar.gz
gentoo-2-e51f557b896caf0f1d4dd63cc4c2e747c9aac144.tar.bz2
gentoo-2-e51f557b896caf0f1d4dd63cc4c2e747c9aac144.zip
Disable XDM-AUTHENTICATION-1 wrt bug #445662.
(Portage version: 2.2.0_alpha144/cvs/Linux x86_64, signed Manifest commit with key 42B9401D)
Diffstat (limited to 'x11-apps/xdm')
-rw-r--r--x11-apps/xdm/ChangeLog7
-rw-r--r--x11-apps/xdm/xdm-1.1.11-r2.ebuild73
2 files changed, 79 insertions, 1 deletions
diff --git a/x11-apps/xdm/ChangeLog b/x11-apps/xdm/ChangeLog
index f54b41a518ac..e549c2cda66a 100644
--- a/x11-apps/xdm/ChangeLog
+++ b/x11-apps/xdm/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-apps/xdm
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-apps/xdm/ChangeLog,v 1.145 2012/08/20 21:28:34 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-apps/xdm/ChangeLog,v 1.146 2012/12/07 18:10:39 mgorny Exp $
+
+*xdm-1.1.11-r2 (07 Dec 2012)
+
+ 07 Dec 2012; Michał Górny <mgorny@gentoo.org> +xdm-1.1.11-r2.ebuild:
+ Disable XDM-AUTHENTICATION-1 wrt bug #445662.
20 Aug 2012; Michał Górny <mgorny@gentoo.org> xdm-1.1.11-r1.ebuild:
systemd: update the unit to install as display-manager.service.
diff --git a/x11-apps/xdm/xdm-1.1.11-r2.ebuild b/x11-apps/xdm/xdm-1.1.11-r2.ebuild
new file mode 100644
index 000000000000..c8a247107bc2
--- /dev/null
+++ b/x11-apps/xdm/xdm-1.1.11-r2.ebuild
@@ -0,0 +1,73 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-apps/xdm/xdm-1.1.11-r2.ebuild,v 1.1 2012/12/07 18:10:39 mgorny Exp $
+
+EAPI=4
+
+XORG_EAUTORECONF=yes
+
+inherit multilib xorg-2 pam systemd
+
+DEFAULTVT=vt7
+
+DESCRIPTION="X.Org xdm application"
+
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="consolekit ipv6 pam"
+
+RDEPEND="x11-apps/xrdb
+ x11-libs/libXdmcp
+ x11-libs/libXaw
+ >=x11-apps/xinit-1.0.2-r3
+ x11-libs/libXinerama
+ x11-libs/libXmu
+ x11-libs/libX11
+ x11-libs/libXt
+ x11-apps/sessreg
+ x11-apps/xconsole
+ consolekit? ( sys-auth/consolekit )
+ pam? ( virtual/pam )
+ !<sys-apps/systemd-187"
+DEPEND="${RDEPEND}
+ consolekit? ( !=sys-auth/pambase-20101024-r1 )
+ x11-proto/xineramaproto
+ x11-proto/xproto"
+
+pkg_setup() {
+ PATCHES=( "${FILESDIR}"/${PN}-consolekit.patch )
+
+ XORG_CONFIGURE_OPTIONS=(
+ $(use_enable ipv6)
+ $(use_with pam)
+ "$(systemd_with_unitdir)"
+ --with-default-vt=${DEFAULTVT}
+ --with-xdmconfigdir=/etc/X11/xdm
+ $(use_with consolekit)
+ )
+}
+
+src_prepare() {
+ # fedora invented that in -187...
+ sed -i -e 's:^Alias=.*$:Alias=display-manager.service:' \
+ xdm.service.in || die
+
+ # disable XDM-AUTHENTICATION-1 wrt bug #445662.
+ # it causes issue with libreoffice and SDL games (bug #306223).
+ sed -i -e '/authorize/a\
+DisplayManager*authName: MIT-MAGIC-COOKIE-1' \
+ config/xdm-config.cpp || die
+
+ xorg-2_src_prepare
+}
+
+src_install() {
+ xorg-2_src_install
+
+ exeinto /usr/$(get_libdir)/X11/xdm
+ doexe "${FILESDIR}"/Xsession
+
+ use pam && pamd_mimic system-local-login xdm auth account session
+
+ # Keep /var/lib/xdm. This is where authfiles are stored. See #286350.
+ keepdir /var/lib/xdm
+}