summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoshua Baergen <joshuabaergen@gentoo.org>2006-11-14 16:29:25 +0000
committerJoshua Baergen <joshuabaergen@gentoo.org>2006-11-14 16:29:25 +0000
commitda9a54794a024539484560dc937631dc34dfcdf5 (patch)
tree6984cef7e8970a359bd3a50c49da0291fc29fcea /x11-apps/xdm
parentStable on sparc wrt #147570 (diff)
downloadgentoo-2-da9a54794a024539484560dc937631dc34dfcdf5.tar.gz
gentoo-2-da9a54794a024539484560dc937631dc34dfcdf5.tar.bz2
gentoo-2-da9a54794a024539484560dc937631dc34dfcdf5.zip
Version bump for 7.2RC2. Contains minor bugfixes.
(Portage version: 2.1.2_rc1-r6)
Diffstat (limited to 'x11-apps/xdm')
-rw-r--r--x11-apps/xdm/ChangeLog7
-rw-r--r--x11-apps/xdm/files/digest-xdm-1.1.13
-rw-r--r--x11-apps/xdm/xdm-1.1.1.ebuild59
3 files changed, 68 insertions, 1 deletions
diff --git a/x11-apps/xdm/ChangeLog b/x11-apps/xdm/ChangeLog
index 59df7e2969e9..b2269a53ddd0 100644
--- a/x11-apps/xdm/ChangeLog
+++ b/x11-apps/xdm/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-apps/xdm
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-apps/xdm/ChangeLog,v 1.58 2006/10/04 02:05:33 dberkholz Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-apps/xdm/ChangeLog,v 1.59 2006/11/14 16:29:25 joshuabaergen Exp $
+
+*xdm-1.1.1 (14 Nov 2006)
+
+ 14 Nov 2006; Joshua Baergen <joshuabaergen@gentoo.org> +xdm-1.1.1.ebuild:
+ Version bump for 7.2RC2. Contains minor bugfixes.
*xdm-1.1.0 (04 Oct 2006)
diff --git a/x11-apps/xdm/files/digest-xdm-1.1.1 b/x11-apps/xdm/files/digest-xdm-1.1.1
new file mode 100644
index 000000000000..44a78419eefe
--- /dev/null
+++ b/x11-apps/xdm/files/digest-xdm-1.1.1
@@ -0,0 +1,3 @@
+MD5 1bc39006d43b72103bad2c82d0240871 xdm-1.1.1.tar.bz2 381303
+RMD160 269e147e6ec0701683675aa3d607f713205d986b xdm-1.1.1.tar.bz2 381303
+SHA256 7cf3908a181578ac8db1bd125034de9a3bb7e2ab1ea112a19f531801d28c8b08 xdm-1.1.1.tar.bz2 381303
diff --git a/x11-apps/xdm/xdm-1.1.1.ebuild b/x11-apps/xdm/xdm-1.1.1.ebuild
new file mode 100644
index 000000000000..33a16e7214d9
--- /dev/null
+++ b/x11-apps/xdm/xdm-1.1.1.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-apps/xdm/xdm-1.1.1.ebuild,v 1.1 2006/11/14 16:29:25 joshuabaergen Exp $
+
+# Must be before x-modular eclass is inherited
+#SNAPSHOT="yes"
+
+inherit multilib x-modular pam
+
+DEFAULTVT="vt7"
+
+DESCRIPTION="X.Org xdm application"
+
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="xprint ipv6 pam"
+
+RDEPEND="x11-apps/xrdb
+ x11-libs/libXdmcp
+ x11-libs/libXaw
+ >=x11-apps/xinit-1.0.2-r3
+ x11-libs/libXinerama
+ x11-libs/libX11
+ x11-libs/libXt
+ x11-apps/sessreg"
+DEPEND="${RDEPEND}
+ x11-proto/xineramaproto
+ x11-proto/xproto"
+
+PATCHES="${FILESDIR}/wtmp.patch
+ ${FILESDIR}/xwilling-hang.patch"
+
+CONFIGURE_OPTIONS="$(use_enable xprint)
+ $(use_enable ipv6)
+ $(use_with pam)
+ --with-default-vt=${DEFAULTVT}
+ --with-xdmconfigdir=/etc/X11/xdm"
+
+pkg_setup() {
+ if use xprint && ! built_with_use x11-libs/libXaw xprint; then
+ die "Build x11-libs/libXaw with USE=xprint."
+ fi
+}
+
+src_install() {
+ x-modular_src_install
+ exeinto /usr/$(get_libdir)/X11/xdm
+ doexe ${FILESDIR}/Xsession
+ newpamd ${FILESDIR}/xdm.pamd xdm
+}
+
+pkg_preinst() {
+ x-modular_pkg_preinst
+
+ # Check for leftover /usr/lib/X11/xdm symlink
+ if [[ -L "/usr/lib/X11/xdm" ]]; then
+ ewarn "/usr/lib/X11/xdm is a symlink; deleting."
+ rm /usr/lib/X11/xdm
+ fi
+}