summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDonnie Berkholz <spyderous@gentoo.org>2005-12-23 10:36:23 +0000
committerDonnie Berkholz <spyderous@gentoo.org>2005-12-23 10:36:23 +0000
commit1bad507be14f43b28099df097874b01586861088 (patch)
treef14ebc5154b72667beb05738f08eb42604961166 /x11-apps/xclock/xclock-1.0.1.ebuild
parentAdded ~ppc64 (diff)
downloadgentoo-2-1bad507be14f43b28099df097874b01586861088.tar.gz
gentoo-2-1bad507be14f43b28099df097874b01586861088.tar.bz2
gentoo-2-1bad507be14f43b28099df097874b01586861088.zip
Bump for 7.0.
(Portage version: 2.1_pre1)
Diffstat (limited to 'x11-apps/xclock/xclock-1.0.1.ebuild')
-rw-r--r--x11-apps/xclock/xclock-1.0.1.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/x11-apps/xclock/xclock-1.0.1.ebuild b/x11-apps/xclock/xclock-1.0.1.ebuild
new file mode 100644
index 000000000000..25ee0242736d
--- /dev/null
+++ b/x11-apps/xclock/xclock-1.0.1.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-apps/xclock/xclock-1.0.1.ebuild,v 1.1 2005/12/23 10:33:38 spyderous Exp $
+
+# Must be before x-modular eclass is inherited
+#SNAPSHOT="yes"
+
+inherit x-modular
+
+DESCRIPTION="X.Org xclock application"
+KEYWORDS="~amd64 ~arm ~mips ~ppc ~s390 ~sparc ~x86"
+IUSE="xprint"
+RDEPEND="x11-libs/libX11
+ x11-libs/libXrender
+ x11-libs/libXft
+ x11-libs/libxkbfile
+ x11-libs/libXaw"
+DEPEND="${RDEPEND}"
+
+CONFIGURE_OPTIONS="$(use_enable xprint)"
+
+pkg_setup() {
+ if use xprint && ! built_with_use x11-libs/libXaw xprint; then
+ die "Build x11-libs/libXaw with USE=xprint."
+ fi
+}