summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRomain Perier <mrpouet@gentoo.org>2009-10-15 19:40:10 +0000
committerRomain Perier <mrpouet@gentoo.org>2009-10-15 19:40:10 +0000
commite755b1cf626e9c6a3480a9c892c792782e659dd8 (patch)
tree36ba821c98e54afc6330b8e09e244655a69800ba /x11-apps/simple-ccsm
parentbuild even if the user has a deficient system (bug #276439) (diff)
downloadgentoo-2-e755b1cf626e9c6a3480a9c892c792782e659dd8.tar.gz
gentoo-2-e755b1cf626e9c6a3480a9c892c792782e659dd8.tar.bz2
gentoo-2-e755b1cf626e9c6a3480a9c892c792782e659dd8.zip
Version bump.
(Portage version: 2.2_rc46/cvs/Linux x86_64)
Diffstat (limited to 'x11-apps/simple-ccsm')
-rw-r--r--x11-apps/simple-ccsm/ChangeLog8
-rw-r--r--x11-apps/simple-ccsm/simple-ccsm-0.8.4.ebuild33
2 files changed, 40 insertions, 1 deletions
diff --git a/x11-apps/simple-ccsm/ChangeLog b/x11-apps/simple-ccsm/ChangeLog
index b1121c4024d1..243987dce797 100644
--- a/x11-apps/simple-ccsm/ChangeLog
+++ b/x11-apps/simple-ccsm/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for x11-apps/simple-ccsm
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-apps/simple-ccsm/ChangeLog,v 1.7 2009/04/25 16:03:35 ranger Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-apps/simple-ccsm/ChangeLog,v 1.8 2009/10/15 19:40:10 mrpouet Exp $
+
+*simple-ccsm-0.8.4 (15 Oct 2009)
+
+ 15 Oct 2009; Romain Perier <mrpouet@gentoo.org>
+ +simple-ccsm-0.8.4.ebuild:
+ Version bump.
25 Apr 2009; Brent Baude <ranger@gentoo.org> simple-ccsm-0.8.2.ebuild:
Marking simple-ccsm-0.8.2 ~ppc for bug 246804
diff --git a/x11-apps/simple-ccsm/simple-ccsm-0.8.4.ebuild b/x11-apps/simple-ccsm/simple-ccsm-0.8.4.ebuild
new file mode 100644
index 000000000000..1b86bdfd02e0
--- /dev/null
+++ b/x11-apps/simple-ccsm/simple-ccsm-0.8.4.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-apps/simple-ccsm/simple-ccsm-0.8.4.ebuild,v 1.1 2009/10/15 19:40:10 mrpouet Exp $
+
+inherit distutils gnome2-utils
+
+DESCRIPTION="Simplified Compizconfig Settings Manager"
+HOMEPAGE="http://www.compiz.org/"
+SRC_URI="http://releases.compiz.org/${PV}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE="gtk"
+
+RDEPEND="~dev-python/compizconfig-python-${PV}
+ >=dev-python/pygtk-2.10
+ ~x11-apps/ccsm-${PV}"
+
+src_compile() {
+ distutils_src_compile --prefix=/usr
+}
+
+src_install() {
+ distutils_src_install --prefix=/usr
+}
+
+pkg_postinst() {
+ if use gtk; then
+ gnome2_icon_savelist
+ gnome2_icon_cache_update
+ fi
+}