summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkos Chandras <hwoarang@gentoo.org>2013-03-21 21:10:25 +0000
committerMarkos Chandras <hwoarang@gentoo.org>2013-03-21 21:10:25 +0000
commit7b5430f3e46630dad879f260ca72d74096fcfdd6 (patch)
treec3945bc17cb230a47eea824fe30360ed7e27f04f /x11-apps/ardesia/ardesia-1.0.ebuild
parentversion bump (diff)
downloadgentoo-2-7b5430f3e46630dad879f260ca72d74096fcfdd6.tar.gz
gentoo-2-7b5430f3e46630dad879f260ca72d74096fcfdd6.tar.bz2
gentoo-2-7b5430f3e46630dad879f260ca72d74096fcfdd6.zip
Version bump. Bug #415607. Thanks to Marco Clocchiatti <ziapannocchia@gmail.com>
(Portage version: 2.1.11.57/cvs/Linux x86_64, signed Manifest commit with key C2BA7F3C!)
Diffstat (limited to 'x11-apps/ardesia/ardesia-1.0.ebuild')
-rw-r--r--x11-apps/ardesia/ardesia-1.0.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/x11-apps/ardesia/ardesia-1.0.ebuild b/x11-apps/ardesia/ardesia-1.0.ebuild
new file mode 100644
index 000000000000..29889d409a28
--- /dev/null
+++ b/x11-apps/ardesia/ardesia-1.0.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-apps/ardesia/ardesia-1.0.ebuild,v 1.1 2013/03/21 21:10:25 hwoarang Exp $
+
+EAPI=4
+
+HOMEPAGE="http://code.google.com/p/ardesia/"
+SRC_URI="http://ardesia.googlecode.com/files/${P}.tar.bz2"
+DESCRIPTION="Color, record and share free-hand annotations on screen and on network."
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="cwiid"
+
+RDEPEND="dev-libs/atk
+ dev-libs/libsigsegv
+ media-libs/fontconfig
+ media-libs/libpng
+ sci-libs/gsl
+ sys-devel/gettext
+ x11-libs/cairo
+ x11-libs/gtk+:2
+ gnome-extra/libgsf
+ cwiid? ( app-misc/cwiid )"
+DEPEND="${RDEPEND}
+ x11-misc/xdg-utils"
+
+src_install() {
+ emake DESTDIR="${D}" ardesiadocdir="/usr/share/doc/${P}" install || die "make install ardesia failed"
+}
+
+pkg_postinst() {
+ elog "Ardesia requires a Composite Manager, such as Compiz"
+ elog "Metacity with compositing, Kwin, etc in order to run"
+ echo
+}