summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <drac@gentoo.org>2008-02-25 16:35:13 +0000
committerSamuli Suominen <drac@gentoo.org>2008-02-25 16:35:13 +0000
commitd32e61525650db32e00d8fe2b55124716d9a153d (patch)
treeefceaff6daca816213a5469af40f26ae0a2d5234 /x11-apps/amlc/amlc-0.5.1.ebuild
parentEdit qtcurve ebuilds to correctly use current cmake-utils.eclass (diff)
downloadgentoo-2-d32e61525650db32e00d8fe2b55124716d9a153d.tar.gz
gentoo-2-d32e61525650db32e00d8fe2b55124716d9a153d.tar.bz2
gentoo-2-d32e61525650db32e00d8fe2b55124716d9a153d.zip
amd64 stable
(Portage version: 2.1.4.4)
Diffstat (limited to 'x11-apps/amlc/amlc-0.5.1.ebuild')
-rw-r--r--x11-apps/amlc/amlc-0.5.1.ebuild14
1 files changed, 7 insertions, 7 deletions
diff --git a/x11-apps/amlc/amlc-0.5.1.ebuild b/x11-apps/amlc/amlc-0.5.1.ebuild
index c0505c45e45d..07b11f4db130 100644
--- a/x11-apps/amlc/amlc-0.5.1.ebuild
+++ b/x11-apps/amlc/amlc-0.5.1.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-apps/amlc/amlc-0.5.1.ebuild,v 1.4 2007/11/21 15:01:22 drac Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-apps/amlc/amlc-0.5.1.ebuild,v 1.5 2008/02/25 16:35:13 drac Exp $
inherit toolchain-funcs
@@ -10,19 +10,19 @@ SRC_URI="http://amlc.berlios.de/src/${P}.cpp"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="~amd64 x86"
+KEYWORDS="amd64 x86"
IUSE=""
-S="${WORKDIR}"
+S=${WORKDIR}
src_unpack() {
- cp "${DISTDIR}"/${P}.cpp "${S}"
+ cp ${DISTDIR}/${P}.cpp "${S}"
}
src_compile() {
- $(tc-getCXX) ${CXXFLAGS} ${LDFLAGS} "${S}"/${P}.cpp -o amlc || die "build failed."
+ $(tc-getCXX) ${CXXFLAGS} ${LDFLAGS} ${P}.cpp -o ${PN} || die "build failed."
}
src_install() {
- dobin amlc
+ dobin ${PN}
}