summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKonstantin V. Arkhipov <voxus@gentoo.org>2009-07-09 13:44:57 +0000
committerKonstantin V. Arkhipov <voxus@gentoo.org>2009-07-09 13:44:57 +0000
commite28848561579283431c7c58808155182296025d9 (patch)
tree1427ddc0751e7b463bde5ded32c631b179ab9a89 /www-servers
parentUSE vdpau with VIDEO_CARDS=nvidia wrt #262433, thanks to Bob Deblier for repo... (diff)
downloadgentoo-2-e28848561579283431c7c58808155182296025d9.tar.gz
gentoo-2-e28848561579283431c7c58808155182296025d9.tar.bz2
gentoo-2-e28848561579283431c7c58808155182296025d9.zip
* stabilization
(Portage version: 2.2_rc33/cvs/Linux x86_64)
Diffstat (limited to 'www-servers')
-rw-r--r--www-servers/nginx/ChangeLog6
-rw-r--r--www-servers/nginx/nginx-0.6.32.ebuild104
-rw-r--r--www-servers/nginx/nginx-0.6.38.ebuild4
-rw-r--r--www-servers/nginx/nginx-0.7.61.ebuild4
4 files changed, 9 insertions, 109 deletions
diff --git a/www-servers/nginx/ChangeLog b/www-servers/nginx/ChangeLog
index 9977a2ee24fd..95013ef5c188 100644
--- a/www-servers/nginx/ChangeLog
+++ b/www-servers/nginx/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for www-servers/nginx
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-servers/nginx/ChangeLog,v 1.218 2009/06/23 08:51:41 voxus Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-servers/nginx/ChangeLog,v 1.219 2009/07/09 13:44:57 voxus Exp $
+
+ 09 Jul 2009; Konstantin V. Arkhipov <voxus@gentoo.org>
+ -nginx-0.6.32.ebuild, nginx-0.6.38.ebuild, nginx-0.7.61.ebuild:
+ Stabilization.
*nginx-0.6.38 (23 Jun 2009)
diff --git a/www-servers/nginx/nginx-0.6.32.ebuild b/www-servers/nginx/nginx-0.6.32.ebuild
deleted file mode 100644
index 4bfdfa599dd0..000000000000
--- a/www-servers/nginx/nginx-0.6.32.ebuild
+++ /dev/null
@@ -1,104 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-servers/nginx/nginx-0.6.32.ebuild,v 1.2 2008/10/25 17:36:52 voxus Exp $
-
-inherit eutils ssl-cert
-
-DESCRIPTION="Robust, small and high performance http and reverse proxy server"
-
-HOMEPAGE="http://nginx.net/"
-SRC_URI="http://sysoev.ru/nginx/${P}.tar.gz"
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="amd64 ~ppc x86"
-IUSE="addition debug fastcgi flv imap pcre perl ssl status sub webdav zlib"
-
-DEPEND="dev-lang/perl
- pcre? ( >=dev-libs/libpcre-4.2 )
- ssl? ( dev-libs/openssl )
- zlib? ( sys-libs/zlib )
- perl? ( >=dev-lang/perl-5.8 )"
-
-pkg_setup() {
- ebegin "Creating nginx user and group"
- enewgroup nginx
- enewuser nginx -1 -1 /dev/null nginx
- eend ${?}
-}
-
-src_compile() {
- local myconf
-
- # threads support is broken atm.
- #
- # if use threads; then
- # einfo
- # ewarn "threads support is experimental at the moment"
- # ewarn "do not use it on production systems - you've been warned"
- # einfo
- # myconf="${myconf} --with-threads"
- # fi
-
- use addition && myconf="${myconf} --with-http_addition_module"
- use fastcgi || myconf="${myconf} --without-http_fastcgi_module"
- use fastcgi && myconf="${myconf} --with-http_realip_module"
- use flv && myconf="${myconf} --with-http_flv_module"
- use zlib || myconf="${myconf} --without-http_gzip_module"
- use pcre || {
- myconf="${myconf} --without-pcre --without-http_rewrite_module"
- }
- use debug && myconf="${myconf} --with-debug"
- use ssl && myconf="${myconf} --with-http_ssl_module"
- use imap && myconf="${myconf} --with-imap" # pop3/imap4 proxy support
- use perl && myconf="${myconf} --with-http_perl_module"
- use status && myconf="${myconf} --with-http_stub_status_module"
- use webdav && myconf="${myconf} --with-http_dav_module"
- use sub && myconf="${myconf} --with-http_sub_module"
-
- ./configure \
- --prefix=/usr \
- --conf-path=/etc/${PN}/${PN}.conf \
- --http-log-path=/var/log/${PN}/access_log \
- --error-log-path=/var/log/${PN}/error_log \
- --pid-path=/var/run/${PN}.pid \
- --http-client-body-temp-path=/var/tmp/${PN}/client \
- --http-proxy-temp-path=/var/tmp/${PN}/proxy \
- --http-fastcgi-temp-path=/var/tmp/${PN}/fastcgi \
- --with-md5-asm --with-md5=/usr/include \
- --with-sha1-asm --with-sha1=/usr/include \
- ${myconf} || die "configure failed"
-
- emake || die "failed to compile"
-}
-
-src_install() {
- keepdir /var/log/${PN} /var/tmp/${PN}/{client,proxy,fastcgi}
-
- dosbin objs/nginx
- cp "${FILESDIR}"/nginx-r1 "${T}"/nginx
- doinitd "${T}"/nginx
-
- cp "${FILESDIR}"/nginx.conf-r4 conf/nginx.conf
-
- dodir "${ROOT}"/etc/${PN}
- insinto "${ROOT}"/etc/${PN}
- doins conf/*
-
- dodoc CHANGES{,.ru} LICENSE README
-
- use perl && {
- cd "${S}"/objs/src/http/modules/perl/
- einstall DESTDIR="${D}"|| die "failed to install perl stuff"
- }
-}
-
-pkg_postinst() {
- use ssl && {
- if [ ! -f "${ROOT}"/etc/ssl/${PN}/${PN}.key ]; then
- dodir "${ROOT}"/etc/ssl/${PN}
- insinto "${ROOT}"etc/ssl/${PN}/
- insopts -m0644 -o nginx -g nginx
- install_cert /etc/ssl/nginx/nginx
- fi
- }
-}
diff --git a/www-servers/nginx/nginx-0.6.38.ebuild b/www-servers/nginx/nginx-0.6.38.ebuild
index 33333a0e73e5..e35c319d5bf4 100644
--- a/www-servers/nginx/nginx-0.6.38.ebuild
+++ b/www-servers/nginx/nginx-0.6.38.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-servers/nginx/nginx-0.6.38.ebuild,v 1.1 2009/06/23 08:51:41 voxus Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-servers/nginx/nginx-0.6.38.ebuild,v 1.2 2009/07/09 13:44:57 voxus Exp $
inherit eutils ssl-cert
@@ -10,7 +10,7 @@ HOMEPAGE="http://nginx.net/"
SRC_URI="http://sysoev.ru/nginx/${P}.tar.gz"
LICENSE="BSD"
SLOT="0"
-KEYWORDS="~amd64 ~ppc ~x86"
+KEYWORDS="amd64 ~ppc x86"
IUSE="addition debug fastcgi flv imap pcre perl ssl status sub webdav zlib"
DEPEND="dev-lang/perl
diff --git a/www-servers/nginx/nginx-0.7.61.ebuild b/www-servers/nginx/nginx-0.7.61.ebuild
index a0f924c21168..7ba7f77c7725 100644
--- a/www-servers/nginx/nginx-0.7.61.ebuild
+++ b/www-servers/nginx/nginx-0.7.61.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-servers/nginx/nginx-0.7.61.ebuild,v 1.1 2009/06/22 10:06:39 voxus Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-servers/nginx/nginx-0.7.61.ebuild,v 1.2 2009/07/09 13:44:57 voxus Exp $
inherit eutils ssl-cert toolchain-funcs
@@ -10,7 +10,7 @@ HOMEPAGE="http://nginx.net/"
SRC_URI="http://sysoev.ru/nginx/${P}.tar.gz"
LICENSE="BSD"
SLOT="0"
-KEYWORDS="~amd64 ~ppc ~x86 ~x86-fbsd"
+KEYWORDS="amd64 ~ppc x86 ~x86-fbsd"
IUSE="addition debug fastcgi flv imap pcre perl random-index ssl status sub webdav zlib"
DEPEND="dev-lang/perl