summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRafael Martins <rafaelmartins@gentoo.org>2014-07-22 04:26:43 +0000
committerRafael Martins <rafaelmartins@gentoo.org>2014-07-22 04:26:43 +0000
commitd5e7bfe66928eb3b7063894a0a62e5bd32ebbf1c (patch)
tree748f4357535d112a1e1b514e9211e7e51925fae9 /www-servers
parentdrop py2.6 pypy2_0 add py3.4 (diff)
downloadgentoo-2-d5e7bfe66928eb3b7063894a0a62e5bd32ebbf1c.tar.gz
gentoo-2-d5e7bfe66928eb3b7063894a0a62e5bd32ebbf1c.tar.bz2
gentoo-2-d5e7bfe66928eb3b7063894a0a62e5bd32ebbf1c.zip
Version bump. bug #515560
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key )
Diffstat (limited to 'www-servers')
-rw-r--r--www-servers/gunicorn/ChangeLog8
-rw-r--r--www-servers/gunicorn/files/gunicorn-19.0.0-gaiohttp.patch59
-rw-r--r--www-servers/gunicorn/gunicorn-19.0.0.ebuild54
3 files changed, 120 insertions, 1 deletions
diff --git a/www-servers/gunicorn/ChangeLog b/www-servers/gunicorn/ChangeLog
index 782ffd8a1d8f..c5dddf4ec4f4 100644
--- a/www-servers/gunicorn/ChangeLog
+++ b/www-servers/gunicorn/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for www-servers/gunicorn
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-servers/gunicorn/ChangeLog,v 1.35 2014/05/13 00:56:10 rafaelmartins Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-servers/gunicorn/ChangeLog,v 1.36 2014/07/22 04:26:43 rafaelmartins Exp $
+
+*gunicorn-19.0.0 (22 Jul 2014)
+
+ 22 Jul 2014; Rafael G. Martins <rafaelmartins@gentoo.org>
+ +files/gunicorn-19.0.0-gaiohttp.patch, +gunicorn-19.0.0.ebuild:
+ Version bump. bug #515560
*gunicorn-18.0-r1 (13 May 2014)
diff --git a/www-servers/gunicorn/files/gunicorn-19.0.0-gaiohttp.patch b/www-servers/gunicorn/files/gunicorn-19.0.0-gaiohttp.patch
new file mode 100644
index 000000000000..7561ab2f3027
--- /dev/null
+++ b/www-servers/gunicorn/files/gunicorn-19.0.0-gaiohttp.patch
@@ -0,0 +1,59 @@
+From 86f740420cb12cf071f7dc7981330353e258931a Mon Sep 17 00:00:00 2001
+From: Andrew Svetlov <andrew.svetlov@gmail.com>
+Date: Sun, 22 Jun 2014 15:19:27 +0300
+Subject: [PATCH] Don't install gaiohttp if python < 3.3
+
+---
+ setup.py | 18 ++++++++++++++++--
+ 1 file changed, 16 insertions(+), 2 deletions(-)
+
+diff --git a/setup.py b/setup.py
+index be54106..f538734 100644
+--- a/setup.py
++++ b/setup.py
+@@ -5,12 +5,15 @@
+
+
+ import os
+-from setuptools import setup, find_packages, Command
++from setuptools import setup, Command
+ import sys
+
+ from gunicorn import __version__
+
+
++ASYNCIO_COMPAT = sys.version_info >= (3, 3)
++
++
+ CLASSIFIERS = [
+ 'Development Status :: 4 - Beta',
+ 'Environment :: Other Environment',
+@@ -65,6 +68,17 @@ def run(self):
+
+ REQUIREMENTS = []
+
++py_modules = []
++
++for root, folders, files in os.walk('gunicorn'):
++ for f in files:
++ if f.endswith('.py') and (ASYNCIO_COMPAT or f != 'gaiohttp.py'):
++ full = os.path.join(root, f[:-3])
++ parts = full.split(os.path.sep)
++ modname = '.'.join(parts)
++ py_modules.append(modname)
++
++
+ setup(
+ name = 'gunicorn',
+ version = __version__,
+@@ -78,7 +92,7 @@ def run(self):
+
+ classifiers = CLASSIFIERS,
+ zip_safe = False,
+- packages = find_packages(exclude=['examples', 'tests']),
++ py_modules = py_modules,
+ include_package_data = True,
+
+ tests_require = tests_require,
+--
+1.9.3
diff --git a/www-servers/gunicorn/gunicorn-19.0.0.ebuild b/www-servers/gunicorn/gunicorn-19.0.0.ebuild
new file mode 100644
index 000000000000..387f0d4e35bb
--- /dev/null
+++ b/www-servers/gunicorn/gunicorn-19.0.0.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-servers/gunicorn/gunicorn-19.0.0.ebuild,v 1.1 2014/07/22 04:26:43 rafaelmartins Exp $
+
+EAPI="5"
+PYTHON_COMPAT=( python{2_6,2_7,3_3,3_4} pypy pypy2_0 )
+
+inherit distutils-r1
+
+DESCRIPTION="A WSGI HTTP Server for UNIX"
+HOMEPAGE="http://gunicorn.org http://pypi.python.org/pypi/gunicorn"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+IUSE="doc examples test"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="dev-python/setproctitle"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ doc? ( dev-python/sphinx )
+ test? ( dev-python/pytest[${PYTHON_USEDEP}] )"
+
+DOCS="README.rst"
+
+python_prepare() {
+ # these tests requires an already installed version of gunicorn
+ rm tests/test_003-config.py
+
+ sed -ie "s/..\/bin/\/usr\/bin\//" docs/Makefile || die
+
+ epatch "${FILESDIR}/${P}-gaiohttp.patch"
+
+ distutils-r1_python_prepare
+}
+
+python_compile_all() {
+ use doc && emake -C docs html
+}
+
+python_test() {
+ py.test -v || die "Testing failed with ${EPYTHON}"
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/build/html/. )
+
+ distutils-r1_python_install_all
+
+ if use examples; then
+ insinto /usr/share/doc/${P}
+ doins -r examples
+ fi
+}