summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBenedikt Boehm <hollow@gentoo.org>2008-01-07 22:59:25 +0000
committerBenedikt Boehm <hollow@gentoo.org>2008-01-07 22:59:25 +0000
commitcfcc74ffe2e06f687e5685173a5657fc618f303f (patch)
tree5f27ce4bf2cd600bcc21f0ea46a9c242dbc0584f /www-servers
parentmask the evo flag since evolution is masked for this profile (diff)
downloadgentoo-2-cfcc74ffe2e06f687e5685173a5657fc618f303f.tar.gz
gentoo-2-cfcc74ffe2e06f687e5685173a5657fc618f303f.tar.bz2
gentoo-2-cfcc74ffe2e06f687e5685173a5657fc618f303f.zip
fix #204822, #204408, #204409 and #204410
(Portage version: 2.1.4_rc11)
Diffstat (limited to 'www-servers')
-rw-r--r--www-servers/apache/ChangeLog9
-rw-r--r--www-servers/apache/apache-2.2.6-r7.ebuild177
-rw-r--r--www-servers/apache/files/digest-apache-2.2.6-r76
3 files changed, 190 insertions, 2 deletions
diff --git a/www-servers/apache/ChangeLog b/www-servers/apache/ChangeLog
index e496ac8ebfdc..ae5c75cc8da5 100644
--- a/www-servers/apache/ChangeLog
+++ b/www-servers/apache/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for www-servers/apache
-# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-servers/apache/ChangeLog,v 1.45 2007/12/19 21:13:50 hollow Exp $
+# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/www-servers/apache/ChangeLog,v 1.46 2008/01/07 22:59:24 hollow Exp $
+
+*apache-2.2.6-r7 (07 Jan 2008)
+
+ 07 Jan 2008; Benedikt Böhm <hollow@gentoo.org> +apache-2.2.6-r7.ebuild:
+ fix #204822, #204408, #204409 and #204410
19 Dec 2007; Benedikt Böhm <hollow@gentoo.org> -apache-2.2.6.ebuild,
apache-2.2.6-r6.ebuild:
diff --git a/www-servers/apache/apache-2.2.6-r7.ebuild b/www-servers/apache/apache-2.2.6-r7.ebuild
new file mode 100644
index 000000000000..51d29a0f1b76
--- /dev/null
+++ b/www-servers/apache/apache-2.2.6-r7.ebuild
@@ -0,0 +1,177 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-servers/apache/apache-2.2.6-r7.ebuild,v 1.1 2008/01/07 22:59:24 hollow Exp $
+
+# latest gentoo apache files
+GENTOO_PATCHSTAMP="20080107"
+GENTOO_DEVELOPER="hollow"
+
+# IUSE/USE_EXPAND magic
+IUSE_MPMS_FORK="itk peruser prefork"
+IUSE_MPMS_THREAD="event worker"
+
+IUSE_MODULES="actions alias asis auth_basic auth_digest authn_alias authn_anon
+authn_dbd authn_dbm authn_default authn_file authz_dbm authz_default
+authz_groupfile authz_host authz_owner authz_user autoindex cache cern_meta
+charset_lite dav dav_fs dav_lock dbd deflate dir disk_cache dumpio env expires
+ext_filter file_cache filter headers ident imagemap include info log_config
+log_forensic logio mem_cache mime mime_magic negotiation proxy proxy_ajp
+proxy_balancer proxy_connect proxy_ftp proxy_http rewrite setenvif speling
+status unique_id userdir usertrack version vhost_alias"
+
+# inter-module dependencies
+# TODO: this may still be incomplete
+MODULE_DEPENDS="
+ dav_fs:dav
+ dav_lock:dav
+ deflate:filter
+ disk_cache:cache
+ ext_filter:filter
+ file_cache:cache
+ log_forensic:log_config
+ logio:log_config
+ mem_cache:cache
+ mime_magic:mime
+ proxy_ajp:proxy
+ proxy_balancer:proxy
+ proxy_connect:proxy
+ proxy_ftp:proxy
+ proxy_http:proxy
+ usertrack:unique_id
+"
+
+# module<->define mappings
+MODULE_DEFINES="
+ auth_digest:AUTH_DIGEST
+ authnz_ldap:AUTHNZ_LDAP
+ cache:CACHE
+ dav:DAV
+ dav_fs:DAV
+ dav_lock:DAV
+ disk_cache:CACHE
+ file_cache:CACHE
+ info:INFO
+ ldap:LDAP
+ mem_cache:CACHE
+ proxy:PROXY
+ proxy_ajp:PROXY
+ proxy_balancer:PROXY
+ proxy_connect:PROXY
+ proxy_ftp:PROXY
+ proxy_http:PROXY
+ ssl:SSL
+ status:INFO
+ suexec:SUEXEC
+ userdir:USERDIR
+"
+
+MODULE_CRITICAL="
+authz_host
+dir
+mime
+"
+
+inherit apache-2
+
+DESCRIPTION="The Apache Web Server."
+HOMEPAGE="http://httpd.apache.org/"
+
+# some helper scripts are apache-1.1, thus both are here
+LICENSE="Apache-2.0 Apache-1.1"
+SLOT="2"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="sni"
+
+DEPEND="${DEPEND}
+ apache2_modules_deflate? ( sys-libs/zlib )"
+
+RDEPEND="${RDEPEND}
+ apache2_modules_mime? ( app-misc/mime-types )"
+
+src_unpack() {
+ if ! use sni ; then
+ EPATCH_EXCLUDE="04_all_mod_ssl_tls_sni.patch"
+ fi
+
+ apache-2_src_unpack
+}
+
+pkg_postinst() {
+ apache-2_pkg_postinst
+
+ # previous installations of apache-2.2 installed the upstream configuration
+ # files, which shouldn't even have been installed!
+ if has_version '>=www-servers/apache-2.2.4' ; then
+ if [[ -f "${ROOT}"etc/apache2/apache2.conf ]] ; then
+ rm -f "${ROOT}"/etc/apache2/apache2.conf >/dev/null 2>&1
+ fi
+
+ for i in extra original ; do
+ if [[ -d "${ROOT}"/etc/apache2/${i} ]] ; then
+ rm -rf "${ROOT}"/etc/apache2/${i} >/dev/null 2>&1
+ fi
+ done
+ fi
+
+ # note regarding IfDefine changes
+ if has_version '<www-servers/apache-2.2.6-r1' ; then
+ elog
+ elog "When upgrading from versions 2.2.6 or earlier, please be aware"
+ elog "that the define for mod_authnz_ldap has changed from AUTH_LDAP"
+ elog "to AUTHNZ_LDAP. Additionally mod_auth_digest needs to be enabled"
+ elog "with AUTH_DIGEST now."
+ elog
+ fi
+
+ # note the changes regarding DEFAULT_VHOST and SSL_DEFAULT_VHOST
+ if has_version '<www-servers/apache-2.2.4-r7' ; then
+ elog
+ elog "Listen directives have been moved into the default virtual host"
+ elog "configuation. At least DEFAULT_VHOST has been enabled for you"
+ elog "(depending on your USE-flags.)"
+ elog
+ elog "If you disable DEFAULT_VHOST or SSL_DEFAULT_VHOST, there will"
+ elog "be no listening sockets available."
+ elog
+ fi
+
+ # note the user of the config changes
+ if has_version '<www-servers/apache-2.2.4-r5' ; then
+ elog
+ elog "Please make sure that you update your /etc directory."
+ elog "Between the versions, we had to changes some config files"
+ elog "and move some stuff out of the main httpd.conf file to a seperate"
+ elog "modules.d entry."
+ elog
+ elog "Thus please update your /etc directory either via etc-update,"
+ elog "dispatch-conf or conf-update !"
+ elog
+ fi
+
+ # check for dual/upgrade install
+ if has_version '<www-servers/apache-2.2.0' ; then
+ elog
+ elog "When upgrading from versions below 2.2.0 to this version, you"
+ elog "need to rebuild all your modules. Please do so for your modules"
+ elog "to continue working correctly."
+ elog
+ elog "Also note that some configuration directives have been"
+ elog "split into their own files under ${ROOT}etc/apache2/modules.d/"
+ elog "and that some modules, foremost the authentication related ones,"
+ elog "have been renamed."
+ elog
+ elog "Some examples:"
+ elog " - USERDIR is now configureable in ${ROOT}etc/apache2/modules.d/00_mod_userdir.conf."
+ elog
+ elog "For more information on what you may need to change, please"
+ elog "see the overview of changes at:"
+ elog "http://httpd.apache.org/docs/2.2/new_features_2_2.html"
+ elog "and the upgrading guide at:"
+ elog "http://httpd.apache.org/docs/2.2/upgrading.html"
+ elog
+ fi
+
+ # cleanup the vim backup files, placed in /etc/apache2 by the last
+ # patchtarball (gentoo-apache-2.2.4-r7-20070615)
+ rm -f "${ROOT}etc/apache2/modules.d/*.conf~"
+}
diff --git a/www-servers/apache/files/digest-apache-2.2.6-r7 b/www-servers/apache/files/digest-apache-2.2.6-r7
new file mode 100644
index 000000000000..5739cc167335
--- /dev/null
+++ b/www-servers/apache/files/digest-apache-2.2.6-r7
@@ -0,0 +1,6 @@
+MD5 e24a379e1644b39f1fe975c9a236e02f gentoo-apache-2.2.6-r7-20080107.tar.bz2 61536
+RMD160 b08af8e9d840b49685bf7a67243b80dc4e346efa gentoo-apache-2.2.6-r7-20080107.tar.bz2 61536
+SHA256 b2116b2b09ba3a5d4e1130bf7e202cc95312ac5b4f78f8653f15e2842bbbf92f gentoo-apache-2.2.6-r7-20080107.tar.bz2 61536
+MD5 203bea91715064f0c787f6499d33a377 httpd-2.2.6.tar.bz2 4717066
+RMD160 5ae895c6898213e1e3b7e7b02cdfcbe5b36a108f httpd-2.2.6.tar.bz2 4717066
+SHA256 f27cd9df50a2acd9df8f37520f62f6ce51758689d425ead5883e75ff5ed6548c httpd-2.2.6.tar.bz2 4717066