summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThilo Bangert <bangert@gentoo.org>2007-01-09 08:01:31 +0000
committerThilo Bangert <bangert@gentoo.org>2007-01-09 08:01:31 +0000
commitccc14067fed1f64ef9e8e5ea5a697af79a3acfa5 (patch)
tree143ea1c0e481a880dc9543dd893a3d76903289a5 /www-servers
parentStable on ppc64; bug #159846 (diff)
downloadgentoo-2-ccc14067fed1f64ef9e8e5ea5a697af79a3acfa5.tar.gz
gentoo-2-ccc14067fed1f64ef9e8e5ea5a697af79a3acfa5.tar.bz2
gentoo-2-ccc14067fed1f64ef9e8e5ea5a697af79a3acfa5.zip
version bump - elog transition
(Portage version: 2.1.1-r2)
Diffstat (limited to 'www-servers')
-rw-r--r--www-servers/pound/ChangeLog14
-rw-r--r--www-servers/pound/files/digest-pound-2.23
-rw-r--r--www-servers/pound/files/pound-2.2.cfg54
-rw-r--r--www-servers/pound/pound-1.10.ebuild10
-rw-r--r--www-servers/pound/pound-2.0.5.ebuild10
-rw-r--r--www-servers/pound/pound-2.1.ebuild10
-rw-r--r--www-servers/pound/pound-2.2.ebuild59
7 files changed, 143 insertions, 17 deletions
diff --git a/www-servers/pound/ChangeLog b/www-servers/pound/ChangeLog
index d3741ffeae27..4cddde0aac7e 100644
--- a/www-servers/pound/ChangeLog
+++ b/www-servers/pound/ChangeLog
@@ -1,6 +1,16 @@
# ChangeLog for www-servers/pound
-# Copyright 2000-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-servers/pound/ChangeLog,v 1.24 2006/12/10 09:34:17 beu Exp $
+# Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/www-servers/pound/ChangeLog,v 1.25 2007/01/09 08:01:31 bangert Exp $
+
+ 09 Jan 2007; Thilo Bangert <bangert@gentoo.org> pound-1.10.ebuild,
+ pound-2.0.5.ebuild, pound-2.1.ebuild:
+ einfo -> elog transition
+
+*pound-2.2 (08 Jan 2007)
+
+ 08 Jan 2007; Thilo Bangert <bangert@gentoo.org> +files/pound-2.2.cfg,
+ +pound-2.2.ebuild:
+ version bump
10 Dec 2006; Elfyn McBratney <beu@gentoo.org> pound-1.10.ebuild,
pound-2.0.5.ebuild, pound-2.1.ebuild:
diff --git a/www-servers/pound/files/digest-pound-2.2 b/www-servers/pound/files/digest-pound-2.2
new file mode 100644
index 000000000000..30eedca128fc
--- /dev/null
+++ b/www-servers/pound/files/digest-pound-2.2
@@ -0,0 +1,3 @@
+MD5 a94e781ced1b2f3a7f8b8051f4d95713 Pound-2.2.tgz 146076
+RMD160 7b120b1c5bc6d478e01d7d13ea40f712d60d3285 Pound-2.2.tgz 146076
+SHA256 316545c126f11be95deab5fb60d6a26e1aa644f9a8b5972219062ce6521e1491 Pound-2.2.tgz 146076
diff --git a/www-servers/pound/files/pound-2.2.cfg b/www-servers/pound/files/pound-2.2.cfg
new file mode 100644
index 000000000000..664ea53c9edd
--- /dev/null
+++ b/www-servers/pound/files/pound-2.2.cfg
@@ -0,0 +1,54 @@
+## Minimal sample pound.cfg
+##
+## see pound(8) for details
+
+
+######################################################################
+## global options:
+
+User "nobody"
+Group "nobody"
+#RootJail /chroot/pound
+
+## Logging: (goes to syslog by default)
+## 0 no logging
+## 1 normal
+## 2 extended
+## 3 Apache-style (common log format)
+LogLevel 1
+
+## check backend every X secs:
+Alive 30
+
+## use hardware-accelleration card supported by openssl(1):
+#SSLEngine <hw>
+
+
+######################################################################
+## listen, redirect and ... to:
+
+## redirect all requests on port 8888 ("ListenHTTP") to the local webserver see "UrlGroup" below):
+ListenHTTP
+Address 127.0.0.1
+Port 8888
+
+## allow PUT and DELETE also (by default only GET, POST and HEAD)?:
+xHTTP 0
+
+Service
+URL ".*"
+
+BackEnd
+Address 127.0.0.1
+Port 80
+Priority 1
+
+## End Backend
+End
+
+## End Service
+End
+
+## End listener
+End
+
diff --git a/www-servers/pound/pound-1.10.ebuild b/www-servers/pound/pound-1.10.ebuild
index 8de59c051a29..f043d54b8953 100644
--- a/www-servers/pound/pound-1.10.ebuild
+++ b/www-servers/pound/pound-1.10.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2006 Gentoo Foundation
+# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-servers/pound/pound-1.10.ebuild,v 1.3 2006/12/10 09:34:17 beu Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-servers/pound/pound-1.10.ebuild,v 1.4 2007/01/09 08:01:31 bangert Exp $
inherit flag-o-matic
@@ -43,7 +43,7 @@ src_install() {
}
pkg_postinst() {
- einfo "No demo-/sample-configfile is included in the distribution -- read the man-page"
- einfo "for more info."
- einfo "A sample (localhost:8888 -> localhost:80) for gentoo is given in \"/etc/pound.cfg\"."
+ elog "No demo-/sample-configfile is included in the distribution -- read the man-page"
+ elog "for more info."
+ elog "A sample (localhost:8888 -> localhost:80) for gentoo is given in \"/etc/pound.cfg\"."
}
diff --git a/www-servers/pound/pound-2.0.5.ebuild b/www-servers/pound/pound-2.0.5.ebuild
index 9cb2404b8774..cefdd871cac4 100644
--- a/www-servers/pound/pound-2.0.5.ebuild
+++ b/www-servers/pound/pound-2.0.5.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2006 Gentoo Foundation
+# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-servers/pound/pound-2.0.5.ebuild,v 1.6 2006/12/10 09:34:17 beu Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-servers/pound/pound-2.0.5.ebuild,v 1.7 2007/01/09 08:01:31 bangert Exp $
inherit flag-o-matic
@@ -45,9 +45,9 @@ src_install() {
}
pkg_postinst() {
- einfo "No demo-/sample-configfile is included in the distribution -- read the man-page"
- einfo "for more info."
- einfo "A sample (localhost:8888 -> localhost:80) for gentoo is given in \"/etc/pound.cfg\"."
+ elog "No demo-/sample-configfile is included in the distribution -- read the man-page"
+ elog "for more info."
+ elog "A sample (localhost:8888 -> localhost:80) for gentoo is given in \"/etc/pound.cfg\"."
echo
ewarn "You will have to upgrade you configuration file, if you are"
ewarn "upgrading from a version <= 1.9."
diff --git a/www-servers/pound/pound-2.1.ebuild b/www-servers/pound/pound-2.1.ebuild
index 9a9f59eeffcf..6fc098237f2b 100644
--- a/www-servers/pound/pound-2.1.ebuild
+++ b/www-servers/pound/pound-2.1.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2006 Gentoo Foundation
+# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-servers/pound/pound-2.1.ebuild,v 1.2 2006/12/10 09:34:17 beu Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-servers/pound/pound-2.1.ebuild,v 1.3 2007/01/09 08:01:31 bangert Exp $
inherit flag-o-matic
@@ -45,9 +45,9 @@ src_install() {
}
pkg_postinst() {
- einfo "No demo-/sample-configfile is included in the distribution -- read the man-page"
- einfo "for more info."
- einfo "A sample (localhost:8888 -> localhost:80) for gentoo is given in \"/etc/pound.cfg\"."
+ elog "No demo-/sample-configfile is included in the distribution -- read the man-page"
+ elog "for more info."
+ elog "A sample (localhost:8888 -> localhost:80) for gentoo is given in \"/etc/pound.cfg\"."
echo
ewarn "You will have to upgrade you configuration file, if you are"
ewarn "upgrading from a version <= 2.0."
diff --git a/www-servers/pound/pound-2.2.ebuild b/www-servers/pound/pound-2.2.ebuild
new file mode 100644
index 000000000000..eab818b53a37
--- /dev/null
+++ b/www-servers/pound/pound-2.2.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-servers/pound/pound-2.2.ebuild,v 1.1 2007/01/09 08:01:31 bangert Exp $
+
+inherit flag-o-matic
+
+MY_P="${P/p/P}"
+DESCRIPTION="A http/https reverse-proxy and load-balancer."
+SRC_URI="http://www.apsis.ch/pound/${MY_P}.tgz"
+HOMEPAGE="http://www.apsis.ch/pound/"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~mips ~ppc ~sparc ~x86"
+IUSE="ssl dynscaler static"
+
+DEPEND="ssl? ( dev-libs/openssl )"
+
+S="${WORKDIR}/${MY_P}"
+
+src_compile() {
+ use static && append-ldflags -static
+
+ econf \
+ $(use_with ssl) \
+ $(use_enable dynscaler) \
+ || die "configure failed"
+
+ emake || die "compile failed"
+}
+
+src_install() {
+ dodir /usr/sbin
+ cp ${S}/pound ${D}/usr/sbin/
+ cp ${S}/poundctl ${D}/usr/sbin/
+
+ doman pound.8
+ doman poundctl.8
+ dodoc README FAQ
+
+ dodir /etc/init.d
+ newinitd ${FILESDIR}/pound.init-1.9 pound
+
+ insinto /etc
+ newins ${FILESDIR}/pound-2.2.cfg pound.cfg
+}
+
+pkg_postinst() {
+ elog "No demo-/sample-configfile is included in the distribution -"
+ elog "read the man-page for more info."
+ elog "A sample (localhost:8888 -> localhost:80) for gentoo is given in \"/etc/pound.cfg\"."
+ echo
+ ewarn "You will have to upgrade you configuration file, if you are"
+ ewarn "upgrading from a version <= 2.0."
+ echo
+ ewarn "The 'WebDAV' config statement is no longer supported!"
+ ewarn "Please adjust your configuration, if necessary."
+ echo
+}