summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBenedikt Boehm <hollow@gentoo.org>2011-09-30 06:45:06 +0000
committerBenedikt Boehm <hollow@gentoo.org>2011-09-30 06:45:06 +0000
commitc876646046f89870fcbb26d0d496ccaa0afcb17f (patch)
tree4f3ee76b26e84617c16dd2ac362dbd9d2d3eec01 /www-servers
parentVersion bump. (diff)
downloadgentoo-2-c876646046f89870fcbb26d0d496ccaa0afcb17f.tar.gz
gentoo-2-c876646046f89870fcbb26d0d496ccaa0afcb17f.tar.bz2
gentoo-2-c876646046f89870fcbb26d0d496ccaa0afcb17f.zip
version bump wrt #383079
(Portage version: 2.2.0_alpha58/cvs/Linux x86_64)
Diffstat (limited to 'www-servers')
-rw-r--r--www-servers/nginx/ChangeLog8
-rw-r--r--www-servers/nginx/metadata.xml2
-rw-r--r--www-servers/nginx/nginx-1.1.4.ebuild (renamed from www-servers/nginx/nginx-1.0.5.ebuild)121
3 files changed, 71 insertions, 60 deletions
diff --git a/www-servers/nginx/ChangeLog b/www-servers/nginx/ChangeLog
index cf8181f6b134..836e6fa3ba42 100644
--- a/www-servers/nginx/ChangeLog
+++ b/www-servers/nginx/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for www-servers/nginx
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-servers/nginx/ChangeLog,v 1.289 2011/09/09 16:44:14 hollow Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-servers/nginx/ChangeLog,v 1.290 2011/09/30 06:45:06 hollow Exp $
+
+*nginx-1.1.4 (30 Sep 2011)
+
+ 30 Sep 2011; Benedikt Böhm <hollow@gentoo.org> -nginx-1.0.5.ebuild,
+ +nginx-1.1.4.ebuild, metadata.xml:
+ version bump wrt #383079
09 Sep 2011; Benedikt Böhm <hollow@gentoo.org> nginx-1.0.4.ebuild,
nginx-1.0.5.ebuild, nginx-1.0.6.ebuild, nginx-1.1.2.ebuild:
diff --git a/www-servers/nginx/metadata.xml b/www-servers/nginx/metadata.xml
index 9c19bbe4abb2..a8693e07c4b7 100644
--- a/www-servers/nginx/metadata.xml
+++ b/www-servers/nginx/metadata.xml
@@ -40,6 +40,8 @@
ability to cache static files</flag>
<flag name='nginx_modules_http_upload_progress'>This module adds the
ability to track POST upload progress via JSON API</flag>
+ <flag name='nginx_modules_http_mp4'>This module adds pseudo-streaming
+ support for H.264/AAC in MP4 containers.</flag>
<flag name='nginx_modules_mail_imap'>Enables IMAP proxy support</flag>
<flag name='nginx_modules_mail_pop3'>Enables POP3 proxy support</flag>
<flag name='nginx_modules_mail_smtp'>Enables SMTP proxy support</flag>
diff --git a/www-servers/nginx/nginx-1.0.5.ebuild b/www-servers/nginx/nginx-1.1.4.ebuild
index 273289b08a24..488c68dfe258 100644
--- a/www-servers/nginx/nginx-1.0.5.ebuild
+++ b/www-servers/nginx/nginx-1.1.4.ebuild
@@ -1,61 +1,66 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-servers/nginx/nginx-1.0.5.ebuild,v 1.2 2011/09/09 16:44:14 hollow Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-servers/nginx/nginx-1.1.4.ebuild,v 1.1 2011/09/30 06:45:06 hollow Exp $
-EAPI="2"
+EAPI="4"
# Maintainer notes:
# - http_rewrite-independent pcre-support makes sense for matching locations without an actual rewrite
# - any http-module activates the main http-functionality and overrides USE=-http
-# - keep the following 3 requirements in mind before adding external modules:
+# - keep the following requirements in mind before adding external modules:
# * alive upstream
# * sane packaging
# * builds cleanly
+# * does not need a patch for nginx core
# - TODO: test the google-perftools module (included in vanilla tarball)
# prevent perl-module from adding automagic perl DEPENDs
GENTOO_DEPEND_ON_PERL="no"
+# http_uploadprogress (https://github.com/masterzen/nginx-upload-progress-module, BSD-2 license)
+HTTP_UPLOAD_PROGRESS_MODULE_PV="0.8.2"
+HTTP_UPLOAD_PROGRESS_MODULE_P="ngx_upload_progress-${HTTP_UPLOAD_PROGRESS_MODULE_PV}"
+HTTP_UPLOAD_PROGRESS_MODULE_SHA1="8b55a34"
+HTTP_UPLOAD_PROGRESS_MODULE_URI="http://github.com/masterzen/nginx-upload-progress-module/tarball/v${HTTP_UPLOAD_PROGRESS_MODULE_PV}"
+
# http_headers_more (http://github.com/agentzh/headers-more-nginx-module, BSD license)
-HTTP_HEADERS_MORE_MODULE_PV="0.13"
-HTTP_HEADERS_MORE_MODULE_P="ngx-http-headers-more-${HTTP_HEADERS_MORE_MODULE_PV}"
-HTTP_HEADERS_MORE_MODULE_SHA1="9508330"
+HTTP_HEADERS_MORE_MODULE_PV="0.15"
+HTTP_HEADERS_MORE_MODULE_P="ngx_http_headers_more-${HTTP_HEADERS_MORE_MODULE_PV}"
+HTTP_HEADERS_MORE_MODULE_SHA1="137855d"
+HTTP_HEADERS_MORE_MODULE_URI="http://github.com/agentzh/headers-more-nginx-module/tarball/v${HTTP_HEADERS_MORE_MODULE_PV}"
# http_push (http://pushmodule.slact.net/, MIT license)
HTTP_PUSH_MODULE_PV="0.692"
HTTP_PUSH_MODULE_P="nginx_http_push_module-${HTTP_PUSH_MODULE_PV}"
+HTTP_PUSH_MODULE_URI="http://pushmodule.slact.net/downloads/${HTTP_PUSH_MODULE_P}.tar.gz"
# http_cache_purge (http://labs.frickle.com/nginx_ngx_cache_purge/, BSD-2 license)
HTTP_CACHE_PURGE_MODULE_PV="1.3"
HTTP_CACHE_PURGE_MODULE_P="ngx_cache_purge-${HTTP_CACHE_PURGE_MODULE_PV}"
+HTTP_CACHE_PURGE_MODULE_URI="http://labs.frickle.com/files/${HTTP_CACHE_PURGE_MODULE_P}.tar.gz"
# HTTP Upload module from Valery Kholodkov
# (http://www.grid.net.ru/nginx/upload.en.html, BSD license)
HTTP_UPLOAD_MODULE_PV="2.2.0"
HTTP_UPLOAD_MODULE_P="nginx_upload_module-${HTTP_UPLOAD_MODULE_PV}"
-
-# ey-balancer/maxconn module (https://github.com/ry/nginx-ey-balancer, as-is)
-HTTP_EY_BALANCER_MODULE_PV="0.0.6"
-HTTP_EY_BALANCER_MODULE_P="nginx-ey-balancer-${HTTP_EY_BALANCER_MODULE_PV}"
-HTTP_EY_BALANCER_MODULE_SHA1="d373670"
+HTTP_UPLOAD_MODULE_URI="http://www.grid.net.ru/nginx/download/${HTTP_UPLOAD_MODULE_P}.tar.gz"
# http_slowfs_cache (http://labs.frickle.com/nginx_ngx_slowfs_cache/, BSD-2 license)
HTTP_SLOWFS_CACHE_MODULE_PV="1.6"
HTTP_SLOWFS_CACHE_MODULE_P="ngx_slowfs_cache-${HTTP_SLOWFS_CACHE_MODULE_PV}"
+HTTP_SLOWFS_CACHE_MODULE_URI="http://labs.frickle.com/files/${HTTP_SLOWFS_CACHE_MODULE_P}.tar.gz"
inherit eutils ssl-cert toolchain-funcs perl-module flag-o-matic
DESCRIPTION="Robust, small and high performance http and reverse proxy server"
-HOMEPAGE="http://nginx.net/
- http://pushmodule.slact.net/
- http://labs.frickle.com/nginx_ngx_cache_purge/"
-SRC_URI="http://sysoev.ru/nginx/${P}.tar.gz
- nginx_modules_http_headers_more? ( http://github.com/agentzh/headers-more-nginx-module/tarball/v${HTTP_HEADERS_MORE_MODULE_PV} -> ${HTTP_HEADERS_MORE_MODULE_P}.tar.gz )
- nginx_modules_http_push? ( http://pushmodule.slact.net/downloads/${HTTP_PUSH_MODULE_P}.tar.gz )
- nginx_modules_http_cache_purge? ( http://labs.frickle.com/files/${HTTP_CACHE_PURGE_MODULE_P}.tar.gz )
- nginx_modules_http_upload? ( http://www.grid.net.ru/nginx/download/${HTTP_UPLOAD_MODULE_P}.tar.gz )
- nginx_modules_http_ey_balancer? ( https://github.com/ry/nginx-ey-balancer/tarball/v${HTTP_EY_BALANCER_MODULE_PV} -> ${HTTP_EY_BALANCER_MODULE_P}.tar.gz )
- nginx_modules_http_slowfs_cache? ( http://labs.frickle.com/files/${HTTP_SLOWFS_CACHE_MODULE_P}.tar.gz )"
+HOMEPAGE="http://nginx.org"
+SRC_URI="http://nginx.org/download/${P}.tar.gz
+ nginx_modules_http_upload_progress? ( ${HTTP_UPLOAD_PROGRESS_MODULE_URI} -> ${HTTP_UPLOAD_PROGRESS_MODULE_P}.tar.gz )
+ nginx_modules_http_headers_more? ( ${HTTP_HEADERS_MORE_MODULE_URI} -> ${HTTP_HEADERS_MORE_MODULE_P}.tar.gz )
+ nginx_modules_http_push? ( ${HTTP_PUSH_MODULE_URI} )
+ nginx_modules_http_cache_purge? ( ${HTTP_CACHE_PURGE_MODULE_URI} )
+ nginx_modules_http_upload? ( ${HTTP_UPLOAD_MODULE_URI} )
+ nginx_modules_http_slowfs_cache? ( ${HTTP_SLOWFS_CACHE_MODULE_URI} )"
LICENSE="as-is BSD BSD-2 GPL-2 MIT"
SLOT="0"
@@ -65,10 +70,16 @@ NGINX_MODULES_STD="access auth_basic autoindex browser charset empty_gif fastcgi
geo gzip limit_req limit_zone map memcached proxy referer rewrite scgi ssi
split_clients upstream_ip_hash userid uwsgi"
NGINX_MODULES_OPT="addition dav degradation flv geoip gzip_static image_filter
-perl random_index realip secure_link stub_status sub xslt"
+mp4 perl random_index realip secure_link stub_status sub xslt"
NGINX_MODULES_MAIL="imap pop3 smtp"
-NGINX_MODULES_3RD="http_cache_purge http_headers_more http_passenger http_push
-http_upload http_ey_balancer http_slowfs_cache"
+NGINX_MODULES_3RD="
+ http_upload_progress
+ http_headers_more
+ http_passenger
+ http_push
+ http_cache_purge
+ http_upload
+ http_slowfs_cache"
IUSE="aio debug +http +http-cache ipv6 libatomic +pcre ssl vim-syntax"
@@ -128,7 +139,7 @@ pkg_setup() {
ebegin "Creating nginx user and group"
enewgroup ${PN}
enewuser ${PN} -1 -1 -1 ${PN}
- eend ${?}
+ eend $?
if use libatomic; then
ewarn "GCC 4.1+ features built-in atomic operations."
@@ -151,70 +162,66 @@ pkg_setup() {
src_prepare() {
sed -i 's/ make/ \\$(MAKE)/' "${S}"/auto/lib/perl/make
-
- if use nginx_modules_http_ey_balancer; then
- epatch "${FILESDIR}"/nginx-0.8.32-ey-balancer.patch
- fi
}
src_configure() {
local myconf= http_enabled= mail_enabled=
- use aio && myconf="${myconf} --with-file-aio --with-aio_module"
- use debug && myconf="${myconf} --with-debug"
- use ipv6 && myconf="${myconf} --with-ipv6"
- use libatomic && myconf="${myconf} --with-libatomic"
- use pcre && myconf="${myconf} --with-pcre"
+ use aio && myconf+=" --with-file-aio --with-aio_module"
+ use debug && myconf+=" --with-debug"
+ use ipv6 && myconf+=" --with-ipv6"
+ use libatomic && myconf+=" --with-libatomic"
+ use pcre && myconf+=" --with-pcre"
# HTTP modules
for mod in $NGINX_MODULES_STD; do
if use nginx_modules_http_${mod}; then
http_enabled=1
else
- myconf="${myconf} --without-http_${mod}_module"
+ myconf+=" --without-http_${mod}_module"
fi
done
for mod in $NGINX_MODULES_OPT; do
if use nginx_modules_http_${mod}; then
http_enabled=1
- myconf="${myconf} --with-http_${mod}_module"
+ myconf+=" --with-http_${mod}_module"
fi
done
if use nginx_modules_http_fastcgi; then
- myconf="${myconf} --with-http_realip_module"
+ myconf+=" --with-http_realip_module"
fi
# third-party modules
+ if use nginx_modules_http_upload_progress; then
+ http_enabled=1
+ myconf+=" --add-module=${WORKDIR}/masterzen-nginx-upload-progress-module-${HTTP_UPLOAD_PROGRESS_MODULE_SHA1}"
+ fi
+
if use nginx_modules_http_headers_more; then
http_enabled=1
- myconf="${myconf} --add-module=${WORKDIR}/agentzh-headers-more-nginx-module-${HTTP_HEADERS_MORE_MODULE_SHA1}"
+ myconf+=" --add-module=${WORKDIR}/agentzh-headers-more-nginx-module-${HTTP_HEADERS_MORE_MODULE_SHA1}"
fi
if use nginx_modules_http_push; then
http_enabled=1
- myconf="${myconf} --add-module=${WORKDIR}/${HTTP_PUSH_MODULE_P}"
+ myconf+=" --add-module=${WORKDIR}/${HTTP_PUSH_MODULE_P}"
fi
if use nginx_modules_http_cache_purge; then
http_enabled=1
- myconf="${myconf} --add-module=${WORKDIR}/${HTTP_CACHE_PURGE_MODULE_P}"
+ myconf+=" --add-module=${WORKDIR}/${HTTP_CACHE_PURGE_MODULE_P}"
fi
if use nginx_modules_http_upload; then
http_enabled=1
- myconf="${myconf} --add-module=${WORKDIR}/${HTTP_UPLOAD_MODULE_P}"
- fi
-
- if use nginx_modules_http_ey_balancer; then
- http_enabled=1
- myconf="${myconf} --add-module=${WORKDIR}/ry-nginx-ey-balancer-${HTTP_EY_BALANCER_MODULE_SHA1}"
+ myconf+=" --add-module=${WORKDIR}/${HTTP_UPLOAD_MODULE_P}"
fi
if use nginx_modules_http_slowfs_cache; then
http_enabled=1
- myconf="${myconf} --add-module=${WORKDIR}/${HTTP_SLOWFS_CACHE_MODULE_P}"
+ myconf+=" --add-module=${WORKDIR}/${HTTP_SLOWFS_CACHE_MODULE_P}"
fi
if use http || use http-cache; then
@@ -222,10 +229,10 @@ src_configure() {
fi
if [ $http_enabled ]; then
- use http-cache || myconf="${myconf} --without-http-cache"
- use ssl && myconf="${myconf} --with-http_ssl_module"
+ use http-cache || myconf+=" --without-http-cache"
+ use ssl && myconf+=" --with-http_ssl_module"
else
- myconf="${myconf} --without-http --without-http-cache"
+ myconf+=" --without-http --without-http-cache"
fi
# MAIL modules
@@ -233,18 +240,18 @@ src_configure() {
if use nginx_modules_mail_${mod}; then
mail_enabled=1
else
- myconf="${myconf} --without-mail_${mod}_module"
+ myconf+=" --without-mail_${mod}_module"
fi
done
if [ $mail_enabled ]; then
- myconf="${myconf} --with-mail"
- use ssl && myconf="${myconf} --with-mail_ssl_module"
+ myconf+=" --with-mail"
+ use ssl && myconf+=" --with-mail_ssl_module"
fi
# custom modules
for mod in $NGINX_ADD_MODULES; do
- myconf="${myconf} --add-module=${mod}"
+ myconf+=" --add-module=${mod}"
done
# https://bugs.gentoo.org/286772
@@ -278,6 +285,7 @@ src_compile() {
src_install() {
keepdir /var/log/${PN} /var/tmp/${PN}/{client,proxy,fastcgi,scgi,uwsgi}
+ keepdir /var/www/localhost/htdocs
dosbin objs/nginx
newinitd "${FILESDIR}"/nginx.init-r2 nginx
@@ -317,11 +325,6 @@ src_install() {
dodoc "${WORKDIR}"/${HTTP_UPLOAD_MODULE_P}/{Changelog,README}
fi
- if use nginx_modules_http_ey_balancer; then
- docinto ${HTTP_EY_BALANCER_MODULE_P}
- dodoc "${WORKDIR}"/ry-nginx-ey-balancer-${HTTP_EY_BALANCER_MODULE_SHA1}/README
- fi
-
if use nginx_modules_http_slowfs_cache; then
docinto ${HTTP_SLOWFS_CACHE_MODULE_P}
dodoc "${WORKDIR}"/${HTTP_SLOWFS_CACHE_MODULE_P}/{CHANGES,README}