summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Matthijs <axxo@gentoo.org>2005-07-18 23:59:33 +0000
committerThomas Matthijs <axxo@gentoo.org>2005-07-18 23:59:33 +0000
commitc28f19c11bd58be33c0c17a533d9c9f39a4c8d9e (patch)
tree6fc063bf16409488426631372e6f1850ec528d25 /www-servers
parentadd mozcalendar support (diff)
downloadgentoo-2-c28f19c11bd58be33c0c17a533d9c9f39a4c8d9e.tar.gz
gentoo-2-c28f19c11bd58be33c0c17a533d9c9f39a4c8d9e.tar.bz2
gentoo-2-c28f19c11bd58be33c0c17a533d9c9f39a4c8d9e.zip
style fix
(Portage version: 2.0.51.22-r1)
Diffstat (limited to 'www-servers')
-rw-r--r--www-servers/orion/files/digest-orion-2.0.11
-rw-r--r--www-servers/orion/files/digest-orion-2.0.21
-rw-r--r--www-servers/orion/orion-2.0.1.ebuild135
-rw-r--r--www-servers/orion/orion-2.0.2.ebuild135
-rw-r--r--www-servers/orion/orion-2.0.5.ebuild6
5 files changed, 3 insertions, 275 deletions
diff --git a/www-servers/orion/files/digest-orion-2.0.1 b/www-servers/orion/files/digest-orion-2.0.1
deleted file mode 100644
index 924ed52ca3b4..000000000000
--- a/www-servers/orion/files/digest-orion-2.0.1
+++ /dev/null
@@ -1 +0,0 @@
-MD5 05c1b4fc84fbb7021d8d314de94ddc35 orion2.0.1.zip 7204675
diff --git a/www-servers/orion/files/digest-orion-2.0.2 b/www-servers/orion/files/digest-orion-2.0.2
deleted file mode 100644
index b8cb9f179264..000000000000
--- a/www-servers/orion/files/digest-orion-2.0.2
+++ /dev/null
@@ -1 +0,0 @@
-MD5 0bc33958ecee3684c5c92a4739bf1d85 orion2.0.2.zip 7125959
diff --git a/www-servers/orion/orion-2.0.1.ebuild b/www-servers/orion/orion-2.0.1.ebuild
deleted file mode 100644
index d7a3a10d01f5..000000000000
--- a/www-servers/orion/orion-2.0.1.ebuild
+++ /dev/null
@@ -1,135 +0,0 @@
-# Copyright 1999-2005 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-servers/orion/orion-2.0.1.ebuild,v 1.5 2005/07/09 17:52:44 swegener Exp $
-
-inherit eutils java-pkg
-
-S=${WORKDIR}/${PN}
-
-At=${PN}${PV}.zip
-
-DESCRIPTION="Orion EJB/J2EE application webserver"
-SRC_URI="http://www.orionserver.com/distributions/${At}"
-HOMEPAGE="http://www.orionserver.com/"
-KEYWORDS="x86 ppc sparc"
-LICENSE="ORIONSERVER"
-SLOT="0"
-DEPEND=">=virtual/jdk-1.3
- app-arch/unzip"
-IUSE=""
-
-src_unpack() {
- unpack ${A}
- cd ${S}
- epatch ${FILESDIR}/${PV}/${PV}-gentoo.patch
-}
-
-src_install() {
- # CREATE DIRECTORIES
- diropts -m0775
- dodir /opt/${PN}
- dodir /opt/${PN}/config
- dodir /opt/${PN}/sbin
- dodir /var/log/${PN}
-
- cd ${S}
-
- # INSTALL STARTUP SCRIPTS
- insinto /opt/orion/sbin
- insopts -m0750
- doins ${FILESDIR}/${PV}/start_orion.sh
- doins ${FILESDIR}/${PV}/stop_orion.sh
-
- cp -a ${FILESDIR}/${PV}/orion.init ${S}/orion
- insinto /etc/init.d
- insopts -m0750
- doins ${S}/orion
-
- cp -a ${FILESDIR}/${PV}/orion.conf ${S}/orion
- insinto /etc/conf.d
- insopts -m0750
- doins ${S}/orion
-
- # CREATE DUMMY LOG & PERSISTENCE DIR
- dodir /var/log/${PN}
- dodir /opt/${PN}/persistence
-
- keepdir /var/log/${PN}
- keepdir /opt/${PN}/persistence
-
- # INSTALL EXTRA FILES
- local dirs="applications database default-web-app demo lib persistence autoupdate.properties"
- for i in $dirs ; do
- cp -a ${i} ${D}/opt/${PN}/
- done
-
- # INSTALL APP CONFIG
- cd ${S}/config
- local dirs="application.xml data-sources.xml database-schemas default-web-site.xml global-web-application.xml jms.xml mime.types principals.xml rmi.xml server.xml"
- for i in $dirs ; do
- cp -a ${i} ${D}/opt/${PN}/config
- done
-
- # INSTALL JARS
- cd ${S}
- for i in `ls *.jar` ; do
- java-pkg_dojar $i
- done
-
- # LINK IN SDK TOOLS.JAR
- dosym ${JAVA_HOME}/lib/tools.jar /usr/share/${PN}/lib/tools.jar
-
- # INSTALL DOCS
- dodoc Readme.txt changes.txt
-}
-
-pkg_preinst() {
- enewgroup orion
- enewuser orion -1 /bin/bash /opt/orion orion
- chown -R orion:orion ${IMAGE}/opt/${PN}
- chown -R orion:orion ${IMAGE}/var/log/${PN}
- chown orion:orion ${IMAGE}/etc/conf.d/orion
-}
-
-pkg_postinst() {
- einfo
- einfo " NOTICE!"
- einfo " User and group 'orion' have been added."
- einfo " Please set a password for the user account 'orion'"
- einfo " if you have not done so already."
- einfo
- einfo
- einfo " FILE LOCATIONS:"
- einfo " 1. Orion home directory: /opt/orion"
- einfo " Contains application data, configuration files."
- einfo " 2. Runtime settings: /etc/conf.d/orion"
- einfo " Contains CLASSPATH and JDK settings."
- einfo " 3. Logs: /var/log/orion/"
- einfo " 4. Executables, libraries: /usr/share/${PN}/"
- einfo
- einfo
- einfo " STARTING AND STOPPING ORION:"
- einfo " /etc/init.d/orion start"
- einfo " /etc/init.d/orion stop"
- einfo " /etc/init.d/orion restart"
- einfo
- einfo
- einfo " NETWORK CONFIGURATION:"
- einfo " By default, Orion runs on port 8080. You can change this"
- einfo " value by editing /opt/orion/config/default-web-site.xml."
- einfo
- einfo " To test Orion while it's running, point your web browser to:"
- einfo " http://localhost:8080/"
- einfo
- einfo
- einfo " APPLICATION DEPLOYMENT:"
- einfo " To set an administrative password, execute the following"
- einfo " commands as user 'orion':"
- einfo " \$ java -jar /usr/share/${PN}/lib/orion.jar -install"
- einfo
- einfo
- einfo " BUGS:"
- einfo " Please file any bugs at http://bugs.gentoo.org/ or else it"
- einfo " may not get seen. Thank you."
- einfo
-}
diff --git a/www-servers/orion/orion-2.0.2.ebuild b/www-servers/orion/orion-2.0.2.ebuild
deleted file mode 100644
index 5deb21220f6f..000000000000
--- a/www-servers/orion/orion-2.0.2.ebuild
+++ /dev/null
@@ -1,135 +0,0 @@
-# Copyright 1999-2005 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-servers/orion/orion-2.0.2.ebuild,v 1.5 2005/07/09 17:52:44 swegener Exp $
-
-inherit eutils java-pkg
-
-S=${WORKDIR}/${PN}
-
-At=${PN}${PV}.zip
-
-DESCRIPTION="Orion EJB/J2EE application webserver"
-SRC_URI="http://www.orionserver.com/distributions/${At}"
-HOMEPAGE="http://www.orionserver.com/"
-KEYWORDS="~x86 ~ppc ~sparc"
-LICENSE="ORIONSERVER"
-SLOT="0"
-DEPEND=">=virtual/jdk-1.3
- app-arch/unzip"
-IUSE=""
-
-src_unpack() {
- unpack ${A}
- cd ${S}
- epatch ${FILESDIR}/${PV}/${PV}-gentoo.patch
-}
-
-src_install() {
- # CREATE DIRECTORIES
- diropts -m0775
- dodir /opt/${PN}
- dodir /opt/${PN}/config
- dodir /opt/${PN}/sbin
- dodir /var/log/${PN}
-
- cd ${S}
-
- # INSTALL STARTUP SCRIPTS
- insinto /opt/orion/sbin
- insopts -m0750
- doins ${FILESDIR}/${PV}/start_orion.sh
- doins ${FILESDIR}/${PV}/stop_orion.sh
-
- cp -a ${FILESDIR}/${PV}/orion.init ${S}/orion
- insinto /etc/init.d
- insopts -m0750
- doins ${S}/orion
-
- cp -a ${FILESDIR}/${PV}/orion.conf ${S}/orion
- insinto /etc/conf.d
- insopts -m0750
- doins ${S}/orion
-
- # CREATE DUMMY LOG & PERSISTENCE DIR
- dodir /var/log/${PN}
- dodir /opt/${PN}/persistence
-
- keepdir /var/log/${PN}
- keepdir /opt/${PN}/persistence
-
- # INSTALL EXTRA FILES
- local dirs="applications database default-web-app demo lib persistence autoupdate.properties"
- for i in $dirs ; do
- cp -a ${i} ${D}/opt/${PN}/
- done
-
- # INSTALL APP CONFIG
- cd ${S}/config
- local dirs="application.xml data-sources.xml database-schemas default-web-site.xml global-web-application.xml jms.xml mime.types principals.xml rmi.xml server.xml"
- for i in $dirs ; do
- cp -a ${i} ${D}/opt/${PN}/config
- done
-
- # INSTALL JARS
- cd ${S}
- for i in `ls *.jar` ; do
- java-pkg_dojar $i
- done
-
- # LINK IN SDK TOOLS.JAR
- dosym ${JAVA_HOME}/lib/tools.jar /usr/share/${PN}/lib/tools.jar
-
- # INSTALL DOCS
- dodoc Readme.txt changes.txt
-}
-
-pkg_preinst() {
- enewgroup orion
- enewuser orion -1 /bin/bash /opt/orion orion
- chown -R orion:orion ${IMAGE}/opt/${PN}
- chown -R orion:orion ${IMAGE}/var/log/${PN}
- chown orion:orion ${IMAGE}/etc/conf.d/orion
-}
-
-pkg_postinst() {
- einfo
- einfo " NOTICE!"
- einfo " User and group 'orion' have been added."
- einfo " Please set a password for the user account 'orion'"
- einfo " if you have not done so already."
- einfo
- einfo
- einfo " FILE LOCATIONS:"
- einfo " 1. Orion home directory: /opt/orion"
- einfo " Contains application data, configuration files."
- einfo " 2. Runtime settings: /etc/conf.d/orion"
- einfo " Contains CLASSPATH and JDK settings."
- einfo " 3. Logs: /var/log/orion/"
- einfo " 4. Executables, libraries: /usr/share/${PN}/"
- einfo
- einfo
- einfo " STARTING AND STOPPING ORION:"
- einfo " /etc/init.d/orion start"
- einfo " /etc/init.d/orion stop"
- einfo " /etc/init.d/orion restart"
- einfo
- einfo
- einfo " NETWORK CONFIGURATION:"
- einfo " By default, Orion runs on port 8080. You can change this"
- einfo " value by editing /opt/orion/config/default-web-site.xml."
- einfo
- einfo " To test Orion while it's running, point your web browser to:"
- einfo " http://localhost:8080/"
- einfo
- einfo
- einfo " APPLICATION DEPLOYMENT:"
- einfo " To set an administrative password, execute the following"
- einfo " commands as user 'orion':"
- einfo " \$ java -jar /usr/share/${PN}/lib/orion.jar -install"
- einfo
- einfo
- einfo " BUGS:"
- einfo " Please file any bugs at http://bugs.gentoo.org/ or else it"
- einfo " may not get seen. Thank you."
- einfo
-}
diff --git a/www-servers/orion/orion-2.0.5.ebuild b/www-servers/orion/orion-2.0.5.ebuild
index f745dcecbfb5..328905632963 100644
--- a/www-servers/orion/orion-2.0.5.ebuild
+++ b/www-servers/orion/orion-2.0.5.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-servers/orion/orion-2.0.5.ebuild,v 1.5 2005/07/09 17:52:44 swegener Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-servers/orion/orion-2.0.5.ebuild,v 1.6 2005/07/18 23:59:33 axxo Exp $
inherit eutils java-pkg
@@ -11,7 +11,7 @@ At=${PN}${PV}.zip
DESCRIPTION="Orion EJB/J2EE application webserver"
SRC_URI="http://www.orionserver.com/distributions/${At}"
HOMEPAGE="http://www.orionserver.com/"
-KEYWORDS="~x86 ~ppc ~sparc ~amd64"
+KEYWORDS="~amd64 ~ppc ~sparc x86"
LICENSE="ORIONSERVER"
SLOT="0"
DEPEND=">=virtual/jdk-1.3
@@ -72,7 +72,7 @@ src_install() {
# INSTALL JARS
cd ${S}
- for i in `ls *.jar` ; do
+ for i in *.jar ; do
java-pkg_dojar $i
done