summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBenedikt Boehm <hollow@gentoo.org>2009-07-29 08:13:35 +0000
committerBenedikt Boehm <hollow@gentoo.org>2009-07-29 08:13:35 +0000
commita8e92ab968bc7248f87b8af28a1741332e99cffb (patch)
treeb1189dd747a0f33bcbe08d6be8c83cc966af0562 /www-servers
parentversion bump (diff)
downloadgentoo-2-a8e92ab968bc7248f87b8af28a1741332e99cffb.tar.gz
gentoo-2-a8e92ab968bc7248f87b8af28a1741332e99cffb.tar.bz2
gentoo-2-a8e92ab968bc7248f87b8af28a1741332e99cffb.zip
version bump
(Portage version: 2.2_rc33/cvs/Linux i686)
Diffstat (limited to 'www-servers')
-rw-r--r--www-servers/apache/ChangeLog7
-rw-r--r--www-servers/apache/apache-2.2.12.ebuild102
2 files changed, 108 insertions, 1 deletions
diff --git a/www-servers/apache/ChangeLog b/www-servers/apache/ChangeLog
index 09e30fd3fe2c..4bdecbf48f06 100644
--- a/www-servers/apache/ChangeLog
+++ b/www-servers/apache/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for www-servers/apache
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-servers/apache/ChangeLog,v 1.115 2009/07/24 18:38:38 hollow Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-servers/apache/ChangeLog,v 1.116 2009/07/29 08:13:35 hollow Exp $
+
+*apache-2.2.12 (29 Jul 2009)
+
+ 29 Jul 2009; Benedikt Böhm <hollow@gentoo.org> +apache-2.2.12.ebuild:
+ version bump
*apache-2.2.11-r3 (24 Jul 2009)
diff --git a/www-servers/apache/apache-2.2.12.ebuild b/www-servers/apache/apache-2.2.12.ebuild
new file mode 100644
index 000000000000..ee6bbe90c0cc
--- /dev/null
+++ b/www-servers/apache/apache-2.2.12.ebuild
@@ -0,0 +1,102 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-servers/apache/apache-2.2.12.ebuild,v 1.1 2009/07/29 08:13:35 hollow Exp $
+
+# latest gentoo apache files
+GENTOO_PATCHSTAMP="20090729"
+GENTOO_DEVELOPER="hollow"
+
+# IUSE/USE_EXPAND magic
+IUSE_MPMS_FORK="itk peruser prefork"
+IUSE_MPMS_THREAD="event worker"
+
+IUSE_MODULES="actions alias asis auth_basic auth_digest authn_alias authn_anon
+authn_dbd authn_dbm authn_default authn_file authz_dbm authz_default
+authz_groupfile authz_host authz_owner authz_user autoindex cache cern_meta
+charset_lite dav dav_fs dav_lock dbd deflate dir disk_cache dumpio env expires
+ext_filter file_cache filter headers ident imagemap include info log_config
+log_forensic logio mem_cache mime mime_magic negotiation proxy proxy_ajp
+proxy_balancer proxy_connect proxy_ftp proxy_http rewrite setenvif speling
+status substitute unique_id userdir usertrack version vhost_alias"
+
+# inter-module dependencies
+# TODO: this may still be incomplete
+MODULE_DEPENDS="
+ dav_fs:dav
+ dav_lock:dav
+ deflate:filter
+ disk_cache:cache
+ ext_filter:filter
+ file_cache:cache
+ log_forensic:log_config
+ logio:log_config
+ mem_cache:cache
+ mime_magic:mime
+ proxy_ajp:proxy
+ proxy_balancer:proxy
+ proxy_connect:proxy
+ proxy_ftp:proxy
+ proxy_http:proxy
+ substitute:filter
+"
+
+# module<->define mappings
+MODULE_DEFINES="
+ auth_digest:AUTH_DIGEST
+ authnz_ldap:AUTHNZ_LDAP
+ cache:CACHE
+ dav:DAV
+ dav_fs:DAV
+ dav_lock:DAV
+ disk_cache:CACHE
+ file_cache:CACHE
+ info:INFO
+ ldap:LDAP
+ mem_cache:CACHE
+ proxy:PROXY
+ proxy_ajp:PROXY
+ proxy_balancer:PROXY
+ proxy_connect:PROXY
+ proxy_ftp:PROXY
+ proxy_http:PROXY
+ ssl:SSL
+ status:STATUS
+ suexec:SUEXEC
+ userdir:USERDIR
+"
+
+# critical modules for the default config
+MODULE_CRITICAL="
+ authz_host
+ dir
+ mime
+"
+
+inherit apache-2
+
+DESCRIPTION="The Apache Web Server."
+HOMEPAGE="http://httpd.apache.org/"
+
+# some helper scripts are Apache-1.1, thus both are here
+LICENSE="Apache-2.0 Apache-1.1"
+SLOT="2"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~sparc-fbsd ~x86-fbsd"
+IUSE="peruser_dc"
+
+DEPEND="${DEPEND}
+ apache2_modules_deflate? ( sys-libs/zlib )"
+
+RDEPEND="${RDEPEND}
+ apache2_modules_mime? ( app-misc/mime-types )"
+
+src_unpack() {
+ if use peruser_dc ; then
+ if ! use apache2_mpms_peruser ; then
+ die "USE=peruser_dc requires APACHE2_MPMS=peruser"
+ fi
+ else
+ EPATCH_EXCLUDE="${EPATCH_EXCLUDE} 22_all_peruser_0.3.0-dc3.patch"
+ fi
+
+ apache-2_src_unpack
+}