summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDirkjan Ochtman <djc@gentoo.org>2010-01-24 15:50:21 +0000
committerDirkjan Ochtman <djc@gentoo.org>2010-01-24 15:50:21 +0000
commit9f06f0b24b78a1f4229e61576d31a6f56c9c4d6b (patch)
treebba63d1c33d15d14450ff6b78fde34efb8b2d4b7 /www-servers
parentStable on alpha, bug #297845 (diff)
downloadgentoo-2-9f06f0b24b78a1f4229e61576d31a6f56c9c4d6b.tar.gz
gentoo-2-9f06f0b24b78a1f4229e61576d31a6f56c9c4d6b.tar.bz2
gentoo-2-9f06f0b24b78a1f4229e61576d31a6f56c9c4d6b.zip
Version bump nginx to 0.8.32.
(Portage version: 2.1.6.13/cvs/Linux x86_64)
Diffstat (limited to 'www-servers')
-rw-r--r--www-servers/nginx/ChangeLog8
-rw-r--r--www-servers/nginx/nginx-0.8.32.ebuild (renamed from www-servers/nginx/nginx-0.8.29.ebuild)30
2 files changed, 29 insertions, 9 deletions
diff --git a/www-servers/nginx/ChangeLog b/www-servers/nginx/ChangeLog
index 0898da004f97..2ec9be07dd64 100644
--- a/www-servers/nginx/ChangeLog
+++ b/www-servers/nginx/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for www-servers/nginx
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-servers/nginx/ChangeLog,v 1.241 2010/01/03 20:58:11 djc Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-servers/nginx/ChangeLog,v 1.242 2010/01/24 15:50:21 djc Exp $
+
+*nginx-0.8.32 (24 Jan 2010)
+
+ 24 Jan 2010; Dirkjan Ochtman <djc@gentoo.org> -nginx-0.8.29.ebuild,
+ +nginx-0.8.32.ebuild:
+ Simple version bump to 0.8.32, clean out 0.8.29 while we're at it.
03 Jan 2010; Dirkjan Ochtman <djc@gentoo.org> -nginx-0.7.64-r2.ebuild:
Remove superseded 0.7.64-r2.
diff --git a/www-servers/nginx/nginx-0.8.29.ebuild b/www-servers/nginx/nginx-0.8.32.ebuild
index 6012f3984b71..5ccb3eea38f6 100644
--- a/www-servers/nginx/nginx-0.8.29.ebuild
+++ b/www-servers/nginx/nginx-0.8.32.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-servers/nginx/nginx-0.8.29.ebuild,v 1.4 2010/01/03 11:32:08 fauli Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-servers/nginx/nginx-0.8.32.ebuild,v 1.1 2010/01/24 15:50:21 djc Exp $
-inherit eutils ssl-cert toolchain-funcs
+inherit eutils ssl-cert toolchain-funcs perl-module
DESCRIPTION="Robust, small and high performance http and reverse proxy server"
@@ -11,7 +11,7 @@ SRC_URI="http://sysoev.ru/nginx/${P}.tar.gz"
LICENSE="BSD"
SLOT="0"
KEYWORDS="~amd64 ~ppc ~x86 ~x86-fbsd"
-IUSE="addition debug fastcgi flv imap ipv6 pcre perl random-index securelink ssl status sub webdav zlib"
+IUSE="addition aio debug fastcgi flv imap ipv6 pcre perl pop random-index realip securelink smtp ssl static-gzip status sub webdav zlib"
DEPEND="dev-lang/perl
dev-libs/openssl
@@ -50,6 +50,7 @@ src_compile() {
# fi
use addition && myconf="${myconf} --with-http_addition_module"
+ use aio && myconf="${myconf} --with-file-aio"
use ipv6 && myconf="${myconf} --with-ipv6"
use fastcgi || myconf="${myconf} --without-http_fastcgi_module"
use fastcgi && myconf="${myconf} --with-http_realip_module"
@@ -60,13 +61,22 @@ src_compile() {
}
use debug && myconf="${myconf} --with-debug"
use ssl && myconf="${myconf} --with-http_ssl_module"
- use imap && myconf="${myconf} --with-imap" # pop3/imap4 proxy support
use perl && myconf="${myconf} --with-http_perl_module"
use status && myconf="${myconf} --with-http_stub_status_module"
use webdav && myconf="${myconf} --with-http_dav_module"
use sub && myconf="${myconf} --with-http_sub_module"
+ use realip && myconf="${myconf} --with-http_realip_module"
+ use static-gzip && myconf="${myconf} --with-http_gzip_static_module"
use random-index && myconf="${myconf} --with-http_random_index_module"
- use securelink && myconf="${myconf} --with-http_secure_link_module"
+ use securelink && myconf="${myconf} --with-http_secure_link_module"
+
+ if use smtp || use pop || use imap; then
+ myconf="${myconf} --with-mail"
+ use ssl && myconf="${myconf} --with-mail_ssl_module"
+ fi
+ use imap || myconf="${myconf} --without-mail_imap_module"
+ use pop || myconf="${myconf} --without-mail_pop3_module"
+ use smtp || myconf="${myconf} --without-mail_smtp_module"
tc-export CC
./configure \
@@ -89,8 +99,7 @@ src_install() {
keepdir /var/log/${PN} /var/tmp/${PN}/{client,proxy,fastcgi}
dosbin objs/nginx
- cp "${FILESDIR}"/nginx-r1 "${T}"/nginx
- doinitd "${T}"/nginx
+ newinitd "${FILESDIR}"/nginx.init-r2 nginx || die
cp "${FILESDIR}"/nginx.conf-r4 conf/nginx.conf
@@ -100,9 +109,14 @@ src_install() {
dodoc CHANGES{,.ru} README
+ # logrotate
+ insinto /etc/logrotate.d
+ newins "${FILESDIR}"/nginx.logrotate nginx || die
+
use perl && {
cd "${S}"/objs/src/http/modules/perl/
- einstall DESTDIR="${D}"|| die "failed to install perl stuff"
+ einstall DESTDIR="${D}" INSTALLDIRS=vendor || die "failed to install perl stuff"
+ fixlocalpod
}
}