summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKonstantin V. Arkhipov <voxus@gentoo.org>2008-10-25 17:36:52 +0000
committerKonstantin V. Arkhipov <voxus@gentoo.org>2008-10-25 17:36:52 +0000
commit90738cfe05e2c519c1340de5791f249504380899 (patch)
tree24578a0e69773a64706f034cd3fbaa0fe3b23b5f /www-servers
parentStable on ppc wrt bug 243488 (diff)
downloadgentoo-2-90738cfe05e2c519c1340de5791f249504380899.tar.gz
gentoo-2-90738cfe05e2c519c1340de5791f249504380899.tar.bz2
gentoo-2-90738cfe05e2c519c1340de5791f249504380899.zip
* bump
* latest from 0.5/0.6 goes stable (Portage version: 2.2_rc12/cvs/Linux 2.6.27-rc5-mm1 x86_64)
Diffstat (limited to 'www-servers')
-rw-r--r--www-servers/nginx/ChangeLog10
-rw-r--r--www-servers/nginx/nginx-0.5.35.ebuild102
-rw-r--r--www-servers/nginx/nginx-0.5.37.ebuild4
-rw-r--r--www-servers/nginx/nginx-0.6.29.ebuild104
-rw-r--r--www-servers/nginx/nginx-0.6.32.ebuild4
-rw-r--r--www-servers/nginx/nginx-0.7.17.ebuild104
-rw-r--r--www-servers/nginx/nginx-0.7.19.ebuild (renamed from www-servers/nginx/nginx-0.7.16.ebuild)2
7 files changed, 14 insertions, 316 deletions
diff --git a/www-servers/nginx/ChangeLog b/www-servers/nginx/ChangeLog
index 4d62692d8c2f..01cb6e112792 100644
--- a/www-servers/nginx/ChangeLog
+++ b/www-servers/nginx/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for www-servers/nginx
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-servers/nginx/ChangeLog,v 1.192 2008/09/16 13:28:45 voxus Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-servers/nginx/ChangeLog,v 1.193 2008/10/25 17:36:52 voxus Exp $
+
+*nginx-0.7.19 (25 Oct 2008)
+
+ 25 Oct 2008; Konstantin V. Arkhipov <voxus@gentoo.org>
+ -nginx-0.5.35.ebuild, nginx-0.5.37.ebuild, -nginx-0.6.29.ebuild,
+ nginx-0.6.32.ebuild, -nginx-0.7.16.ebuild, -nginx-0.7.17.ebuild,
+ +nginx-0.7.19.ebuild:
+ Version bump, stabilization.
*nginx-0.7.17 (16 Sep 2008)
diff --git a/www-servers/nginx/nginx-0.5.35.ebuild b/www-servers/nginx/nginx-0.5.35.ebuild
deleted file mode 100644
index add6ee4de6e6..000000000000
--- a/www-servers/nginx/nginx-0.5.35.ebuild
+++ /dev/null
@@ -1,102 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-servers/nginx/nginx-0.5.35.ebuild,v 1.2 2008/04/11 14:06:07 voxus Exp $
-
-inherit eutils ssl-cert
-
-DESCRIPTION="Robust, small and high performance http and reverse proxy server"
-
-HOMEPAGE="http://sysoev.ru/nginx/"
-SRC_URI="http://sysoev.ru/nginx/${P}.tar.gz"
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="amd64 ~ppc x86"
-IUSE="debug fastcgi flv imap pcre perl ssl status sub webdav zlib"
-
-DEPEND="dev-lang/perl
- pcre? ( >=dev-libs/libpcre-4.2 )
- ssl? ( dev-libs/openssl )
- zlib? ( sys-libs/zlib )
- perl? ( >=dev-lang/perl-5.8 )"
-
-pkg_setup() {
- ebegin "Creating nginx user and group"
- enewgroup nginx
- enewuser nginx -1 -1 /dev/null nginx
- eend ${?}
-}
-
-src_compile() {
- local myconf
-
- # threads support is broken atm.
- #
- # if use threads; then
- # einfo
- # ewarn "threads support is experimental at the moment"
- # ewarn "do not use it on production systems - you've been warned"
- # einfo
- # myconf="${myconf} --with-threads"
- # fi
-
- use fastcgi || myconf="${myconf} --without-http_fastcgi_module"
- use fastcgi && myconf="${myconf} --with-http_realip_module"
- use flv && myconf="${myconf} --with-http_flv_module"
- use zlib || myconf="${myconf} --without-http_gzip_module"
- use pcre || {
- myconf="${myconf} --without-pcre --without-http_rewrite_module"
- }
- use debug && myconf="${myconf} --with-debug"
- use ssl && myconf="${myconf} --with-http_ssl_module"
- use imap && myconf="${myconf} --with-imap" # pop3/imap4 proxy support
- use perl && myconf="${myconf} --with-http_perl_module"
- use status && myconf="${myconf} --with-http_stub_status_module"
- use webdav && myconf="${myconf} --with-http_dav_module"
- use sub && myconf="${myconf} --with-http_sub_module"
-
- ./configure \
- --prefix=/usr \
- --conf-path=/etc/${PN}/${PN}.conf \
- --http-log-path=/var/log/${PN}/access_log \
- --error-log-path=/var/log/${PN}/error_log \
- --pid-path=/var/run/${PN}.pid \
- --http-client-body-temp-path=/var/tmp/${PN}/client \
- --http-proxy-temp-path=/var/tmp/${PN}/proxy \
- --http-fastcgi-temp-path=/var/tmp/${PN}/fastcgi \
- --with-md5-asm --with-md5=/usr/include \
- ${myconf} || die "configure failed"
-
- emake || die "failed to compile"
-}
-
-src_install() {
- keepdir /var/log/${PN} /var/tmp/${PN}/{client,proxy,fastcgi}
-
- dosbin objs/nginx
- cp "${FILESDIR}"/nginx-r1 "${T}"/nginx
- doinitd "${T}"/nginx
-
- cp "${FILESDIR}"/nginx.conf-r4 conf/nginx.conf
-
- dodir "${ROOT}"/etc/${PN}
- insinto "${ROOT}"/etc/${PN}
- doins conf/*
-
- dodoc CHANGES{,.ru} LICENSE README
-
- use perl && {
- cd "${S}"/objs/src/http/modules/perl/
- einstall DESTDIR="${D}"|| die "failed to install perl stuff"
- }
-}
-
-pkg_postinst() {
- use ssl && {
- if [ ! -f "${ROOT}"/etc/ssl/${PN}/${PN}.key ]; then
- dodir "${ROOT}"/etc/ssl/${PN}
- insinto "${ROOT}"etc/ssl/${PN}/
- insopts -m0644 -o nginx -g nginx
- install_cert /etc/ssl/nginx/nginx
- fi
- }
-}
diff --git a/www-servers/nginx/nginx-0.5.37.ebuild b/www-servers/nginx/nginx-0.5.37.ebuild
index 1dfa5e8c67fc..b8e946f0fc9b 100644
--- a/www-servers/nginx/nginx-0.5.37.ebuild
+++ b/www-servers/nginx/nginx-0.5.37.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-servers/nginx/nginx-0.5.37.ebuild,v 1.1 2008/07/29 11:50:10 voxus Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-servers/nginx/nginx-0.5.37.ebuild,v 1.2 2008/10/25 17:36:52 voxus Exp $
inherit eutils ssl-cert
@@ -10,7 +10,7 @@ HOMEPAGE="http://sysoev.ru/nginx/"
SRC_URI="http://sysoev.ru/nginx/${P}.tar.gz"
LICENSE="BSD"
SLOT="0"
-KEYWORDS="~amd64 ~ppc ~x86"
+KEYWORDS="amd64 ~ppc x86"
IUSE="debug fastcgi flv imap pcre perl ssl status sub webdav zlib"
DEPEND="dev-lang/perl
diff --git a/www-servers/nginx/nginx-0.6.29.ebuild b/www-servers/nginx/nginx-0.6.29.ebuild
deleted file mode 100644
index dac251868313..000000000000
--- a/www-servers/nginx/nginx-0.6.29.ebuild
+++ /dev/null
@@ -1,104 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-servers/nginx/nginx-0.6.29.ebuild,v 1.2 2008/04/11 14:06:07 voxus Exp $
-
-inherit eutils ssl-cert
-
-DESCRIPTION="Robust, small and high performance http and reverse proxy server"
-
-HOMEPAGE="http://nginx.net/"
-SRC_URI="http://sysoev.ru/nginx/${P}.tar.gz"
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="amd64 ~ppc x86"
-IUSE="addition debug fastcgi flv imap pcre perl ssl status sub webdav zlib"
-
-DEPEND="dev-lang/perl
- pcre? ( >=dev-libs/libpcre-4.2 )
- ssl? ( dev-libs/openssl )
- zlib? ( sys-libs/zlib )
- perl? ( >=dev-lang/perl-5.8 )"
-
-pkg_setup() {
- ebegin "Creating nginx user and group"
- enewgroup nginx
- enewuser nginx -1 -1 /dev/null nginx
- eend ${?}
-}
-
-src_compile() {
- local myconf
-
- # threads support is broken atm.
- #
- # if use threads; then
- # einfo
- # ewarn "threads support is experimental at the moment"
- # ewarn "do not use it on production systems - you've been warned"
- # einfo
- # myconf="${myconf} --with-threads"
- # fi
-
- use addition && myconf="${myconf} --with-http_addition_module"
- use fastcgi || myconf="${myconf} --without-http_fastcgi_module"
- use fastcgi && myconf="${myconf} --with-http_realip_module"
- use flv && myconf="${myconf} --with-http_flv_module"
- use zlib || myconf="${myconf} --without-http_gzip_module"
- use pcre || {
- myconf="${myconf} --without-pcre --without-http_rewrite_module"
- }
- use debug && myconf="${myconf} --with-debug"
- use ssl && myconf="${myconf} --with-http_ssl_module"
- use imap && myconf="${myconf} --with-imap" # pop3/imap4 proxy support
- use perl && myconf="${myconf} --with-http_perl_module"
- use status && myconf="${myconf} --with-http_stub_status_module"
- use webdav && myconf="${myconf} --with-http_dav_module"
- use sub && myconf="${myconf} --with-http_sub_module"
-
- ./configure \
- --prefix=/usr \
- --conf-path=/etc/${PN}/${PN}.conf \
- --http-log-path=/var/log/${PN}/access_log \
- --error-log-path=/var/log/${PN}/error_log \
- --pid-path=/var/run/${PN}.pid \
- --http-client-body-temp-path=/var/tmp/${PN}/client \
- --http-proxy-temp-path=/var/tmp/${PN}/proxy \
- --http-fastcgi-temp-path=/var/tmp/${PN}/fastcgi \
- --with-md5-asm --with-md5=/usr/include \
- --with-sha1-asm --with-sha1=/usr/include \
- ${myconf} || die "configure failed"
-
- emake || die "failed to compile"
-}
-
-src_install() {
- keepdir /var/log/${PN} /var/tmp/${PN}/{client,proxy,fastcgi}
-
- dosbin objs/nginx
- cp "${FILESDIR}"/nginx-r1 "${T}"/nginx
- doinitd "${T}"/nginx
-
- cp "${FILESDIR}"/nginx.conf-r4 conf/nginx.conf
-
- dodir "${ROOT}"/etc/${PN}
- insinto "${ROOT}"/etc/${PN}
- doins conf/*
-
- dodoc CHANGES{,.ru} LICENSE README
-
- use perl && {
- cd "${S}"/objs/src/http/modules/perl/
- einstall DESTDIR="${D}"|| die "failed to install perl stuff"
- }
-}
-
-pkg_postinst() {
- use ssl && {
- if [ ! -f "${ROOT}"/etc/ssl/${PN}/${PN}.key ]; then
- dodir "${ROOT}"/etc/ssl/${PN}
- insinto "${ROOT}"etc/ssl/${PN}/
- insopts -m0644 -o nginx -g nginx
- install_cert /etc/ssl/nginx/nginx
- fi
- }
-}
diff --git a/www-servers/nginx/nginx-0.6.32.ebuild b/www-servers/nginx/nginx-0.6.32.ebuild
index a648f0948121..4bfdfa599dd0 100644
--- a/www-servers/nginx/nginx-0.6.32.ebuild
+++ b/www-servers/nginx/nginx-0.6.32.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-servers/nginx/nginx-0.6.32.ebuild,v 1.1 2008/07/14 17:49:03 voxus Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-servers/nginx/nginx-0.6.32.ebuild,v 1.2 2008/10/25 17:36:52 voxus Exp $
inherit eutils ssl-cert
@@ -10,7 +10,7 @@ HOMEPAGE="http://nginx.net/"
SRC_URI="http://sysoev.ru/nginx/${P}.tar.gz"
LICENSE="BSD"
SLOT="0"
-KEYWORDS="~amd64 ~ppc ~x86"
+KEYWORDS="amd64 ~ppc x86"
IUSE="addition debug fastcgi flv imap pcre perl ssl status sub webdav zlib"
DEPEND="dev-lang/perl
diff --git a/www-servers/nginx/nginx-0.7.17.ebuild b/www-servers/nginx/nginx-0.7.17.ebuild
deleted file mode 100644
index 8e200273258c..000000000000
--- a/www-servers/nginx/nginx-0.7.17.ebuild
+++ /dev/null
@@ -1,104 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-servers/nginx/nginx-0.7.17.ebuild,v 1.1 2008/09/16 13:28:45 voxus Exp $
-
-inherit eutils ssl-cert
-
-DESCRIPTION="Robust, small and high performance http and reverse proxy server"
-
-HOMEPAGE="http://nginx.net/"
-SRC_URI="http://sysoev.ru/nginx/${P}.tar.gz"
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc ~x86"
-IUSE="addition debug fastcgi flv imap pcre perl ssl status sub webdav zlib"
-
-DEPEND="dev-lang/perl
- pcre? ( >=dev-libs/libpcre-4.2 )
- ssl? ( dev-libs/openssl )
- zlib? ( sys-libs/zlib )
- perl? ( >=dev-lang/perl-5.8 )"
-
-pkg_setup() {
- ebegin "Creating nginx user and group"
- enewgroup nginx
- enewuser nginx -1 -1 /dev/null nginx
- eend ${?}
-}
-
-src_compile() {
- local myconf
-
- # threads support is broken atm.
- #
- # if use threads; then
- # einfo
- # ewarn "threads support is experimental at the moment"
- # ewarn "do not use it on production systems - you've been warned"
- # einfo
- # myconf="${myconf} --with-threads"
- # fi
-
- use addition && myconf="${myconf} --with-http_addition_module"
- use fastcgi || myconf="${myconf} --without-http_fastcgi_module"
- use fastcgi && myconf="${myconf} --with-http_realip_module"
- use flv && myconf="${myconf} --with-http_flv_module"
- use zlib || myconf="${myconf} --without-http_gzip_module"
- use pcre || {
- myconf="${myconf} --without-pcre --without-http_rewrite_module"
- }
- use debug && myconf="${myconf} --with-debug"
- use ssl && myconf="${myconf} --with-http_ssl_module"
- use imap && myconf="${myconf} --with-imap" # pop3/imap4 proxy support
- use perl && myconf="${myconf} --with-http_perl_module"
- use status && myconf="${myconf} --with-http_stub_status_module"
- use webdav && myconf="${myconf} --with-http_dav_module"
- use sub && myconf="${myconf} --with-http_sub_module"
-
- ./configure \
- --prefix=/usr \
- --conf-path=/etc/${PN}/${PN}.conf \
- --http-log-path=/var/log/${PN}/access_log \
- --error-log-path=/var/log/${PN}/error_log \
- --pid-path=/var/run/${PN}.pid \
- --http-client-body-temp-path=/var/tmp/${PN}/client \
- --http-proxy-temp-path=/var/tmp/${PN}/proxy \
- --http-fastcgi-temp-path=/var/tmp/${PN}/fastcgi \
- --with-md5-asm --with-md5=/usr/include \
- --with-sha1-asm --with-sha1=/usr/include \
- ${myconf} || die "configure failed"
-
- emake || die "failed to compile"
-}
-
-src_install() {
- keepdir /var/log/${PN} /var/tmp/${PN}/{client,proxy,fastcgi}
-
- dosbin objs/nginx
- cp "${FILESDIR}"/nginx-r1 "${T}"/nginx
- doinitd "${T}"/nginx
-
- cp "${FILESDIR}"/nginx.conf-r4 conf/nginx.conf
-
- dodir "${ROOT}"/etc/${PN}
- insinto "${ROOT}"/etc/${PN}
- doins conf/*
-
- dodoc CHANGES{,.ru} README
-
- use perl && {
- cd "${S}"/objs/src/http/modules/perl/
- einstall DESTDIR="${D}"|| die "failed to install perl stuff"
- }
-}
-
-pkg_postinst() {
- use ssl && {
- if [ ! -f "${ROOT}"/etc/ssl/${PN}/${PN}.key ]; then
- dodir "${ROOT}"/etc/ssl/${PN}
- insinto "${ROOT}"etc/ssl/${PN}/
- insopts -m0644 -o nginx -g nginx
- install_cert /etc/ssl/nginx/nginx
- fi
- }
-}
diff --git a/www-servers/nginx/nginx-0.7.16.ebuild b/www-servers/nginx/nginx-0.7.19.ebuild
index 94ac6b89ab0b..54847f682da7 100644
--- a/www-servers/nginx/nginx-0.7.16.ebuild
+++ b/www-servers/nginx/nginx-0.7.19.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-servers/nginx/nginx-0.7.16.ebuild,v 1.1 2008/09/08 10:54:08 voxus Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-servers/nginx/nginx-0.7.19.ebuild,v 1.1 2008/10/25 17:36:52 voxus Exp $
inherit eutils ssl-cert