summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTom Wijsman <tomwij@gentoo.org>2013-02-22 17:31:25 +0000
committerTom Wijsman <tomwij@gentoo.org>2013-02-22 17:31:25 +0000
commit665baa89dd64f5a8d545f1263b01c033ee297394 (patch)
tree993848ee8a39733e4fd6926a99cd01de7f33b382 /www-servers
parentAdd ~arm-linux keyword. (diff)
downloadgentoo-2-665baa89dd64f5a8d545f1263b01c033ee297394.tar.gz
gentoo-2-665baa89dd64f5a8d545f1263b01c033ee297394.tar.bz2
gentoo-2-665baa89dd64f5a8d545f1263b01c033ee297394.zip
Version bump to 0.5.7.
(Portage version: 2.1.11.52/cvs/Linux x86_64, signed Manifest commit with key 6D34E57D)
Diffstat (limited to 'www-servers')
-rw-r--r--www-servers/meteor/ChangeLog7
-rw-r--r--www-servers/meteor/meteor-0.5.7.ebuild69
2 files changed, 75 insertions, 1 deletions
diff --git a/www-servers/meteor/ChangeLog b/www-servers/meteor/ChangeLog
index 3fa19f35c03f..10bff057e587 100644
--- a/www-servers/meteor/ChangeLog
+++ b/www-servers/meteor/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for www-servers/meteor
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-servers/meteor/ChangeLog,v 1.6 2013/02/16 00:14:14 tomwij Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-servers/meteor/ChangeLog,v 1.7 2013/02/22 17:31:25 tomwij Exp $
+
+*meteor-0.5.7 (22 Feb 2013)
+
+ 22 Feb 2013; Tom Wijsman <TomWij@gentoo.org> +meteor-0.5.7.ebuild:
+ Version bump to 0.5.7.
*meteor-0.5.6 (16 Feb 2013)
diff --git a/www-servers/meteor/meteor-0.5.7.ebuild b/www-servers/meteor/meteor-0.5.7.ebuild
new file mode 100644
index 000000000000..cf3beec63644
--- /dev/null
+++ b/www-servers/meteor/meteor-0.5.7.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-servers/meteor/meteor-0.5.7.ebuild,v 1.1 2013/02/22 17:31:25 tomwij Exp $
+
+EAPI=5
+
+inherit eutils vcs-snapshot
+
+METEOR_BUNDLEV="0.2.19"
+
+DESCRIPTION="An open-source platform for building top-quality web apps in a fraction of the time."
+HOMEPAGE="http://meteor.com/"
+SRC_URI="https://github.com/meteor/meteor/tarball/v${PV} -> ${P}.tar.gz
+ x86? ( https://d3sqy0vbqsdhku.cloudfront.net/dev_bundle_Linux_i686_${METEOR_BUNDLEV}.tar.gz -> ${P}_bundle-${METEOR_BUNDLEV}.tar.gz )
+ amd64? ( https://d3sqy0vbqsdhku.cloudfront.net/dev_bundle_Linux_x86_64_${METEOR_BUNDLEV}.tar.gz -> ${P}_bundle-${METEOR_BUNDLEV}.tar.gz )"
+
+LICENSE="AGPL-3
+ Apache-2.0
+ Boost-1.0
+ BSD
+ BSD-2
+ CC-BY-SA-2.0
+ HPND
+ MIT
+ npm
+ ODbL-1.0
+ openssl
+ public-domain
+ Unlicense
+ ZLIB || ( BSD-2 GPL-2+ )
+ WTFPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+src_prepare() {
+ local DEV_BUNDLE_DIR="${WORKDIR}/${P}_bundle-${METEOR_BUNDLEV}"
+
+ einfo "Moving development bundle ..."
+ mv "${DEV_BUNDLE_DIR}"/* "${DEV_BUNDLE_DIR}"/.bundle_version.txt . || die "Couldn't move development bundle."
+
+ einfo "Patching files ..."
+ sed -i 's/DEV_BUNDLE=$(dirname "$SCRIPT_DIR")/DEV_BUNDLE="$SCRIPT_DIR"/g' meteor || die "Couldn't patch DEV_BUNDLE script dir."
+ sed -i "s/^exports\.CURRENT_VERSION.*/exports.CURRENT_VERSION = \"${PV}-gentoo\";/g" app/lib/updater.js || die "Couldn't add gentoo suffix to version."
+
+ einfo "Removing updater since Portage covers this ..."
+ epatch "${FILESDIR}"/${PN}-0.5.4.remove_updater.patch
+ rm app/meteor/update.js || die "Couldn't remove updater."
+
+ # We don't care if these fail, just get rid of them if they exist.
+ einfo "Removing unnecessary files ..."
+ rm -rf admin
+ rm -rf {examples,packages}/*/.meteor/local
+ rm -rf examples/unfinished
+}
+
+src_install() {
+ dodir /opt/meteor
+
+ insinto /opt/meteor
+ doins -r *
+ doins .bundle_version.txt
+
+ dosym /opt/meteor/meteor /usr/bin/meteor
+
+ fperms +x /opt/meteor/meteor
+ fperms +x /opt/meteor/bin/node
+ fperms +x /opt/meteor/mongodb/bin/mongo
+ fperms +x /opt/meteor/mongodb/bin/mongod
+}