summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThilo Bangert <bangert@gentoo.org>2010-04-13 09:20:39 +0000
committerThilo Bangert <bangert@gentoo.org>2010-04-13 09:20:39 +0000
commit5f21790f11c15d66cfb54df04ad4e1a36c9fa75e (patch)
tree964a25fe08b29cf33e1b9f8c1ae2612ab794bbe4 /www-servers
parentx86 stable wrt bug #313307 (diff)
downloadgentoo-2-5f21790f11c15d66cfb54df04ad4e1a36c9fa75e.tar.gz
gentoo-2-5f21790f11c15d66cfb54df04ad4e1a36c9fa75e.tar.bz2
gentoo-2-5f21790f11c15d66cfb54df04ad4e1a36c9fa75e.zip
version bump
(Portage version: 2.2_rc67/cvs/Linux i686)
Diffstat (limited to 'www-servers')
-rw-r--r--www-servers/varnish/ChangeLog9
-rw-r--r--www-servers/varnish/varnish-2.0.6.ebuild47
2 files changed, 54 insertions, 2 deletions
diff --git a/www-servers/varnish/ChangeLog b/www-servers/varnish/ChangeLog
index 6887f777d178..fb465a7d0231 100644
--- a/www-servers/varnish/ChangeLog
+++ b/www-servers/varnish/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for www-servers/varnish
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-servers/varnish/ChangeLog,v 1.29 2009/11/20 09:05:35 bangert Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/www-servers/varnish/ChangeLog,v 1.30 2010/04/13 09:20:39 bangert Exp $
+
+*varnish-2.0.6 (13 Apr 2010)
+
+ 13 Apr 2010; Thilo Bangert <bangert@gentoo.org> +varnish-2.0.6.ebuild:
+ version bump
*varnish-2.0.5 (20 Nov 2009)
diff --git a/www-servers/varnish/varnish-2.0.6.ebuild b/www-servers/varnish/varnish-2.0.6.ebuild
new file mode 100644
index 000000000000..ab3403fcd816
--- /dev/null
+++ b/www-servers/varnish/varnish-2.0.6.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-servers/varnish/varnish-2.0.6.ebuild,v 1.1 2010/04/13 09:20:39 bangert Exp $
+
+EAPI="2"
+
+inherit autotools
+
+DESCRIPTION="Varnish is a state-of-the-art, high-performance HTTP accelerator."
+HOMEPAGE="http://varnish.projects.linpro.no/"
+SRC_URI="mirror://sourceforge/varnish/${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+#varnish compiles stuff at run time
+RDEPEND="sys-devel/gcc"
+
+HTTP_HDR_MAX_VAL=${HTTP_HDR_MAX_VAL:-32}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-2.0.4-link-order.patch
+ epatch "${FILESDIR}"/${PN}-2.0.4-virtual-ncsa.patch
+ sed -e "s/#define HTTP_HDR_MAX_VAL .*/#define HTTP_HDR_MAX_VAL ${HTTP_HDR_MAX_VAL}/" \
+ -i bin/varnishd/cache.h
+ eautoreconf
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ newinitd "${FILESDIR}"/varnishd.initd varnishd || die
+ newconfd "${FILESDIR}"/varnishd.confd varnishd || die
+
+ insinto /etc/logrotate.d
+ newins "${FILESDIR}/varnishd.logrotate" varnishd
+
+ dodir /var/log/varnish
+}
+
+pkg_postinst () {
+ elog "No demo-/sample-configfile is included in the distribution -"
+ elog "please read the man-page for more info."
+ elog "A sample (localhost:8080 -> localhost:80) for gentoo is given in"
+ elog " /etc/conf.d/varnishd"
+ echo
+}