summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2015-03-07 17:33:25 +0000
committerAnthony G. Basile <blueness@gentoo.org>2015-03-07 17:33:25 +0000
commit595a162856f948e170e0f69b37abe1759fb323e1 (patch)
tree6b0595823c095c77e21da58d6f5679ccef328161 /www-servers
parentFix bug #514530. (diff)
downloadgentoo-2-595a162856f948e170e0f69b37abe1759fb323e1.tar.gz
gentoo-2-595a162856f948e170e0f69b37abe1759fb323e1.tar.bz2
gentoo-2-595a162856f948e170e0f69b37abe1759fb323e1.zip
Some further cleanups.
(Portage version: 2.2.14/cvs/Linux x86_64, signed Manifest commit with key 0xF52D4BBA)
Diffstat (limited to 'www-servers')
-rw-r--r--www-servers/cherokee/ChangeLog7
-rw-r--r--www-servers/cherokee/cherokee-1.2.101-r3.ebuild196
-rw-r--r--www-servers/cherokee/files/cherokee-1.2.101-libav-9.patch29
-rw-r--r--www-servers/cherokee/files/cherokee-1.2.98-linux3.patch45
4 files changed, 6 insertions, 271 deletions
diff --git a/www-servers/cherokee/ChangeLog b/www-servers/cherokee/ChangeLog
index b80254a62aa8..acc8ce4ebbca 100644
--- a/www-servers/cherokee/ChangeLog
+++ b/www-servers/cherokee/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for www-servers/cherokee
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-servers/cherokee/ChangeLog,v 1.106 2015/03/07 17:29:35 blueness Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-servers/cherokee/ChangeLog,v 1.107 2015/03/07 17:33:25 blueness Exp $
+
+ 07 Mar 2015; Anthony G. Basile <blueness@gentoo.org>
+ -cherokee-1.2.101-r3.ebuild, -files/cherokee-1.2.101-libav-9.patch,
+ -files/cherokee-1.2.98-linux3.patch:
+ Some further cleanups.
07 Mar 2015; Anthony G. Basile <blueness@gentoo.org>
cherokee-1.2.103-r2.ebuild, cherokee-1.2.104.ebuild:
diff --git a/www-servers/cherokee/cherokee-1.2.101-r3.ebuild b/www-servers/cherokee/cherokee-1.2.101-r3.ebuild
deleted file mode 100644
index aa6595b6d1ae..000000000000
--- a/www-servers/cherokee/cherokee-1.2.101-r3.ebuild
+++ /dev/null
@@ -1,196 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-servers/cherokee/cherokee-1.2.101-r3.ebuild,v 1.3 2014/08/10 20:08:32 slyfox Exp $
-
-EAPI=4
-PYTHON_DEPEND="admin? 2"
-PYTHON_USE_WITH="threads"
-
-inherit eutils multilib pam python versionator systemd user
-
-DESCRIPTION="An extremely fast and tiny web server"
-SRC_URI="http://www.cherokee-project.com/download/$(get_version_component_range 1-2)/${PV}/${P}.tar.gz"
-HOMEPAGE="http://www.cherokee-project.com/"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~mips ~ppc ~ppc64 ~x86"
-IUSE="admin ffmpeg debug geoip ipv6 kernel_linux ldap mysql nls pam php rrdtool ssl static static-libs"
-
-COMMON_DEPEND="dev-libs/libpcre
- >=sys-libs/zlib-1.1.4-r1
- ffmpeg? ( virtual/ffmpeg )
- geoip? ( dev-libs/geoip )
- ldap? ( net-nds/openldap )
- mysql? ( >=virtual/mysql-5 )
- nls? ( virtual/libintl )
- pam? ( virtual/pam )
- php? ( || (
- dev-lang/php[fpm]
- dev-lang/php[cgi]
- ) )
- ssl? ( dev-libs/openssl )"
-DEPEND="${COMMON_DEPEND}
- nls? ( sys-devel/gettext )"
-RDEPEND="${COMMON_DEPEND}
- rrdtool? ( net-analyzer/rrdtool )"
-
-RESTRICT="test"
-
-WEBROOT="/var/www/localhost"
-
-pkg_setup() {
- python_pkg_setup
-
- python_set_active_version 2
-
- enewgroup cherokee
- enewuser cherokee -1 -1 /var/www cherokee
-}
-
-src_prepare() {
- epatch \
- "${FILESDIR}/${PN}-1.2.99-gentoo.patch" \
- "${FILESDIR}/${PN}-1.2.98-linux3.patch" \
- "${FILESDIR}/${P}-libav-9.patch"
-
- python_convert_shebangs -r 2 .
-}
-
-src_configure() {
- local myconf
-
- if use admin ; then
- myconf="${myconf} --enable-admin --with-python=$(PYTHON -2)"
- else
- myconf="${myconf} --disable-admin --without-python"
- fi
-
- # Uses autodetect because --with-php requires path to php-{fpm,cgi}.
- if ! use php ; then
- myconf="${myconf} --without-php"
- fi
-
- if use static ; then
- myconf="${myconf} --enable-static-module=all"
- fi
-
- local os="Unknown"
- case "${CHOST}" in
- *-freebsd*)
- os="FreeBSD" ;;
- *-netbsd*)
- os="NetBSD" ;;
- *-openbsd*)
- os="OpenBSD" ;;
- *)
- os="Linux" ;;
- esac
-
- # This make cherokee 1.2 sad
- # $(use_enable threads pthread) \
- econf \
- $(use_enable debug trace) \
- $(use_enable debug backtraces) \
- $(use_enable ipv6) \
- $(use_enable kernel_linux epoll) \
- $(use_enable nls) \
- $(use_enable pam) \
- $(use_enable static-libs static) \
- $(use_with ffmpeg) \
- $(use_with geoip) \
- $(use_with ldap) \
- $(use_with mysql) \
- $(use_with ssl libssl) \
- --disable-dependency-tracking \
- --docdir="${EPREFIX}/usr/share/doc/${PF}/html" \
- --enable-os-string="Gentoo ${os}" \
- --enable-tmpdir="${EPREFIX}/var/tmp" \
- --localstatedir="${EPREFIX}/var" \
- --with-wwwroot="${EPREFIX}${WEBROOT}/htdocs" \
- --with-cgiroot="${EPREFIX}${WEBROOT}/cgi-bin" \
- --with-wwwuser=cherokee \
- --with-wwwgroup=cherokee \
- ${myconf}
-}
-
-src_install() {
- emake DESTDIR="${D}" install
-
- if ! use static-libs ; then
- find "${ED}" -name '*.la' -delete || die
- elif ! use static ; then
- find "${ED}/usr/$(get_libdir)/cherokee" '(' -name '*.la' -o -name '*.a' ')' -delete || die
- fi
-
- dodoc AUTHORS ChangeLog README
-
- if use pam ; then
- pamd_mimic system-auth cherokee auth account session || die
- fi
-
- newinitd "${FILESDIR}/${PN}-initd-1.2.99" ${PN}
- newconfd "${FILESDIR}/${PN}-confd-1.2.98" ${PN}
-
- if ! use admin ; then
- rm -r \
- "${ED}"/usr/bin/cherokee-admin-launcher \
- "${ED}"/usr/bin/CTK-run \
- "${ED}"/usr/sbin/cherokee-admin \
- "${ED}"/usr/share/cherokee/admin || die
- fi
-
- exeinto /usr/share/doc/${PF}/contrib
- doexe contrib/{bin2buffer.py,make-cert.sh,make-dh_params.sh,tracelor.py}
-
- #move the htdocs to docdir, bug #429632
- docompress -x /usr/share/doc/"${PF}"/htdocs.dist
- mv "${ED}"${WEBROOT}/htdocs \
- "${ED}"/usr/share/doc/"${PF}"/htdocs.dist
- mkdir "${ED}"${WEBROOT}/htdocs
-
- keepdir \
- "${WEBROOT}"/htdocs \
- /var/log/cherokee \
- /var/lib/cherokee/graphs/images
- fowners cherokee:cherokee \
- /var/log/cherokee \
- /var/lib/cherokee/graphs \
- /var/lib/cherokee/graphs/images
-
- # logrotate
- insinto /etc/logrotate.d
- newins "${FILESDIR}"/${PN}.logrotate-r1 ${PN}
-
- systemd_dounit "${FILESDIR}"/cherokee.service
-}
-
-pkg_postinst() {
- elog
- if use admin ; then
- python_mod_optimize "${EPREFIX}/usr/share/cherokee/admin/"
- elog "Just run '/usr/sbin/cherokee-admin' and go to: http://localhost:9090"
- elog
- elog "Cherokee currently supports configuration versioning, so from now on,"
- elog "whenever a change is made to the configuration file format,"
- elog "Cherokee-Admin will be able to automatically convert yours to the new"
- elog "release. You simply have to load Cherokee-Admin and it will be converted"
- elog "once you proceed to saving it."
- elog
- elog "There is also a command line utility that you can use to do the exact"
- elog "same thing. Config format can change in different versions. It is"
- elog "provided under:"
- elog " ${EPREFIX}/usr/share/cherokee/admin/upgrade_config.py"
- else
- elog "Try USE=admin if you want an easy way to configure cherokee."
- fi
- elog
- elog "emerge www-servers/spawn-fcgi if you use Ruby on Rails with ${PN}."
- elog
-}
-
-pkg_postrm() {
- if use admin ; then
- python_mod_cleanup "${EPREFIX}/usr/share/cherokee/admin/"
- fi
-}
diff --git a/www-servers/cherokee/files/cherokee-1.2.101-libav-9.patch b/www-servers/cherokee/files/cherokee-1.2.101-libav-9.patch
deleted file mode 100644
index e7ec110d17c3..000000000000
--- a/www-servers/cherokee/files/cherokee-1.2.101-libav-9.patch
+++ /dev/null
@@ -1,29 +0,0 @@
-diff -burN cherokee-1.2.101.old//cherokee/handler_streaming.c cherokee-1.2.101/cherokee/handler_streaming.c
---- cherokee-1.2.101.old//cherokee/handler_streaming.c 2011-10-12 20:07:44.000000000 +0200
-+++ cherokee-1.2.101/cherokee/handler_streaming.c 2012-11-25 18:08:05.606331619 +0100
-@@ -312,14 +312,14 @@
-
- /* Open the media stream
- */
-- re = av_open_input_file (&hdl->avformat, hdl->local_file.buf, NULL, 0, NULL);
-+ re = avformat_open_input (&hdl->avformat, hdl->local_file.buf, NULL, NULL);
- if (re != 0) {
- goto error;
- }
-
- /* Read the info
- */
-- re = av_find_stream_info (hdl->avformat);
-+ re = avformat_find_stream_info (hdl->avformat, NULL);
- if (re < 0) {
- goto error;
- }
-@@ -380,7 +380,7 @@
- if (likely (secs > 0)) {
- long tmp;
-
-- tmp = (hdl->avformat->file_size / secs);
-+ tmp = (avio_size(hdl->avformat->pb) / secs);
- if (tmp > rate) {
- rate = tmp;
- TRACE(ENTRIES, "New rate: %d bytes/s\n", rate);
diff --git a/www-servers/cherokee/files/cherokee-1.2.98-linux3.patch b/www-servers/cherokee/files/cherokee-1.2.98-linux3.patch
deleted file mode 100644
index e1e335264b6c..000000000000
--- a/www-servers/cherokee/files/cherokee-1.2.98-linux3.patch
+++ /dev/null
@@ -1,45 +0,0 @@
-diff -Naur cherokee-1.2.98.orig/admin/SystemStats.py cherokee-1.2.98/admin/SystemStats.py
---- cherokee-1.2.98.orig/admin/SystemStats.py 2011-05-03 18:01:41.000000000 +0900
-+++ cherokee-1.2.98/admin/SystemStats.py 2011-08-26 13:05:08.128851462 +0900
-@@ -39,7 +39,7 @@
- global _stats
-
- if not _stats:
-- if sys.platform == 'linux2':
-+ if sys.platform == 'linux2' or sys.platform == 'linux3':
- _stats = System_stats__Linux()
- elif sys.platform == 'darwin':
- _stats = System_stats__Darwin()
-diff -Naur cherokee-1.2.98.orig/admin/market/InstallUtil.py cherokee-1.2.98/admin/market/InstallUtil.py
---- cherokee-1.2.98.orig/admin/market/InstallUtil.py 2011-05-03 18:01:41.000000000 +0900
-+++ cherokee-1.2.98/admin/market/InstallUtil.py 2011-08-26 13:05:06.596844132 +0900
-@@ -56,7 +56,7 @@
- first_group = str(root_group)
-
- # Systems
-- if sys.platform == 'linux2':
-+ if sys.platform == 'linux2' or sys.platform == 'linux3':
- if os.getuid() == 0:
- return root_group
- return first_group
-@@ -72,7 +72,7 @@
-
-
- def current_UID_is_admin():
-- if sys.platform == 'linux2':
-+ if sys.platform == 'linux2' or sys.platform == 'linux3':
- return os.getuid() == 0
- elif sys.platform == 'darwin':
- return os.getuid() == 0
-diff -Naur cherokee-1.2.98.orig/admin/util.py cherokee-1.2.98/admin/util.py
---- cherokee-1.2.98.orig/admin/util.py 2011-03-31 17:30:04.000000000 +0900
-+++ cherokee-1.2.98/admin/util.py 2011-08-26 13:05:04.622834682 +0900
-@@ -341,7 +341,7 @@
- def os_get_document_root():
- if sys.platform == 'darwin':
- return "/Library/WebServer/Documents"
-- elif sys.platform == 'linux2':
-+ elif sys.platform == 'linux2' or sys.platform == 'linux3':
- if os.path.exists ("/etc/redhat-release"):
- return '/var/www'
- elif os.path.exists ("/etc/fedora-release"):