summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2014-04-16 14:12:00 +0000
committerLars Wendler <polynomial-c@gentoo.org>2014-04-16 14:12:00 +0000
commit4f4d40f63632cec28d48a1073c2881ea53f8870f (patch)
treec7122f4b348bd32e345e81f175aa41e337dd6150 /www-servers
parentVersion bump. Removed old (diff)
downloadgentoo-2-4f4d40f63632cec28d48a1073c2881ea53f8870f.tar.gz
gentoo-2-4f4d40f63632cec28d48a1073c2881ea53f8870f.tar.bz2
gentoo-2-4f4d40f63632cec28d48a1073c2881ea53f8870f.zip
Version bump. Removed old
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key 0x981CA6FC)
Diffstat (limited to 'www-servers')
-rw-r--r--www-servers/apache/ChangeLog8
-rw-r--r--www-servers/apache/apache-2.2.27.ebuild126
-rw-r--r--www-servers/apache/apache-2.4.7.ebuild245
3 files changed, 133 insertions, 246 deletions
diff --git a/www-servers/apache/ChangeLog b/www-servers/apache/ChangeLog
index c669eca98127..731e5f9d6283 100644
--- a/www-servers/apache/ChangeLog
+++ b/www-servers/apache/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for www-servers/apache
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-servers/apache/ChangeLog,v 1.260 2014/03/18 18:50:08 polynomial-c Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-servers/apache/ChangeLog,v 1.261 2014/04/16 14:12:00 polynomial-c Exp $
+
+*apache-2.2.27 (16 Apr 2014)
+
+ 16 Apr 2014; Lars Wendler <polynomial-c@gentoo.org> +apache-2.2.27.ebuild,
+ -apache-2.4.7.ebuild:
+ Version bump. Removed old.
*apache-2.4.9 (18 Mar 2014)
diff --git a/www-servers/apache/apache-2.2.27.ebuild b/www-servers/apache/apache-2.2.27.ebuild
new file mode 100644
index 000000000000..54bdc1d2c049
--- /dev/null
+++ b/www-servers/apache/apache-2.2.27.ebuild
@@ -0,0 +1,126 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-servers/apache/apache-2.2.27.ebuild,v 1.1 2014/04/16 14:12:00 polynomial-c Exp $
+
+EAPI=5
+
+# latest gentoo apache files
+GENTOO_PATCHSTAMP="20121012"
+GENTOO_DEVELOPER="patrick"
+GENTOO_PATCHNAME="gentoo-apache-2.2.23"
+
+# IUSE/USE_EXPAND magic
+IUSE_MPMS_FORK="itk peruser prefork"
+IUSE_MPMS_THREAD="event worker"
+
+IUSE_MODULES="actions alias asis auth_basic auth_digest authn_alias authn_anon
+authn_dbd authn_dbm authn_default authn_file authz_dbm authz_default
+authz_groupfile authz_host authz_owner authz_user autoindex cache cern_meta
+charset_lite cgi cgid dav dav_fs dav_lock dbd deflate dir disk_cache dumpio
+env expires ext_filter file_cache filter headers ident imagemap include info
+log_config log_forensic logio mem_cache mime mime_magic negotiation proxy
+proxy_ajp proxy_balancer proxy_connect proxy_ftp proxy_http proxy_scgi rewrite
+reqtimeout setenvif speling status substitute unique_id userdir usertrack
+version vhost_alias"
+# The following are also in the source as of this version, but are not available
+# for user selection:
+# bucketeer case_filter case_filter_in echo http isapi optional_fn_export
+# optional_fn_import optional_hook_export optional_hook_import
+
+# inter-module dependencies
+# TODO: this may still be incomplete
+MODULE_DEPENDS="
+ dav_fs:dav
+ dav_lock:dav
+ deflate:filter
+ disk_cache:cache
+ ext_filter:filter
+ file_cache:cache
+ log_forensic:log_config
+ logio:log_config
+ mem_cache:cache
+ mime_magic:mime
+ proxy_ajp:proxy
+ proxy_balancer:proxy
+ proxy_connect:proxy
+ proxy_ftp:proxy
+ proxy_http:proxy
+ proxy_scgi:proxy
+ substitute:filter
+"
+
+# module<->define mappings
+MODULE_DEFINES="
+ auth_digest:AUTH_DIGEST
+ authnz_ldap:AUTHNZ_LDAP
+ cache:CACHE
+ dav:DAV
+ dav_fs:DAV
+ dav_lock:DAV
+ disk_cache:CACHE
+ file_cache:CACHE
+ info:INFO
+ ldap:LDAP
+ mem_cache:CACHE
+ proxy:PROXY
+ proxy_ajp:PROXY
+ proxy_balancer:PROXY
+ proxy_connect:PROXY
+ proxy_ftp:PROXY
+ proxy_http:PROXY
+ ssl:SSL
+ status:STATUS
+ suexec:SUEXEC
+ userdir:USERDIR
+"
+
+# critical modules for the default config
+MODULE_CRITICAL="
+ authz_host
+ dir
+ mime
+"
+
+inherit apache-2 systemd toolchain-funcs
+
+DESCRIPTION="The Apache Web Server."
+HOMEPAGE="http://httpd.apache.org/"
+
+# some helper scripts are Apache-1.1, thus both are here
+LICENSE="Apache-2.0 Apache-1.1"
+SLOT="2"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~sparc-fbsd ~x86-fbsd"
+IUSE=""
+
+DEPEND="${DEPEND}
+ >=dev-libs/openssl-0.9.8m
+ apache2_modules_deflate? ( sys-libs/zlib )"
+
+# dependency on >=dev-libs/apr-1.4.5 for bug #368651
+RDEPEND="${RDEPEND}
+ >=dev-libs/apr-1.4.5
+ >=dev-libs/openssl-0.9.8m
+ apache2_modules_mime? ( app-misc/mime-types )"
+
+# init script fixup - should be rolled into next tarball #389965
+src_prepare() {
+ apache-2_src_prepare
+ pushd "${GENTOO_PATCHDIR}" &>/dev/null || die
+ epatch "${FILESDIR}"/gentoo-apache-2.2.23-initd_fixups.patch
+ popd &>/dev/null || die
+ cp "${FILESDIR}"/2.2.22-envvars-std.in "${S}"/support/envvars-std.in || die "Failed to apply LD_PRELOAD fix"
+}
+
+src_configure() {
+ # Brain dead check.
+ tc-is-cross-compiler && export ap_cv_void_ptr_lt_long="no"
+
+ apache-2_src_configure
+}
+
+src_install() {
+ apache-2_src_install
+
+ systemd_newunit "${FILESDIR}/apache2.2.service" "apache2.service"
+ systemd_dotmpfilesd "${FILESDIR}/apache.conf"
+}
diff --git a/www-servers/apache/apache-2.4.7.ebuild b/www-servers/apache/apache-2.4.7.ebuild
deleted file mode 100644
index 1141ddd0bc9a..000000000000
--- a/www-servers/apache/apache-2.4.7.ebuild
+++ /dev/null
@@ -1,245 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-servers/apache/apache-2.4.7.ebuild,v 1.8 2014/02/19 09:20:39 polynomial-c Exp $
-
-EAPI=5
-
-# latest gentoo apache files
-GENTOO_PATCHSTAMP="20130801"
-GENTOO_DEVELOPER="kensington"
-GENTOO_PATCHNAME="gentoo-apache-2.4.4"
-
-# IUSE/USE_EXPAND magic
-IUSE_MPMS_FORK="itk peruser prefork"
-IUSE_MPMS_THREAD="event worker"
-
-# << obsolete modules:
-# authn_default authz_default mem_cache
-# mem_cache is replaced by cache_disk
-# ?? buggy modules
-# proxy_scgi: startup error: undefined symbol "ap_proxy_release_connection", no fix found
-# >> added modules for reason:
-# compat: compatibility with 2.2 access control
-# authz_host: new module for access control
-# authn_core: functionality provided by authn_alias in previous versions
-# authz_core: new module, provides core authorization capabilities
-# cache_disk: replacement for mem_cache
-# lbmethod_byrequests: Split off from mod_proxy_balancer in 2.3
-# lbmethod_bytraffic: Split off from mod_proxy_balancer in 2.3
-# lbmethod_bybusyness: Split off from mod_proxy_balancer in 2.3
-# lbmethod_heartbeat: Split off from mod_proxy_balancer in 2.3
-# slotmem_shm: Slot-based shared memory provider (for lbmethod_byrequests).
-# socache_shmcb: shared object cache provider. Default config with ssl needs it
-# unixd: fixes startup error: Invalid command 'User'
-IUSE_MODULES="access_compat actions alias asis auth_basic auth_digest authn_alias authn_anon
-authn_core authn_dbd authn_dbm authn_file authz_core authz_dbm
-authz_groupfile authz_host authz_owner authz_user autoindex cache cache_disk cern_meta
-charset_lite cgi cgid dav dav_fs dav_lock dbd deflate dir dumpio
-env expires ext_filter file_cache filter headers ident imagemap include info
-lbmethod_byrequests lbmethod_bytraffic lbmethod_bybusyness lbmethod_heartbeat
-log_config log_forensic logio mime mime_magic negotiation proxy
-proxy_ajp proxy_balancer proxy_connect proxy_ftp proxy_http proxy_scgi proxy_fcgi
-rewrite ratelimit remoteip reqtimeout setenvif slotmem_shm speling socache_shmcb status substitute
-unique_id userdir usertrack unixd version vhost_alias"
-# The following are also in the source as of this version, but are not available
-# for user selection:
-# bucketeer case_filter case_filter_in echo http isapi optional_fn_export
-# optional_fn_import optional_hook_export optional_hook_import
-
-# inter-module dependencies
-# TODO: this may still be incomplete
-MODULE_DEPENDS="
- dav_fs:dav
- dav_lock:dav
- deflate:filter
- cache_disk:cache
- ext_filter:filter
- file_cache:cache
- lbmethod_byrequests:proxy_balancer
- lbmethod_byrequests:slotmem_shm
- lbmethod_bytraffic:proxy_balancer
- lbmethod_bybusyness:proxy_balancer
- lbmethod_heartbeat:proxy_balancer
- log_forensic:log_config
- logio:log_config
- cache_disk:cache
- mime_magic:mime
- proxy_ajp:proxy
- proxy_balancer:proxy
- proxy_balancer:slotmem_shm
- proxy_connect:proxy
- proxy_ftp:proxy
- proxy_http:proxy
- proxy_scgi:proxy
- proxy_fcgi:proxy
- substitute:filter
-"
-
-# module<->define mappings
-MODULE_DEFINES="
- auth_digest:AUTH_DIGEST
- authnz_ldap:AUTHNZ_LDAP
- cache:CACHE
- cache_disk:CACHE
- dav:DAV
- dav_fs:DAV
- dav_lock:DAV
- file_cache:CACHE
- info:INFO
- ldap:LDAP
- proxy:PROXY
- proxy_ajp:PROXY
- proxy_balancer:PROXY
- proxy_connect:PROXY
- proxy_ftp:PROXY
- proxy_http:PROXY
- proxy_fcgi:PROXY
- proxy_scgi:PROXY
- socache_shmcb:SSL
- ssl:SSL
- status:STATUS
- suexec:SUEXEC
- userdir:USERDIR
-"
-
-# critical modules for the default config
-MODULE_CRITICAL="
- authn_core
- authz_core
- authz_host
- dir
- mime
- unixd
-"
-inherit eutils apache-2 systemd toolchain-funcs
-
-DESCRIPTION="The Apache Web Server."
-HOMEPAGE="http://httpd.apache.org/"
-
-# some helper scripts are Apache-1.1, thus both are here
-LICENSE="Apache-2.0 Apache-1.1"
-SLOT="2"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~sparc-fbsd ~x86-fbsd"
-IUSE=""
-
-DEPEND="${DEPEND}
- >=dev-libs/openssl-0.9.8m
- apache2_modules_deflate? ( sys-libs/zlib )"
-
-# dependency on >=dev-libs/apr-1.5.0 for bug #492578
-RDEPEND="${RDEPEND}
- >=dev-libs/apr-1.5.0
- >=dev-libs/openssl-0.9.8m
- apache2_modules_mime? ( app-misc/mime-types )"
-
-pkg_setup() {
- # dependend critical modules which are not allowed in global scope due
- # to USE flag conditionals (bug #499260)
- use ssl && MODULE_CRITICAL+=" socache_shmcb"
- use doc && MODULE_CRITICAL+=" alias negotiation setenvif"
- apache-2_pkg_setup
-}
-
-# init script fixup - should be rolled into next tarball #389965
-src_prepare() {
- # the following patch can be removed once it is included in
- # GENTOO_PATCHNAME="gentoo-apache-2.4.1" ...
- if [ -f "${FILESDIR}/${GENTOO_PATCHNAME}-${GENTOO_DEVELOPER}-${GENTOO_PATCHSTAMP}-${PVR}.patch" ]; then
- cd "${GENTOO_PATCHDIR}" || die "Failed to cd to ${GENTOO_PATCHDIR}"
- epatch "${FILESDIR}/${GENTOO_PATCHNAME}-${GENTOO_DEVELOPER}-${GENTOO_PATCHSTAMP}-${PVR}.patch"
- cd "${S}" || die "Failed to cd to ${S}"
- fi
- apache-2_src_prepare
- pushd "${GENTOO_PATCHDIR}" &>/dev/null || die
- epatch "${FILESDIR}"/gentoo-apache-2.2.23-initd_fixups.patch
- popd &>/dev/null || die
-}
-
-src_configure() {
- # Brain dead check.
- tc-is-cross-compiler && export ap_cv_void_ptr_lt_long="no"
-
- apache-2_src_configure
-}
-
-src_compile() {
- if tc-is-cross-compiler; then
- # This header is the same across targets, so use the build compiler.
- pushd server >/dev/null
- emake gen_test_char
- tc-export_build_env BUILD_CC
- ${BUILD_CC} ${BUILD_CFLAGS} ${BUILD_CPPFLAGS} ${BUILD_LDFLAGS} \
- gen_test_char.c -o gen_test_char $(apr-1-config --includes) || die
- popd >/dev/null
- fi
-
- default
-}
-
-src_install() {
- apache-2_src_install
- for i in /usr/bin/{htdigest,logresolve,htpasswd,htdbm,ab,httxt2dbm}; do
- rm "${D}"/$i || die "Failed to prune apache-tools bits"
- done
- for i in /usr/share/man/man8/{rotatelogs.8,htcacheclean.8}; do
- rm "${D}"/$i || die "Failed to prune apache-tools bits"
- done
- for i in /usr/share/man/man1/{logresolve.1,htdbm.1,htdigest.1,htpasswd.1,dbmmanage.1,ab.1}; do
- rm "${D}"/$i || die "Failed to prune apache-tools bits"
- done
- for i in /usr/sbin/{checkgid,fcgistarter,htcacheclean,rotatelogs}; do
- rm "${D}/"$i || die "Failed to prune apache-tools bits"
- done
-
- # well, actually installing things makes them more installed, I guess?
- cp "${S}"/support/apxs "${D}"/usr/sbin/apxs || die "Failed to install apxs"
- chmod 0755 "${D}"/usr/sbin/apxs
-
- # Note: wait for mod_systemd to be included in the next release,
- # then apache2.4.service can be used and systemd support controlled
- # through --enable-systemd
- systemd_newunit "${FILESDIR}/apache2.2.service" "apache2.service"
- systemd_dotmpfilesd "${FILESDIR}/apache.conf"
- #insinto /etc/apache2/modules.d
- #doins "${FILESDIR}/00_systemd.conf"
-}
-
-pkg_postinst()
-{
- apache-2_pkg_postinst || die "apache-2_pkg_postinst failed"
- # warnings that default config might not work out of the box
- for mod in $MODULE_CRITICAL; do
- if ! use "apache2_modules_${mod}"; then
- echo
- ewarn "Warning: Critical module not installed!"
- ewarn "Modules 'authn_core', 'authz_core' and 'unixd'"
- ewarn "are highly recomended but might not be in the base profile yet."
- ewarn "Default config for ssl needs module 'socache_shmcb'."
- ewarn "Enabling the following flags is highly recommended:"
- for cmod in $MODULE_CRITICAL; do
- use "apache2_modules_${cmod}" || \
- ewarn "+ apache2_modules_${cmod}"
- done
- echo
- break
- fi
- done
- # warning for proxy_balancer and missing load balancing scheduler
- if use apache2_modules_proxy_balancer; then
- local lbset=
- for mod in lbmethod_byrequests lbmethod_bytraffic lbmethod_bybusyness lbmethod_heartbeat; do
- if use "apache2_modules_${mod}"; then
- lbset=1 && break
- fi
- done
- if [ ! $lbset ]; then
- echo
- ewarn "Info: Missing load balancing scheduler algorithm module"
- ewarn "(They were split off from proxy_balancer in 2.3)"
- ewarn "In order to get the ability of load balancing, at least"
- ewarn "one of these modules has to be present:"
- ewarn "lbmethod_byrequests lbmethod_bytraffic lbmethod_bybusyness lbmethod_heartbeat"
- echo
- fi
- fi
-}