summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBenedikt Boehm <hollow@gentoo.org>2008-08-29 13:31:04 +0000
committerBenedikt Boehm <hollow@gentoo.org>2008-08-29 13:31:04 +0000
commit3732691aa664a9be8ebe31abc5753af8e2d5e997 (patch)
tree6dac4562ff64689a0d7fe0dbbd46e12def9c5c4a /www-servers
parentremove unsupported --with-perl; add message for BSD users (diff)
downloadgentoo-2-3732691aa664a9be8ebe31abc5753af8e2d5e997.tar.gz
gentoo-2-3732691aa664a9be8ebe31abc5753af8e2d5e997.tar.bz2
gentoo-2-3732691aa664a9be8ebe31abc5753af8e2d5e997.zip
fix #230690, #232083, #234088, #235152
(Portage version: 2.2_rc8/cvs/Linux 2.6.22-vs2.2.0.6-gentoo x86_64)
Diffstat (limited to 'www-servers')
-rw-r--r--www-servers/apache/ChangeLog7
-rw-r--r--www-servers/apache/apache-2.2.9-r1.ebuild110
2 files changed, 116 insertions, 1 deletions
diff --git a/www-servers/apache/ChangeLog b/www-servers/apache/ChangeLog
index 871997a4e258..3d0ecf4f5639 100644
--- a/www-servers/apache/ChangeLog
+++ b/www-servers/apache/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for www-servers/apache
# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-servers/apache/ChangeLog,v 1.83 2008/08/22 22:21:41 cardoe Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-servers/apache/ChangeLog,v 1.84 2008/08/29 13:31:04 hollow Exp $
+
+*apache-2.2.9-r1 (29 Aug 2008)
+
+ 29 Aug 2008; Benedikt Böhm <hollow@gentoo.org> +apache-2.2.9-r1.ebuild:
+ fix #230690, #232083, #234088, #235152
22 Aug 2008; Doug Goldstein <cardoe@gentoo.org> metadata.xml:
add GLEP 56 USE flag desc from use.local.desc
diff --git a/www-servers/apache/apache-2.2.9-r1.ebuild b/www-servers/apache/apache-2.2.9-r1.ebuild
new file mode 100644
index 000000000000..3ceb5d6b3f54
--- /dev/null
+++ b/www-servers/apache/apache-2.2.9-r1.ebuild
@@ -0,0 +1,110 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-servers/apache/apache-2.2.9-r1.ebuild,v 1.1 2008/08/29 13:31:04 hollow Exp $
+
+# latest gentoo apache files
+GENTOO_PATCHSTAMP="20080829"
+GENTOO_DEVELOPER="hollow"
+
+# IUSE/USE_EXPAND magic
+IUSE_MPMS_FORK="itk peruser prefork"
+IUSE_MPMS_THREAD="event worker"
+
+IUSE_MODULES="actions alias asis auth_basic auth_digest authn_alias authn_anon
+authn_dbd authn_dbm authn_default authn_file authz_dbm authz_default
+authz_groupfile authz_host authz_owner authz_user autoindex cache cern_meta
+charset_lite dav dav_fs dav_lock dbd deflate dir disk_cache dumpio env expires
+ext_filter file_cache filter headers ident imagemap include info log_config
+log_forensic logio mem_cache mime mime_magic negotiation proxy proxy_ajp
+proxy_balancer proxy_connect proxy_ftp proxy_http rewrite setenvif speling
+status substitute unique_id userdir usertrack version vhost_alias"
+
+# inter-module dependencies
+# TODO: this may still be incomplete
+MODULE_DEPENDS="
+ dav_fs:dav
+ dav_lock:dav
+ deflate:filter
+ disk_cache:cache
+ ext_filter:filter
+ file_cache:cache
+ log_forensic:log_config
+ logio:log_config
+ mem_cache:cache
+ mime_magic:mime
+ proxy_ajp:proxy
+ proxy_balancer:proxy
+ proxy_connect:proxy
+ proxy_ftp:proxy
+ proxy_http:proxy
+ substitute:filter
+"
+
+# module<->define mappings
+MODULE_DEFINES="
+ auth_digest:AUTH_DIGEST
+ authnz_ldap:AUTHNZ_LDAP
+ cache:CACHE
+ dav:DAV
+ dav_fs:DAV
+ dav_lock:DAV
+ disk_cache:CACHE
+ file_cache:CACHE
+ info:INFO
+ ldap:LDAP
+ mem_cache:CACHE
+ proxy:PROXY
+ proxy_ajp:PROXY
+ proxy_balancer:PROXY
+ proxy_connect:PROXY
+ proxy_ftp:PROXY
+ proxy_http:PROXY
+ ssl:SSL
+ status:STATUS
+ suexec:SUEXEC
+ userdir:USERDIR
+"
+
+# critical modules for the default config
+MODULE_CRITICAL="
+ authz_host
+ dir
+ mime
+"
+
+inherit apache-2
+
+DESCRIPTION="The Apache Web Server."
+HOMEPAGE="http://httpd.apache.org/"
+
+# some helper scripts are Apache-1.1, thus both are here
+LICENSE="Apache-2.0 Apache-1.1"
+SLOT="2"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~sparc-fbsd ~x86 ~x86-fbsd"
+IUSE="sni"
+
+DEPEND="${DEPEND}
+ apache2_modules_deflate? ( sys-libs/zlib )"
+
+RDEPEND="${RDEPEND}
+ apache2_modules_mime? ( app-misc/mime-types )"
+
+src_unpack() {
+ if ! use sni ; then
+ EPATCH_EXCLUDE="04_all_mod_ssl_tls_sni.patch"
+ fi
+
+ apache-2_src_unpack
+}
+
+pkg_preinst() {
+ # note regarding IfDefine changes
+ if has_version "<${CATEGORY}/${PN}-2.2.6-r1"; then
+ elog
+ elog "When upgrading from versions 2.2.6 or earlier, please be aware"
+ elog "that the define for mod_authnz_ldap has changed from AUTH_LDAP"
+ elog "to AUTHNZ_LDAP. Additionally mod_auth_digest needs to be enabled"
+ elog "with AUTH_DIGEST now."
+ elog
+ fi
+}