summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThilo Bangert <bangert@gentoo.org>2009-01-27 19:39:52 +0000
committerThilo Bangert <bangert@gentoo.org>2009-01-27 19:39:52 +0000
commit319aeeec9f8560ac5bce90a9b52554a5ce964177 (patch)
tree7fee61bdfbe6cce2b1233296e7ae5c45e02d266f /www-servers
parentInitial import of libmsn (diff)
downloadgentoo-2-319aeeec9f8560ac5bce90a9b52554a5ce964177.tar.gz
gentoo-2-319aeeec9f8560ac5bce90a9b52554a5ce964177.tar.bz2
gentoo-2-319aeeec9f8560ac5bce90a9b52554a5ce964177.zip
version bump
(Portage version: 2.2_rc20/cvs/Linux 2.6.28-gentoo i686)
Diffstat (limited to 'www-servers')
-rw-r--r--www-servers/pound/ChangeLog9
-rw-r--r--www-servers/pound/pound-2.4.4.ebuild59
2 files changed, 66 insertions, 2 deletions
diff --git a/www-servers/pound/ChangeLog b/www-servers/pound/ChangeLog
index 626da5a02e37..b7f40478bef9 100644
--- a/www-servers/pound/ChangeLog
+++ b/www-servers/pound/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for www-servers/pound
-# Copyright 2000-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-servers/pound/ChangeLog,v 1.38 2008/08/22 22:36:02 cardoe Exp $
+# Copyright 2000-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/www-servers/pound/ChangeLog,v 1.39 2009/01/27 19:39:52 bangert Exp $
+
+*pound-2.4.4 (27 Jan 2009)
+
+ 27 Jan 2009; Thilo Bangert <bangert@gentoo.org> +pound-2.4.4.ebuild:
+ version bump
22 Aug 2008; Doug Goldstein <cardoe@gentoo.org> metadata.xml:
add GLEP 56 USE flag desc from use.local.desc
diff --git a/www-servers/pound/pound-2.4.4.ebuild b/www-servers/pound/pound-2.4.4.ebuild
new file mode 100644
index 000000000000..a925e6e67f0a
--- /dev/null
+++ b/www-servers/pound/pound-2.4.4.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-servers/pound/pound-2.4.4.ebuild,v 1.1 2009/01/27 19:39:52 bangert Exp $
+
+inherit flag-o-matic
+
+MY_P="${P/p/P}"
+DESCRIPTION="A http/https reverse-proxy and load-balancer."
+SRC_URI="http://www.apsis.ch/pound/${MY_P}.tgz"
+HOMEPAGE="http://www.apsis.ch/pound/"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~mips ~ppc ~sparc ~x86"
+IUSE="ssl dynscaler static"
+
+DEPEND="ssl? ( dev-libs/openssl )"
+
+S="${WORKDIR}/${MY_P}"
+
+src_compile() {
+ use static && append-ldflags -static
+
+ econf \
+ $(use_with ssl) \
+ $(use_enable dynscaler) \
+ || die "configure failed"
+
+ emake || die "compile failed"
+}
+
+src_install() {
+ dodir /usr/sbin
+ cp "${S}"/pound "${D}"/usr/sbin/
+ cp "${S}"/poundctl "${D}"/usr/sbin/
+
+ doman pound.8
+ doman poundctl.8
+ dodoc README FAQ
+
+ dodir /etc/init.d
+ newinitd "${FILESDIR}"/pound.init-1.9 pound
+
+ insinto /etc
+ newins "${FILESDIR}"/pound-2.2.cfg pound.cfg
+}
+
+pkg_postinst() {
+ elog "No demo-/sample-configfile is included in the distribution -"
+ elog "read the man-page for more info."
+ elog "A sample (localhost:8888 -> localhost:80) for gentoo is given in \"/etc/pound.cfg\"."
+ echo
+ ewarn "You will have to upgrade you configuration file, if you are"
+ ewarn "upgrading from a version <= 2.0."
+ echo
+ ewarn "The 'WebDAV' config statement is no longer supported!"
+ ewarn "Please adjust your configuration, if necessary."
+ echo
+}