summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKonstantin V. Arkhipov <voxus@gentoo.org>2007-06-14 07:42:32 +0000
committerKonstantin V. Arkhipov <voxus@gentoo.org>2007-06-14 07:42:32 +0000
commit23678f8b98e1cc407083e729818bfb99e960e8e7 (patch)
tree9ce8a78dc8b6afa0dbd9338ea582160fdbd030ee /www-servers
parentdev-tex/preview-latex no longer in the tree (diff)
downloadgentoo-2-23678f8b98e1cc407083e729818bfb99e960e8e7.tar.gz
gentoo-2-23678f8b98e1cc407083e729818bfb99e960e8e7.tar.bz2
gentoo-2-23678f8b98e1cc407083e729818bfb99e960e8e7.zip
* bump
(Portage version: 2.1.2.9)
Diffstat (limited to 'www-servers')
-rw-r--r--www-servers/nginx/ChangeLog8
-rw-r--r--www-servers/nginx/files/digest-nginx-0.6.03
-rw-r--r--www-servers/nginx/nginx-0.6.0.ebuild99
3 files changed, 109 insertions, 1 deletions
diff --git a/www-servers/nginx/ChangeLog b/www-servers/nginx/ChangeLog
index 8b4065e5f406..274e630b7efb 100644
--- a/www-servers/nginx/ChangeLog
+++ b/www-servers/nginx/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for www-servers/nginx
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-servers/nginx/ChangeLog,v 1.148 2007/06/11 21:38:43 voxus Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-servers/nginx/ChangeLog,v 1.149 2007/06/14 07:42:32 voxus Exp $
+
+*nginx-0.6.0 (14 Jun 2007)
+
+ 14 Jun 2007; Konstantin V. Arkhipov <voxus@gentoo.org>
+ +nginx-0.6.0.ebuild:
+ Version bump.
*nginx-0.5.25 (11 Jun 2007)
diff --git a/www-servers/nginx/files/digest-nginx-0.6.0 b/www-servers/nginx/files/digest-nginx-0.6.0
new file mode 100644
index 000000000000..8c2aeb8e3cfa
--- /dev/null
+++ b/www-servers/nginx/files/digest-nginx-0.6.0
@@ -0,0 +1,3 @@
+MD5 8397d953f4718a78d465de1e5f333c35 nginx-0.6.0.tar.gz 471941
+RMD160 1a0b59d9d04c3e187a3e28409d58ddfba0e8b5c3 nginx-0.6.0.tar.gz 471941
+SHA256 99d7042a66ddd842043beebbe0e09e3da5742f8f5120c91b2c67b42c6bd2b970 nginx-0.6.0.tar.gz 471941
diff --git a/www-servers/nginx/nginx-0.6.0.ebuild b/www-servers/nginx/nginx-0.6.0.ebuild
new file mode 100644
index 000000000000..d7e3188c1948
--- /dev/null
+++ b/www-servers/nginx/nginx-0.6.0.ebuild
@@ -0,0 +1,99 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-servers/nginx/nginx-0.6.0.ebuild,v 1.1 2007/06/14 07:42:32 voxus Exp $
+
+inherit eutils ssl-cert
+
+DESCRIPTION="Robust, small and high performance http and reverse proxy server"
+
+HOMEPAGE="http://sysoev.ru/nginx/"
+SRC_URI="http://sysoev.ru/nginx/${P}.tar.gz"
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="debug fastcgi imap pcre perl ssl status webdav zlib"
+
+DEPEND="dev-lang/perl
+ pcre? ( >=dev-libs/libpcre-4.2 )
+ ssl? ( dev-libs/openssl )
+ zlib? ( sys-libs/zlib )
+ perl? ( >=dev-lang/perl-5.8 )"
+
+pkg_setup() {
+ ebegin "Creating nginx user and group"
+ enewgroup nginx
+ enewuser nginx -1 -1 /dev/null nginx
+ eend ${?}
+}
+
+src_compile() {
+ local myconf
+
+ # threads support is broken atm.
+ #
+ # if use threads; then
+ # einfo
+ # ewarn "threads support is experimental at the moment"
+ # ewarn "do not use it on production systems - you've been warned"
+ # einfo
+ # myconf="${myconf} --with-threads"
+ # fi
+
+ use fastcgi || myconf="${myconf} --without-http_fastcgi_module"
+ use fastcgi && myconf="${myconf} --with-http_realip_module"
+ use zlib || myconf="${myconf} --without-http_gzip_module"
+ use pcre || {
+ myconf="${myconf} --without-pcre --without-http_rewrite_module"
+ }
+ use debug && myconf="${myconf} --with-debug"
+ use ssl && myconf="${myconf} --with-http_ssl_module"
+ use imap && myconf="${myconf} --with-imap" # pop3/imap4 proxy support
+ use perl && myconf="${myconf} --with-http_perl_module"
+ use status && myconf="${myconf} --with-http_stub_status_module"
+ use webdav && myconf="${myconf} --with-http_dav_module"
+
+ ./configure \
+ --prefix=/usr \
+ --conf-path=/etc/${PN}/${PN}.conf \
+ --http-log-path=/var/log/${PN}/access_log \
+ --error-log-path=/var/log/${PN}/error_log \
+ --pid-path=/var/run/${PN}.pid \
+ --http-client-body-temp-path=/var/tmp/${PN}/client \
+ --http-proxy-temp-path=/var/tmp/${PN}/proxy \
+ --http-fastcgi-temp-path=/var/tmp/${PN}/fastcgi \
+ --with-md5-asm --with-md5=/usr/include \
+ ${myconf} || die "configure failed"
+
+ emake || die "failed to compile"
+}
+
+src_install() {
+ keepdir /var/log/${PN} /var/tmp/${PN}/{client,proxy,fastcgi}
+
+ dosbin objs/nginx
+ cp ${FILESDIR}/nginx-r1 ${T}/nginx
+ doinitd ${T}/nginx
+
+ cp ${FILESDIR}/nginx.conf-r4 conf/nginx.conf
+
+ use ssl && {
+ if [ ! -f /etc/ssl/${PN}/${PN}.key ]; then
+ dodir /etc/ssl/${PN}
+ insinto /etc/ssl/${PN}
+ docert ${PN}
+ fi
+
+ sed -e 's:# ::' -i conf/nginx.conf
+ }
+
+ dodir /etc/${PN}
+ insinto /etc/${PN}
+ doins conf/*
+
+ dodoc CHANGES{,.ru} LICENSE README
+
+ use perl && {
+ cd ${S}/objs/src/http/modules/perl/
+ make DESTDIR=${D} install || die "failed to install perl stuff"
+ }
+}