summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThilo Bangert <bangert@gentoo.org>2009-07-03 21:00:38 +0000
committerThilo Bangert <bangert@gentoo.org>2009-07-03 21:00:38 +0000
commit1c84a167769ba16801acc95e8ff1fc88dee6c99e (patch)
treed1c70fc9c95bd9329787bb35a4ed06215ea15c41 /www-servers
parentversion bump (diff)
downloadgentoo-2-1c84a167769ba16801acc95e8ff1fc88dee6c99e.tar.gz
gentoo-2-1c84a167769ba16801acc95e8ff1fc88dee6c99e.tar.bz2
gentoo-2-1c84a167769ba16801acc95e8ff1fc88dee6c99e.zip
make chdir configurable (bug #274573) - thanks Henry So, Jr.
(Portage version: 2.2_rc33/cvs/Linux i686)
Diffstat (limited to 'www-servers')
-rw-r--r--www-servers/spawn-fcgi/ChangeLog6
-rw-r--r--www-servers/spawn-fcgi/files/spawn-fcgi.confd7
-rw-r--r--www-servers/spawn-fcgi/files/spawn-fcgi.initd6
3 files changed, 16 insertions, 3 deletions
diff --git a/www-servers/spawn-fcgi/ChangeLog b/www-servers/spawn-fcgi/ChangeLog
index 1ff72469601b..15132a49b8cc 100644
--- a/www-servers/spawn-fcgi/ChangeLog
+++ b/www-servers/spawn-fcgi/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for www-servers/spawn-fcgi
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-servers/spawn-fcgi/ChangeLog,v 1.17 2009/05/14 18:45:25 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-servers/spawn-fcgi/ChangeLog,v 1.18 2009/07/03 21:00:38 bangert Exp $
+
+ 03 Jul 2009; Thilo Bangert <bangert@gentoo.org> files/spawn-fcgi.confd,
+ files/spawn-fcgi.initd:
+ make chdir configurable (bug #274573)
14 May 2009; Jeroen Roovers <jer@gentoo.org> spawn-fcgi-1.6.2.ebuild:
Marked ~hppa (bug #264840).
diff --git a/www-servers/spawn-fcgi/files/spawn-fcgi.confd b/www-servers/spawn-fcgi/files/spawn-fcgi.confd
index cbc5d000fd12..6605d8610827 100644
--- a/www-servers/spawn-fcgi/files/spawn-fcgi.confd
+++ b/www-servers/spawn-fcgi/files/spawn-fcgi.confd
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-servers/spawn-fcgi/files/spawn-fcgi.confd,v 1.3 2009/04/09 18:56:04 bangert Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-servers/spawn-fcgi/files/spawn-fcgi.confd,v 1.4 2009/07/03 21:00:38 bangert Exp $
# DO NOT MODIFY THIS FILE DIRECTLY! CREATE A COPY AND MODIFY THAT INSTEAD!
@@ -43,6 +43,11 @@ FCGI_CHILDREN=1
#
FCGI_CHROOT=
+# If you want to run your application from a specific directiory specify
+# it here. Leave this blank otherwise.
+#
+FCGI_CHDIR=
+
# The user and group to run your application as. If you do not specify these,
# the application will be run as root:root.
#
diff --git a/www-servers/spawn-fcgi/files/spawn-fcgi.initd b/www-servers/spawn-fcgi/files/spawn-fcgi.initd
index b904485dec6d..7e6c0e263445 100644
--- a/www-servers/spawn-fcgi/files/spawn-fcgi.initd
+++ b/www-servers/spawn-fcgi/files/spawn-fcgi.initd
@@ -1,7 +1,7 @@
#!/sbin/runscript
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-servers/spawn-fcgi/files/spawn-fcgi.initd,v 1.8 2009/04/12 18:00:42 bangert Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-servers/spawn-fcgi/files/spawn-fcgi.initd,v 1.9 2009/07/03 21:00:38 bangert Exp $
PROGNAME=${SVCNAME#*.}
SPAWNFCGI=/usr/bin/spawn-fcgi
@@ -61,6 +61,10 @@ start() {
OPTIONS="${OPTIONS} -c ${FCGI_CHROOT}"
fi
+ if [ -n "${FCGI_DIR}" ]; then
+ OPTIONS="${OPTIONS} -d ${FCGI_DIR}"
+ fi
+
if [ -n "${FCGI_USER}" ] && [ "${FCGI_USER}" != "root" ]; then
OPTIONS="${OPTIONS} -u ${FCGI_USER}"
fi