summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKonstantin V. Arkhipov <voxus@gentoo.org>2006-12-17 13:09:55 +0000
committerKonstantin V. Arkhipov <voxus@gentoo.org>2006-12-17 13:09:55 +0000
commit186017d3d9f58dc7215cdbb5b0fcf2e611ccf398 (patch)
tree521474dd5a7cb96598b89e3ca17133019ffbf1d4 /www-servers
parentAdded newer snapshot. (diff)
downloadgentoo-2-186017d3d9f58dc7215cdbb5b0fcf2e611ccf398.tar.gz
gentoo-2-186017d3d9f58dc7215cdbb5b0fcf2e611ccf398.tar.bz2
gentoo-2-186017d3d9f58dc7215cdbb5b0fcf2e611ccf398.zip
* bump
(Portage version: 2.1.2_rc3-r6)
Diffstat (limited to 'www-servers')
-rw-r--r--www-servers/nginx/ChangeLog8
-rw-r--r--www-servers/nginx/files/digest-nginx-0.5.43
-rw-r--r--www-servers/nginx/nginx-0.5.4.ebuild79
3 files changed, 89 insertions, 1 deletions
diff --git a/www-servers/nginx/ChangeLog b/www-servers/nginx/ChangeLog
index 9bbe4bd662be..16fe40b5fd1d 100644
--- a/www-servers/nginx/ChangeLog
+++ b/www-servers/nginx/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for www-servers/nginx
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-servers/nginx/ChangeLog,v 1.123 2006/12/11 21:46:37 voxus Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-servers/nginx/ChangeLog,v 1.124 2006/12/17 13:09:55 voxus Exp $
+
+*nginx-0.5.4 (17 Dec 2006)
+
+ 17 Dec 2006; Konstantin V. Arkhipov <voxus@gentoo.org>
+ -nginx-0.5.2.ebuild, +nginx-0.5.4.ebuild:
+ Version bump.
*nginx-0.5.2 (11 Dec 2006)
diff --git a/www-servers/nginx/files/digest-nginx-0.5.4 b/www-servers/nginx/files/digest-nginx-0.5.4
new file mode 100644
index 000000000000..8ad087f5750a
--- /dev/null
+++ b/www-servers/nginx/files/digest-nginx-0.5.4
@@ -0,0 +1,3 @@
+MD5 2295a1f9441a0e48c5668544eef03d12 nginx-0.5.4.tar.gz 442554
+RMD160 c2b4c75e74bedd207262e1dca2778cbe37fe0f04 nginx-0.5.4.tar.gz 442554
+SHA256 746ae459965510e6441bfad75b06bb13c0038ea52469a83cc779c14b3bad8373 nginx-0.5.4.tar.gz 442554
diff --git a/www-servers/nginx/nginx-0.5.4.ebuild b/www-servers/nginx/nginx-0.5.4.ebuild
new file mode 100644
index 000000000000..8ff3d594833e
--- /dev/null
+++ b/www-servers/nginx/nginx-0.5.4.ebuild
@@ -0,0 +1,79 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-servers/nginx/nginx-0.5.4.ebuild,v 1.1 2006/12/17 13:09:55 voxus Exp $
+
+inherit eutils
+
+DESCRIPTION="Robust, small and high performance http and reverse proxy server"
+
+HOMEPAGE="http://sysoev.ru/nginx/"
+SRC_URI="http://sysoev.ru/nginx/${P}.tar.gz"
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="debug fastcgi imap pcre perl threads ssl zlib"
+
+DEPEND="dev-lang/perl
+ pcre? ( >=dev-libs/libpcre-4.2 )
+ ssl? ( dev-libs/openssl )
+ zlib? ( sys-libs/zlib )
+ perl? ( >=dev-lang/perl-5.8 )"
+
+src_compile() {
+ local myconf
+
+ if use threads; then
+ einfo
+ ewarn "threads support is experimental at the moment"
+ ewarn "do not use it on production systems - you've been warned"
+ einfo
+ myconf="${myconf} --with-threads"
+ fi
+
+ use fastcgi || myconf="${myconf} --without-http_fastcgi_module"
+ use fastcgi && myconf="${myconf} --with-http_realip_module"
+ use zlib || myconf="${myconf} --without-http_gzip_module"
+ use pcre || {
+ myconf="${myconf} --without-pcre --without-http_rewrite_module"
+ }
+ use debug && myconf="${myconf} --with-debug"
+ use ssl && myconf="${myconf} --with-http_ssl_module"
+ use imap && myconf="${myconf} --with-imap" # pop3/imap4 proxy support
+ use perl && myconf="${myconf} --with-http_perl_module"
+
+ ./configure \
+ --prefix=/usr \
+ --conf-path=/etc/${PN}/${PN}.conf \
+ --http-log-path=/var/log/${PN}/access_log \
+ --error-log-path=/var/log/${PN}/error_log \
+ --pid-path=/var/run/${PN}.pid \
+ --http-client-body-temp-path=/var/tmp/${PN}/client \
+ --http-proxy-temp-path=/var/tmp/${PN}/proxy \
+ --http-fastcgi-temp-path=/var/tmp/${PN}/fastcgi \
+ --with-md5-asm --with-md5=/usr/include \
+ ${myconf} || die "configure failed"
+
+ emake || die "failed to compile"
+}
+
+src_install() {
+ keepdir /var/log/${PN} /var/tmp/${PN}/{client,proxy,fastcgi}
+
+ dosbin objs/nginx
+ cp ${FILESDIR}/nginx-r1 ${T}/nginx
+ doinitd ${T}/nginx
+
+ rm conf/nginx.conf
+ cp ${FILESDIR}/nginx.conf-r2 ${T}/nginx.conf
+
+ dodir /etc/${PN}
+ insinto /etc/${PN}
+ doins conf/* ${T}/nginx.conf
+
+ dodoc CHANGES{,.ru} LICENSE README
+
+ use perl && {
+ cd ${S}/objs/src/http/modules/perl/
+ make DESTDIR=${D} install || die "failed to install perl stuff"
+ }
+}