summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKonstantin V. Arkhipov <voxus@gentoo.org>2006-10-07 11:44:16 +0000
committerKonstantin V. Arkhipov <voxus@gentoo.org>2006-10-07 11:44:16 +0000
commit122a6bc39105888b47f7933e56071e02afcef6d3 (patch)
tree350d28927266be00eba66fa9b73689d4ee8bd9d5 /www-servers
parentVersion bump, fixes bugs #132417, #137582, #149911. (diff)
downloadgentoo-2-122a6bc39105888b47f7933e56071e02afcef6d3.tar.gz
gentoo-2-122a6bc39105888b47f7933e56071e02afcef6d3.tar.bz2
gentoo-2-122a6bc39105888b47f7933e56071e02afcef6d3.zip
* 0.4.5 actually removed
(Portage version: 2.1.2_pre2-r5)
Diffstat (limited to 'www-servers')
-rw-r--r--www-servers/nginx/files/digest-nginx-0.4.53
-rw-r--r--www-servers/nginx/nginx-0.4.5.ebuild79
2 files changed, 0 insertions, 82 deletions
diff --git a/www-servers/nginx/files/digest-nginx-0.4.5 b/www-servers/nginx/files/digest-nginx-0.4.5
deleted file mode 100644
index 572640c3dfb9..000000000000
--- a/www-servers/nginx/files/digest-nginx-0.4.5
+++ /dev/null
@@ -1,3 +0,0 @@
-MD5 894a7834418ab102879aa97c1207f81a nginx-0.4.5.tar.gz 427266
-RMD160 7f08934b26de98e627515873e3ab387ae99c8b5c nginx-0.4.5.tar.gz 427266
-SHA256 c3daa81302fbf2d0484592fb1a7239c0fd20b9788766d0aa838da2b76fa2c51a nginx-0.4.5.tar.gz 427266
diff --git a/www-servers/nginx/nginx-0.4.5.ebuild b/www-servers/nginx/nginx-0.4.5.ebuild
deleted file mode 100644
index aa48f6778344..000000000000
--- a/www-servers/nginx/nginx-0.4.5.ebuild
+++ /dev/null
@@ -1,79 +0,0 @@
-# Copyright 1999-2006 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-servers/nginx/nginx-0.4.5.ebuild,v 1.1 2006/10/03 08:51:46 voxus Exp $
-
-inherit eutils
-
-DESCRIPTION="Robust, small and high performance http and reverse proxy server"
-
-HOMEPAGE="http://sysoev.ru/nginx/"
-SRC_URI="http://sysoev.ru/nginx/${P}.tar.gz"
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc ~x86"
-IUSE="debug fastcgi imap pcre perl threads ssl zlib"
-
-DEPEND="dev-lang/perl
- pcre? ( >=dev-libs/libpcre-4.2 )
- ssl? ( dev-libs/openssl )
- zlib? ( sys-libs/zlib )
- perl? ( >=dev-lang/perl-5.8 )"
-
-src_compile() {
- local myconf
-
- if use threads; then
- einfo
- ewarn "threads support is experimental at the moment"
- ewarn "do not use it on production systems - you've been warned"
- einfo
- myconf="${myconf} --with-threads"
- fi
-
- use fastcgi || myconf="${myconf} --without-http_fastcgi_module"
- use fastcgi && myconf="${myconf} --with-http_realip_module"
- use zlib || myconf="${myconf} --without-http_gzip_module"
- use pcre || {
- myconf="${myconf} --without-pcre --without-http_rewrite_module"
- }
- use debug && myconf="${myconf} --with-debug"
- use ssl && myconf="${myconf} --with-http_ssl_module"
- use imap && myconf="${myconf} --with-imap" # pop3/imap4 proxy support
- use perl && myconf="${myconf} --with-http_perl_module"
-
- ./configure \
- --prefix=/usr \
- --conf-path=/etc/${PN}/${PN}.conf \
- --http-log-path=/var/log/${PN}/access_log \
- --error-log-path=/var/log/${PN}/error_log \
- --pid-path=/var/run/${PN}.pid \
- --http-client-body-temp-path=/var/tmp/${PN}/client \
- --http-proxy-temp-path=/var/tmp/${PN}/proxy \
- --http-fastcgi-temp-path=/var/tmp/${PN}/fastcgi \
- --with-md5-asm --with-md5=/usr/include \
- ${myconf} || die "configure failed"
-
- emake || die "failed to compile"
-}
-
-src_install() {
- keepdir /var/log/${PN} /var/tmp/${PN}/{client,proxy,fastcgi}
-
- dosbin objs/nginx
- cp ${FILESDIR}/nginx-r1 ${T}/nginx
- doinitd ${T}/nginx
-
- rm conf/nginx.conf
- cp ${FILESDIR}/nginx.conf-r2 ${T}/nginx.conf
-
- dodir /etc/${PN}
- insinto /etc/${PN}
- doins conf/* ${T}/nginx.conf
-
- dodoc CHANGES{,.ru} LICENSE README
-
- use perl && {
- cd ${S}/objs/src/http/modules/perl/
- make DESTDIR=${D} install || die "failed to install perl stuff"
- }
-}