summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2013-06-16 06:25:28 +0000
committerAnthony G. Basile <blueness@gentoo.org>2013-06-16 06:25:28 +0000
commitb85946a2c2e2ffd79da87e4e37ac8558e6bdb656 (patch)
tree8c522d1def3c69598c91309ad9c37bced45c8605 /www-servers/varnish
parentBump to 0.4, thanks to slepnoga (diff)
downloadgentoo-2-b85946a2c2e2ffd79da87e4e37ac8558e6bdb656.tar.gz
gentoo-2-b85946a2c2e2ffd79da87e4e37ac8558e6bdb656.tar.bz2
gentoo-2-b85946a2c2e2ffd79da87e4e37ac8558e6bdb656.zip
Version bump
(Portage version: 2.1.12.2/cvs/Linux x86_64, signed Manifest commit with key 0xF52D4BBA)
Diffstat (limited to 'www-servers/varnish')
-rw-r--r--www-servers/varnish/ChangeLog8
-rw-r--r--www-servers/varnish/files/varnish-3.0.4-automagic.patch94
-rw-r--r--www-servers/varnish/varnish-3.0.4.ebuild83
3 files changed, 184 insertions, 1 deletions
diff --git a/www-servers/varnish/ChangeLog b/www-servers/varnish/ChangeLog
index 8f1239b3128b..b73ac2fe1612 100644
--- a/www-servers/varnish/ChangeLog
+++ b/www-servers/varnish/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for www-servers/varnish
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-servers/varnish/ChangeLog,v 1.57 2013/03/19 22:22:03 blueness Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-servers/varnish/ChangeLog,v 1.58 2013/06/16 06:25:28 blueness Exp $
+
+*varnish-3.0.4 (16 Jun 2013)
+
+ 16 Jun 2013; Anthony G. Basile <blueness@gentoo.org>
+ +files/varnish-3.0.4-automagic.patch, +varnish-3.0.4.ebuild:
+ Version bump
19 Mar 2013; Anthony G. Basile <blueness@gentoo.org>
files/varnish-3.0.3-automagic.patch:
diff --git a/www-servers/varnish/files/varnish-3.0.4-automagic.patch b/www-servers/varnish/files/varnish-3.0.4-automagic.patch
new file mode 100644
index 000000000000..6a517cc9efeb
--- /dev/null
+++ b/www-servers/varnish/files/varnish-3.0.4-automagic.patch
@@ -0,0 +1,94 @@
+diff -Naur varnish-3.0.4.orig/configure.ac varnish-3.0.4/configure.ac
+--- varnish-3.0.4.orig/configure.ac 2013-06-14 04:39:32.000000000 -0400
++++ varnish-3.0.4/configure.ac 2013-06-15 23:51:51.000000000 -0400
+@@ -87,15 +87,20 @@
+
+ save_LIBS="${LIBS}"
+ LIBS=""
+-AC_SEARCH_LIBS(initscr, [curses ncurses],
+- [have_curses=yes], [have_curses=no])
+-CURSES_LIBS="${LIBS}"
+-LIBS="${save_LIBS}"
+-AC_SUBST(CURSES_LIBS)
+-if test "$have_curses" = no; then
+- AC_MSG_WARN([curses not found; some tools will not be built])
+-fi
+-AC_CHECK_HEADERS([ncurses/curses.h curses.h])
++AC_ARG_WITH([tools], AS_HELP_STRING([--without-tools],
++ [Don't build additional tools: varnishhist, varnishstat, varnishtop, varnishsizes (default: test)]))
++
++AS_IF([test "x$with_tools" != "xno"], [
++ AC_SEARCH_LIBS(initscr, [curses ncurses],
++ [have_curses=yes], [have_curses=no])
++ CURSES_LIBS="${LIBS}"
++ LIBS="${save_LIBS}"
++ AC_SUBST(CURSES_LIBS)
++ if test "$have_curses" = no; then
++ AC_MSG_ERROR([curses not found, required to build additional tools])
++ fi
++ AC_CHECK_HEADERS([ncurses/curses.h curses.h])
++])
+ AM_CONDITIONAL([HAVE_CURSES], [test x$have_curses = xyes])
+
+ save_LIBS="${LIBS}"
+@@ -266,7 +271,6 @@
+ CFLAGS="${save_CFLAGS}"
+
+ # Use jemalloc on Linux
+-JEMALLOC_SUBDIR=
+ JEMALLOC_LDADD=
+ AC_ARG_WITH([jemalloc],
+ [AS_HELP_STRING([--with-jemalloc],
+@@ -274,18 +278,13 @@
+ [],
+ [with_jemalloc=check])
+
+-case $target in
+- *-*-linux*)
+- if test "x$with_jemalloc" != xno; then
+- AC_CHECK_LIB([jemalloc], [malloc_conf],
++if test "x$with_jemalloc" != xno; then
++ AC_CHECK_LIB([jemalloc], [malloc_conf],
++ [JEMALLOC_LDADD="-ljemalloc"],
++ [AC_CHECK_LIB([jemalloc], [jmalloc_conf],
+ [JEMALLOC_LDADD="-ljemalloc"],
+- [AC_MSG_NOTICE([No system jemalloc found, using bundled version])
+- JEMALLOC_SUBDIR=libjemalloc
+- JEMALLOC_LDADD='$(top_builddir)/lib/libjemalloc/libjemalloc_mt.la'])
+- fi
+- ;;
+-esac
+-AC_SUBST(JEMALLOC_SUBDIR)
++ [AC_MSG_ERROR([No system jemalloc found])])])
++fi
+ AC_SUBST(JEMALLOC_LDADD)
+
+ # Userland slab allocator, available only on Solaris
+@@ -588,7 +587,6 @@
+ lib/libvcl/Makefile
+ lib/libvgz/Makefile
+ lib/libvmod_std/Makefile
+- lib/libjemalloc/Makefile
+ man/Makefile
+ redhat/Makefile
+ varnishapi.pc
+--- varnish-3.0.4.orig/lib/Makefile.am 2013-06-14 04:39:32.000000000 -0400
++++ varnish-3.0.4/lib/Makefile.am 2013-06-15 23:51:08.000000000 -0400
+@@ -6,14 +6,12 @@
+ libvarnishapi \
+ libvcl \
+ libvgz \
+- libvmod_std \
+- @JEMALLOC_SUBDIR@
++ libvmod_std
+
+-DIST_SUBDIRS = \
++DIST_SUBDIRS = \
+ libvarnishcompat \
+ libvarnish \
+ libvarnishapi \
+ libvcl \
+ libvgz \
+- libvmod_std \
+- libjemalloc
++ libvmod_std
diff --git a/www-servers/varnish/varnish-3.0.4.ebuild b/www-servers/varnish/varnish-3.0.4.ebuild
new file mode 100644
index 000000000000..c1de058f3ec2
--- /dev/null
+++ b/www-servers/varnish/varnish-3.0.4.ebuild
@@ -0,0 +1,83 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-servers/varnish/varnish-3.0.4.ebuild,v 1.1 2013/06/16 06:25:28 blueness Exp $
+
+EAPI="5"
+
+inherit autotools-utils eutils
+
+DESCRIPTION="Varnish is a state-of-the-art, high-performance HTTP accelerator"
+HOMEPAGE="http://www.varnish-cache.org/"
+SRC_URI="http://repo.varnish-cache.org/source/${P}.tar.gz"
+
+LICENSE="BSD-2 GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~mips ~x86"
+IUSE="doc jemalloc jit static-libs +tools"
+
+CDEPEND="
+ dev-libs/libedit
+ dev-libs/libpcre[jit?]
+ jemalloc? ( dev-libs/jemalloc )
+ tools? ( sys-libs/ncurses )"
+
+#varnish compiles stuff at run time
+RDEPEND="
+ ${CDEPEND}
+ sys-devel/gcc"
+
+DEPEND="
+ ${CDEPEND}
+ dev-python/docutils
+ virtual/pkgconfig"
+
+RESTRICT="test" #315725
+
+DOCS=( README doc/changes.rst )
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-3.0.4-automagic.patch
+ "${FILESDIR}"/${PN}-3.0.3-pthread-uclibc.patch
+)
+
+AUTOTOOLS_AUTORECONF="yes"
+
+src_prepare() {
+ # Remove bundled libjemalloc. We also fix
+ # automagic dep in our patches, bug #461638
+ rm -rf lib/libjemalloc
+
+ autotools-utils_src_prepare
+}
+
+src_configure() {
+ local myeconfargs=(
+ $(use_enable static-libs static)
+ $(use_enable jit pcre-jit )
+ $(use_with jemalloc)
+ $(use_with tools)
+ --without-rst2man
+ --without-rst2html
+ )
+ autotools-utils_src_configure
+}
+
+src_install() {
+ autotools-utils_src_install
+
+ newinitd "${FILESDIR}"/varnishd.initd varnishd
+ newconfd "${FILESDIR}"/varnishd.confd varnishd
+
+ insinto /etc/logrotate.d
+ newins "${FILESDIR}/varnishd.logrotate" varnishd
+
+ dodir /var/log/varnish
+
+ use doc && dohtml -r "doc/sphinx/=build/html/"
+}
+
+pkg_postinst () {
+ elog "No demo-/sample-configfile is included in the distribution. Please"
+ elog "read the man-page for more info. A sample configuration proxying"
+ elog "localhost:8080 for localhost:80 is given in /etc/conf.d/varnishd."
+}