summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2011-11-05 08:48:33 +0000
committerTim Harder <radhermit@gentoo.org>2011-11-05 08:48:33 +0000
commit0180cdb27559d499d3e65d64df1a957bd5074211 (patch)
tree1ef09ee2c105ca8902771468eac52ee54573712b /www-servers/varnish
parentRevert part of last commit. (diff)
downloadgentoo-2-0180cdb27559d499d3e65d64df1a957bd5074211.tar.gz
gentoo-2-0180cdb27559d499d3e65d64df1a957bd5074211.tar.bz2
gentoo-2-0180cdb27559d499d3e65d64df1a957bd5074211.zip
Version bump.
(Portage version: 2.2.0_alpha72/cvs/Linux x86_64)
Diffstat (limited to 'www-servers/varnish')
-rw-r--r--www-servers/varnish/ChangeLog7
-rw-r--r--www-servers/varnish/varnish-3.0.2.ebuild46
2 files changed, 52 insertions, 1 deletions
diff --git a/www-servers/varnish/ChangeLog b/www-servers/varnish/ChangeLog
index dfad822b79c2..84b210dda628 100644
--- a/www-servers/varnish/ChangeLog
+++ b/www-servers/varnish/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for www-servers/varnish
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-servers/varnish/ChangeLog,v 1.37 2011/09/02 04:11:19 radhermit Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-servers/varnish/ChangeLog,v 1.38 2011/11/05 08:48:33 radhermit Exp $
+
+*varnish-3.0.2 (05 Nov 2011)
+
+ 05 Nov 2011; Tim Harder <radhermit@gentoo.org> +varnish-3.0.2.ebuild:
+ Version bump.
*varnish-3.0.1 (02 Sep 2011)
diff --git a/www-servers/varnish/varnish-3.0.2.ebuild b/www-servers/varnish/varnish-3.0.2.ebuild
new file mode 100644
index 000000000000..3629fb0e032a
--- /dev/null
+++ b/www-servers/varnish/varnish-3.0.2.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-servers/varnish/varnish-3.0.2.ebuild,v 1.1 2011/11/05 08:48:33 radhermit Exp $
+
+EAPI="4"
+
+inherit autotools-utils
+
+DESCRIPTION="Varnish is a state-of-the-art, high-performance HTTP accelerator"
+HOMEPAGE="http://www.varnish-cache.org/"
+SRC_URI="http://repo.varnish-cache.org/source/${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc static-libs"
+
+#varnish compiles stuff at run time
+RDEPEND="sys-devel/gcc"
+DEPEND="dev-python/docutils"
+
+RESTRICT="test" #315725
+
+AUTOTOOLS_IN_SOURCE_BUILD=1
+
+src_install() {
+ emake DESTDIR="${D}" install
+ remove_libtool_files all
+
+ newinitd "${FILESDIR}"/varnishd.initd varnishd
+ newconfd "${FILESDIR}"/varnishd.confd varnishd
+
+ insinto /etc/logrotate.d
+ newins "${FILESDIR}/varnishd.logrotate" varnishd
+
+ dodir /var/log/varnish
+
+ use doc && dohtml -r "doc/sphinx/=build/html/"
+}
+
+pkg_postinst () {
+ elog "No demo-/sample-configfile is included in the distribution -"
+ elog "please read the man-page for more info."
+ elog "A sample (localhost:8080 -> localhost:80) for gentoo is given in"
+ elog " /etc/conf.d/varnishd"
+}