summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMiroslav Šulc <fordfrog@gentoo.org>2012-07-08 21:35:54 +0000
committerMiroslav Šulc <fordfrog@gentoo.org>2012-07-08 21:35:54 +0000
commit23c491887649f178f6a493bfcedfe2b937860189 (patch)
tree1ee85face547ad9b715bd5b010dec2dd188485e4 /www-servers/tomcat
parentdev-java/tomcat-servlet-api: version bump (diff)
downloadgentoo-2-23c491887649f178f6a493bfcedfe2b937860189.tar.gz
gentoo-2-23c491887649f178f6a493bfcedfe2b937860189.tar.bz2
gentoo-2-23c491887649f178f6a493bfcedfe2b937860189.zip
www-servers/tomcat: version bump
(Portage version: 2.1.11.5/cvs/Linux x86_64)
Diffstat (limited to 'www-servers/tomcat')
-rw-r--r--www-servers/tomcat/ChangeLog8
-rw-r--r--www-servers/tomcat/files/7/7.0.29-build-xml.patch138
-rw-r--r--www-servers/tomcat/tomcat-7.0.29.ebuild237
3 files changed, 382 insertions, 1 deletions
diff --git a/www-servers/tomcat/ChangeLog b/www-servers/tomcat/ChangeLog
index 5736db134564..3be25105e9dc 100644
--- a/www-servers/tomcat/ChangeLog
+++ b/www-servers/tomcat/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for www-servers/tomcat
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-servers/tomcat/ChangeLog,v 1.293 2012/06/19 14:36:26 fordfrog Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-servers/tomcat/ChangeLog,v 1.294 2012/07/08 21:35:54 fordfrog Exp $
+
+*tomcat-7.0.29 (08 Jul 2012)
+
+ 08 Jul 2012; Miroslav Šulc <fordfrog@gentoo.org>
+ +files/7/7.0.29-build-xml.patch, +tomcat-7.0.29.ebuild:
+ version bump
*tomcat-7.0.28 (19 Jun 2012)
diff --git a/www-servers/tomcat/files/7/7.0.29-build-xml.patch b/www-servers/tomcat/files/7/7.0.29-build-xml.patch
new file mode 100644
index 000000000000..e4d30ea2a661
--- /dev/null
+++ b/www-servers/tomcat/files/7/7.0.29-build-xml.patch
@@ -0,0 +1,138 @@
+diff --git a/apache-tomcat-7.0.28-src/build.xml b/apache-tomcat-7.0.28-src/build.xml
+index 3ff8f81..fb50560 100644
+--- a/apache-tomcat-7.0.28-src/build.xml
++++ b/apache-tomcat-7.0.28-src/build.xml
+@@ -163,6 +163,7 @@
+
+ <!-- Classpaths -->
+ <path id="compile.classpath">
++ <pathelement location="${ant.jar}"/>
+ <pathelement location="${jdt.jar}"/>
+ </path>
+
+@@ -309,6 +310,7 @@
+ <exclude name="org/apache/catalina/mbeans/JmxRemote*" />
+ <exclude name="org/apache/catalina/tribes/**" />
+ <exclude name="org/apache/naming/factory/webservices/**" />
++ <exclude name="javax/servlet/**" />
+ </patternset>
+
+ <patternset id="files.catalina-tribes">
+@@ -439,7 +441,7 @@
+ </target>
+
+ <target name="validate" if="${execute.validate}"
+- depends="build-prepare,compile-prepare,download-validate"
++ depends="build-prepare,compile-prepare"
+ description="Uses Checkstyle tool to perform style check for the source code">
+ <!-- Required so we can cache checkstyle results -->
+ <mkdir dir="${tomcat.output}/res/checkstyle"/>
+@@ -551,7 +553,7 @@
+ </copy>
+ </target>
+
+- <target name="compile" depends="build-prepare,download-compile,compile-prepare,validate">
++ <target name="compile" depends="build-prepare,compile-prepare,validate">
+ <!-- Compile internal server components -->
+ <javac srcdir="java" destdir="${tomcat.classes}"
+ debug="${compile.debug}"
+@@ -613,7 +615,7 @@
+ filesId="files.annotations-api"
+ manifest="${tomcat.manifests}/annotations-api.jar.manifest" />
+
+- <!-- Servlet 3.0 Implementation JAR File -->
++<!-- Servlet 3.0 Implementation JAR File
+ <jarIt jarfile="${servlet-api.jar}"
+ filesDir="${tomcat.classes}"
+ filesId="files.servlet-api"
+@@ -621,7 +623,7 @@
+ notice="${tomcat.manifests}/servlet-api.jar.notice"
+ license="${tomcat.manifests}/servlet-api.jar.license" />
+
+- <!-- JSP 2.2 Implementation JAR File -->
++ JSP 2.2 Implementation JAR File
+ <jarIt jarfile="${jsp-api.jar}"
+ filesDir="${tomcat.classes}"
+ filesId="files.jsp-api"
+@@ -629,12 +631,12 @@
+ notice="${tomcat.manifests}/jsp-api.jar.notice"
+ license="${tomcat.manifests}/jsp-api.jar.license" />
+
+- <!-- JSP 2.2 EL Implementation JAR File -->
++ JSP 2.2 EL Implementation JAR File
+ <jarIt jarfile="${el-api.jar}"
+ filesDir="${tomcat.classes}"
+ filesId="files.el-api"
+ manifest="${tomcat.manifests}/el-api.jar.manifest" />
+-
++-->
+ <!-- Bootstrap JAR File -->
+ <jarIt jarfile="${bootstrap.jar}"
+ filesDir="${tomcat.classes}"
+@@ -725,7 +727,7 @@
+
+ </target>
+
+- <target name="build-docs" depends="compile-prepare" description="Builds all documentation from XML sources">
++ <target name="build-docs" depends="compile-prepare" unless="nobuild.docs" description="Builds all documentation from XML sources">
+
+ <copy todir="${tomcat.build}/webapps">
+ <fileset dir="webapps">
+@@ -833,14 +835,14 @@
+
+ <target name="deploy" depends="package,build-docs"
+ description="Default. Builds a working Tomcat instance">
+-
++<!--
+ <copy tofile="${tomcat.build}/bin/tomcat-native.tar.gz"
+ file="${tomcat-native.tar.gz}" />
+ <copy tofile="${tomcat.build}/bin/commons-daemon-native.tar.gz"
+ file="${commons-daemon.native.src.tgz}" />
+
+ <copy tofile="${tomcat.build}/bin/commons-daemon.jar" file="${commons-daemon.jar}" />
+-
++-->
+ <!-- Copy scripts -->
+ <copy todir="${tomcat.build}/bin">
+ <fileset dir="bin">
+@@ -897,7 +899,7 @@
+ source="${compile.source}"
+ target="${compile.target}"
+ optimize="${compile.optimize}"
+- classpath="${tomcat.classes}"
++ classpath="${tomcat.classes}:${jsp-api.jar}"
+ excludes="**/CVS/**,**/.svn/**"
+ encoding="ISO-8859-1"
+ includeantruntime="false">
+@@ -909,7 +911,7 @@
+ source="${compile.source}"
+ target="${compile.target}"
+ optimize="${compile.optimize}"
+- classpath="$tomcat.lcasses}"
++ classpath="${tomcat.classes}:${jsp-api.jar}"
+ excludes="**/CVS/**,**/.svn/**"
+ encoding="ISO-8859-1"
+ includeantruntime="false">
+@@ -917,11 +919,11 @@
+
+ <!-- Add sources for examples -->
+ <antcall target="examples-sources" />
+-
++<!--
+ <copy file="${tomcat-dbcp.jar}" todir="${tomcat.build}/lib"
+ failonerror="false"/>
+ <copy file="${jdt.jar}" todir="${tomcat.build}/lib" />
+-
++-->
+ <!-- build the jdbc-pool jar and source jar-->
+ <echo message="Building Tomcat JDBC pool libraries"/>
+ <ant antfile="${tomcat.jdbc.dir}/build.xml" dir="${tomcat.jdbc.dir}" inheritall="false" target="build">
+@@ -1105,7 +1107,7 @@
+
+ </target>
+
+- <target name="test-compile" depends="compile,download-test-compile" >
++ <target name="test-compile" depends="compile" >
+ <mkdir dir="${test.classes}"/>
+ <!-- Compile -->
+ <javac srcdir="test" destdir="${test.classes}"
diff --git a/www-servers/tomcat/tomcat-7.0.29.ebuild b/www-servers/tomcat/tomcat-7.0.29.ebuild
new file mode 100644
index 000000000000..55d721374eaf
--- /dev/null
+++ b/www-servers/tomcat/tomcat-7.0.29.ebuild
@@ -0,0 +1,237 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-servers/tomcat/tomcat-7.0.29.ebuild,v 1.1 2012/07/08 21:35:54 fordfrog Exp $
+
+EAPI=2
+JAVA_PKG_IUSE="doc examples source test"
+WANT_ANT_TASKS="ant-trax"
+
+inherit eutils java-pkg-2 java-ant-2
+
+DESCRIPTION="Tomcat Servlet-3.0/JSP-2.2 Container"
+
+MY_P="apache-${P}-src"
+SLOT="7"
+SRC_URI="mirror://apache/${PN}/${PN}-${SLOT}/v${PV}/src/${MY_P}.tar.gz"
+HOMEPAGE="http://tomcat.apache.org/"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~x86-fbsd"
+LICENSE="Apache-2.0"
+
+IUSE=""
+
+ECJV="3.7"
+
+# servlet-api slot
+SAPIS="3.0"
+
+COMMON_DEPEND="dev-java/eclipse-ecj:${ECJV}
+ dev-java/ant-eclipse-ecj:${ECJV}
+ >=dev-java/commons-dbcp-1.4
+ >=dev-java/commons-logging-1.1
+ >=dev-java/commons-pool-1.5.5
+ ~dev-java/tomcat-servlet-api-${PV}
+ examples? ( dev-java/jakarta-jstl )"
+
+RDEPEND="
+ !<dev-java/tomcat-native-1.1.20
+ >=virtual/jre-1.6
+ >=dev-java/commons-daemon-1.0.9
+ dev-java/ant-core
+ ${COMMON_DEPEND}"
+
+DEPEND=">=virtual/jdk-1.6
+ ${COMMON_DEPEND}
+ test? ( =dev-java/junit-3.8* )"
+
+S=${WORKDIR}/${MY_P}
+
+TOMCAT_NAME="${PN}-${SLOT}"
+TOMCAT_HOME="/usr/share/${TOMCAT_NAME}"
+WEBAPPS_DIR="/var/lib/${TOMCAT_NAME}/webapps"
+
+# TODO: Fails to find PrettyPrint in with python 2.6 and xml-rewriter-3
+# Find out why so
+JAVA_ANT_CELEMENT_REWRITER="true"
+JAVA_ANT_REWRITE_CLASSPATH="true"
+
+EANT_NEEDS_TOOLS="true"
+EANT_GENTOO_CLASSPATH="tomcat-servlet-api-${SAPIS},eclipse-ecj-${ECJV}"
+
+EANT_BUILD_TARGET="package"
+EANT_DOC_TARGET="build-docs"
+
+EANT_EXTRA_ARGS="-Dbase.path=${T} -Dversion=${PV}-gentoo -Dversion.number=${PV}
+-Dcompile.debug=false -Del-api.jar=el-api.jar -Djsp-api.jar=jsp-api.jar -Dservlet-api.jar=servlet-api.jar
+-Dant.jar=ant.jar"
+
+pkg_setup() {
+ java-pkg-2_pkg_setup
+ enewgroup tomcat 265
+ enewuser tomcat 265 -1 /dev/null tomcat
+}
+
+java_prepare() {
+ epatch "${FILESDIR}/${SLOT}/${PV}-build-xml.patch"
+
+ rm -v webapps/examples/WEB-INF/lib/*.jar \
+ test/webapp-3.0-fragments/WEB-INF/lib/*.jar || die
+
+ # bug # 178980 and #312293
+ use amd64 && java-pkg_force-compiler eclipse-ecj-${ECJV}
+
+ if ! use doc; then
+ EANT_EXTRA_ARGS+=" -Dnobuild.docs=true"
+ fi
+
+ EANT_EXTRA_ARGS+=" -Djdt.jar=$(java-pkg_getjar eclipse-ecj-${ECJV} ecj.jar)"
+ java-pkg_jarfrom --build-only ant-core ant.jar
+}
+
+src_install() {
+ cd "${S}/bin"
+ rm -f *.bat
+ chmod 755 *.sh
+
+ # register jars per bug #171496
+ cd "${S}/output/build/lib/"
+ for jar in *.jar; do
+ java-pkg_dojar ${jar}
+ done
+
+ local CATALINA_BASE=/var/lib/${TOMCAT_NAME}/
+
+ # init.d, conf.d
+ newinitd "${FILESDIR}"/${SLOT}/tomcat.init ${TOMCAT_NAME}
+ newconfd "${FILESDIR}"/${SLOT}/tomcat.conf ${TOMCAT_NAME}
+
+ # create dir structure
+ dodir /usr/share/${TOMCAT_NAME}
+
+ diropts -m750 -o tomcat -g tomcat
+ dodir /etc/${TOMCAT_NAME}
+ keepdir ${WEBAPPS_DIR}
+
+ diropts -m755 -o tomcat -g tomcat
+ dodir ${CATALINA_BASE}
+
+ diropts -m775 -o tomcat -g tomcat
+ dodir /etc/${TOMCAT_NAME}/Catalina/localhost
+ keepdir /var/log/${TOMCAT_NAME}/
+ keepdir /var/run/${TOMCAT_NAME}/
+ keepdir /var/tmp/${TOMCAT_NAME}/
+
+ cd "${S}"
+ # fix context's so webapps will be deployed
+ sed -i -e 's:Context a:Context docBase="${catalina.home}/webapps/host-manager" a:' "${S}"/webapps/host-manager/META-INF/context.xml
+ sed -i -e 's:Context a:Context docBase="${catalina.home}/webapps/manager" a:' "${S}"/webapps/manager/META-INF/context.xml
+
+ # replace the default pw with a random one, see #92281
+ local randpw=$(echo ${RANDOM}|md5sum|cut -c 1-15)
+ sed -e s:SHUTDOWN:${randpw}: -i conf/server.xml
+
+ # copy over the directories
+ chown -R tomcat:tomcat webapps/* conf/*
+ cp -pR conf/* "${D}"/etc/${TOMCAT_NAME} || die "failed to copy conf"
+ cp -pPR output/build/bin "${D}"/usr/share/${TOMCAT_NAME} \
+ || die "failed to copy"
+ # webapps get stored in /usr/share/${TOMCAT_NAME}/webapps
+ cd "${S}"/webapps || die
+ ebegin "Installing webapps to /usr/share/${TOMCAT_NAME}"
+
+ dodir /usr/share/${TOMCAT_NAME}/webapps
+ cp -pR ROOT "${D}"/usr/share/${TOMCAT_NAME}/webapps || die
+ cp -pR host-manager "${D}"/usr/share/${TOMCAT_NAME}/webapps || die
+ cp -pR manager "${D}"/usr/share/${TOMCAT_NAME}/webapps || die
+ if use doc; then
+ cp -pR "${S}"/output/build/webapps/docs "${D}"/usr/share/${TOMCAT_NAME}/webapps || die
+ fi
+ if use examples; then
+ cd "${S}"/webapps/examples/WEB-INF/lib
+ java-pkg_jar-from jakarta-jstl jstl.jar
+ java-pkg_jar-from jakarta-jstl standard.jar
+ cd "${S}"/webapps
+ cp -pR examples "${D}"/usr/share/${TOMCAT_NAME}/webapps || die
+ fi
+
+ # replace catalina.policy with gentoo specific one bug #176701
+# cp ${FILESDIR}/${SLOT}/catalina.policy "${D}"/etc/${TOMCAT_NAME} \
+# || die "failed to replace catalina.policy"
+
+ cd "${D}/usr/share/${TOMCAT_NAME}/lib" || die
+ java-pkg_jar-from eclipse-ecj-${ECJV}
+ java-pkg_jar-from tomcat-servlet-api-${SAPIS}
+
+ # symlink the directories to make CATALINA_BASE possible
+ dosym /etc/${TOMCAT_NAME} ${CATALINA_BASE}/conf
+ dosym /var/log/${TOMCAT_NAME} ${CATALINA_BASE}/logs
+ dosym /var/tmp/${TOMCAT_NAME} ${CATALINA_BASE}/temp
+ # we cannot symlink work directory because that breaks saving session data
+ # because session file cannot be saved to symlinked location by default
+ #dosym /var/run/${TOMCAT_NAME} ${CATALINA_BASE}/work
+
+ dodoc "${S}"/{RELEASE-NOTES,RUNNING.txt}
+ fperms 640 /etc/${TOMCAT_NAME}/tomcat-users.xml
+
+ #install *.sh scripts bug #278059
+ exeinto /usr/share/${TOMCAT_NAME}/bin
+ doexe "${S}"/bin/*.sh
+}
+
+pkg_postinst() {
+ ewarn "Changing ownership recursively on /etc/${TOMCAT_NAME}"
+ # temp fix for bug #176097
+ chown -fR tomcat:tomcat /etc/${TOMCAT_NAME}
+ ewarn "Owner ship changed to tomcat:tomcat. Temp hack/fix."
+
+ # bug #180519
+ if [[ -e "${ROOT}var/lib/${TOMCAT_NAME}/webapps/manager" ]] ; then
+ elog
+ elog "The latest webapp has NOT been installed into"
+ elog "${ROOT}var/lib/${TOMCAT_NAME}/webapps/ because directory already exists"
+ elog "and we do not want to overwrite any files you have put there."
+ elog
+ elog "Installing latest webapp into"
+ elog "${ROOT}usr/share/${TOMCAT_NAME}/webapps instead"
+ elog
+ elog "Manager Symbolic Links NOT created."
+ else
+ einfo "Installing latest webroot to ${ROOT}/${WEBAPPS_DIR}"
+ cp -pR "${ROOT}"/usr/share/${TOMCAT_NAME}/webapps/* \
+ "${ROOT}""${WEBAPPS_DIR}"
+ # link the manager's context to the right position
+ dosym ${TOMCAT_HOME}/webapps/host-manager/META-INF/context.xml /etc/${TOMCAT_NAME}/Catalina/localhost/host-manager.xml
+ dosym ${TOMCAT_HOME}/webapps/manager/META-INF/context.xml /etc/${TOMCAT_NAME}/Catalina/localhost/manager.xml
+ fi
+
+ # bug with storing SESSIONS.ser file to path with symlink
+ if [[ -L "${ROOT}var/lib/${TOMCAT_NAME}/work" ]] ; then
+ elog
+ ewarn "${ROOT}var/lib/${TOMCAT_NAME}/work is symbolic link which breaks"
+ ewarn "storing of SESSIONS.ser files in work directory when allowLinking"
+ ewarn "is disabled (the default). Remove the symbolic link (while Tomcat is"
+ ewarn "not running) to fix the issue."
+ fi
+
+ elog
+ elog " This ebuild implements a FHS compliant layout for tomcat"
+ elog " Please read http://www.gentoo.org/proj/en/java/tomcat6-guide.xml"
+ elog " for more information."
+ elog
+ ewarn "tomcat-dbcp.jar is not built at this time. Please fetch jar"
+ ewarn "from upstream binary if you need it. Gentoo Bug # 144276"
+ elog
+
+ ewarn "The manager webapps have known exploits, please refer to"
+ ewarn "http://cve.mitre.org/cgi-bin/cvename.cgi?name=2007-2450"
+
+ if use examples ; then
+ ewarn
+ ewarn "The examples webapp has a known exploit, please refer to"
+ ewarn "http://cve.mitre.org/cgi-bin/cvename.cgi?name=2007-2449"
+ ewarn
+ fi
+
+ elog
+ elog " Please report any bugs to http://bugs.gentoo.org/"
+ elog
+}