summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThilo Bangert <bangert@gentoo.org>2008-05-31 16:06:45 +0000
committerThilo Bangert <bangert@gentoo.org>2008-05-31 16:06:45 +0000
commite1b0dc02ea9f125ad9539108a6a26fdc303c487f (patch)
tree7418055824679ab843e928559bfd23bb2a0476e6 /www-servers/pound
parentVersion bump. (diff)
downloadgentoo-2-e1b0dc02ea9f125ad9539108a6a26fdc303c487f.tar.gz
gentoo-2-e1b0dc02ea9f125ad9539108a6a26fdc303c487f.tar.bz2
gentoo-2-e1b0dc02ea9f125ad9539108a6a26fdc303c487f.zip
version bump
(Portage version: 2.1.4.4)
Diffstat (limited to 'www-servers/pound')
-rw-r--r--www-servers/pound/ChangeLog7
-rw-r--r--www-servers/pound/pound-2.4.3.ebuild59
2 files changed, 65 insertions, 1 deletions
diff --git a/www-servers/pound/ChangeLog b/www-servers/pound/ChangeLog
index b9aa62e6dc77..c1b3084f9acd 100644
--- a/www-servers/pound/ChangeLog
+++ b/www-servers/pound/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for www-servers/pound
# Copyright 2000-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-servers/pound/ChangeLog,v 1.36 2008/04/24 20:51:43 bangert Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-servers/pound/ChangeLog,v 1.37 2008/05/31 16:06:45 bangert Exp $
+
+*pound-2.4.3 (31 May 2008)
+
+ 31 May 2008; Thilo Bangert <bangert@gentoo.org> +pound-2.4.3.ebuild:
+ version bump
*pound-2.4.2 (24 Apr 2008)
diff --git a/www-servers/pound/pound-2.4.3.ebuild b/www-servers/pound/pound-2.4.3.ebuild
new file mode 100644
index 000000000000..ac849f94c901
--- /dev/null
+++ b/www-servers/pound/pound-2.4.3.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-servers/pound/pound-2.4.3.ebuild,v 1.1 2008/05/31 16:06:45 bangert Exp $
+
+inherit flag-o-matic
+
+MY_P="${P/p/P}"
+DESCRIPTION="A http/https reverse-proxy and load-balancer."
+SRC_URI="http://www.apsis.ch/pound/${MY_P}.tgz"
+HOMEPAGE="http://www.apsis.ch/pound/"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~mips ~ppc ~sparc ~x86"
+IUSE="ssl dynscaler static"
+
+DEPEND="ssl? ( dev-libs/openssl )"
+
+S="${WORKDIR}/${MY_P}"
+
+src_compile() {
+ use static && append-ldflags -static
+
+ econf \
+ $(use_with ssl) \
+ $(use_enable dynscaler) \
+ || die "configure failed"
+
+ emake || die "compile failed"
+}
+
+src_install() {
+ dodir /usr/sbin
+ cp "${S}"/pound "${D}"/usr/sbin/
+ cp "${S}"/poundctl "${D}"/usr/sbin/
+
+ doman pound.8
+ doman poundctl.8
+ dodoc README FAQ
+
+ dodir /etc/init.d
+ newinitd "${FILESDIR}"/pound.init-1.9 pound
+
+ insinto /etc
+ newins "${FILESDIR}"/pound-2.2.cfg pound.cfg
+}
+
+pkg_postinst() {
+ elog "No demo-/sample-configfile is included in the distribution -"
+ elog "read the man-page for more info."
+ elog "A sample (localhost:8888 -> localhost:80) for gentoo is given in \"/etc/pound.cfg\"."
+ echo
+ ewarn "You will have to upgrade you configuration file, if you are"
+ ewarn "upgrading from a version <= 2.0."
+ echo
+ ewarn "The 'WebDAV' config statement is no longer supported!"
+ ewarn "Please adjust your configuration, if necessary."
+ echo
+}