summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThilo Bangert <bangert@gentoo.org>2007-04-11 17:34:00 +0000
committerThilo Bangert <bangert@gentoo.org>2007-04-11 17:34:00 +0000
commit5aec20f7ef95d2c9509a2c6907661e5ad8ec6307 (patch)
treedb701e19a5caeae2761cec30f0c8e5f965aaaf75 /www-servers/pound
parentRevbump - new patchset with gcc4 fixes (diff)
downloadgentoo-2-5aec20f7ef95d2c9509a2c6907661e5ad8ec6307.tar.gz
gentoo-2-5aec20f7ef95d2c9509a2c6907661e5ad8ec6307.tar.bz2
gentoo-2-5aec20f7ef95d2c9509a2c6907661e5ad8ec6307.zip
version bump
(Portage version: 2.1.2.2)
Diffstat (limited to 'www-servers/pound')
-rw-r--r--www-servers/pound/ChangeLog7
-rw-r--r--www-servers/pound/files/digest-pound-2.33
-rw-r--r--www-servers/pound/pound-2.3.ebuild59
3 files changed, 68 insertions, 1 deletions
diff --git a/www-servers/pound/ChangeLog b/www-servers/pound/ChangeLog
index 4cddde0aac7e..135d7357506e 100644
--- a/www-servers/pound/ChangeLog
+++ b/www-servers/pound/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for www-servers/pound
# Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-servers/pound/ChangeLog,v 1.25 2007/01/09 08:01:31 bangert Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-servers/pound/ChangeLog,v 1.26 2007/04/11 17:34:00 bangert Exp $
+
+*pound-2.3 (11 Apr 2007)
+
+ 11 Apr 2007; Thilo Bangert <bangert@gentoo.org> +pound-2.3.ebuild:
+ version bump
09 Jan 2007; Thilo Bangert <bangert@gentoo.org> pound-1.10.ebuild,
pound-2.0.5.ebuild, pound-2.1.ebuild:
diff --git a/www-servers/pound/files/digest-pound-2.3 b/www-servers/pound/files/digest-pound-2.3
new file mode 100644
index 000000000000..5ad52b7e6da7
--- /dev/null
+++ b/www-servers/pound/files/digest-pound-2.3
@@ -0,0 +1,3 @@
+MD5 94251bfc0d38e7aa4d50bff971ddc72e Pound-2.3.tgz 154167
+RMD160 3bb168b95dcbe66bdac4153e95eb4a7416a64d8d Pound-2.3.tgz 154167
+SHA256 2aec3da07856ca2b53b834bdba8a820a130854e02426de41d8eabcf6c4c11606 Pound-2.3.tgz 154167
diff --git a/www-servers/pound/pound-2.3.ebuild b/www-servers/pound/pound-2.3.ebuild
new file mode 100644
index 000000000000..52b52104c793
--- /dev/null
+++ b/www-servers/pound/pound-2.3.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-servers/pound/pound-2.3.ebuild,v 1.1 2007/04/11 17:34:00 bangert Exp $
+
+inherit flag-o-matic
+
+MY_P="${P/p/P}"
+DESCRIPTION="A http/https reverse-proxy and load-balancer."
+SRC_URI="http://www.apsis.ch/pound/${MY_P}.tgz"
+HOMEPAGE="http://www.apsis.ch/pound/"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~mips ~ppc ~sparc ~x86"
+IUSE="ssl dynscaler static"
+
+DEPEND="ssl? ( dev-libs/openssl )"
+
+S="${WORKDIR}/${MY_P}"
+
+src_compile() {
+ use static && append-ldflags -static
+
+ econf \
+ $(use_with ssl) \
+ $(use_enable dynscaler) \
+ || die "configure failed"
+
+ emake || die "compile failed"
+}
+
+src_install() {
+ dodir /usr/sbin
+ cp ${S}/pound ${D}/usr/sbin/
+ cp ${S}/poundctl ${D}/usr/sbin/
+
+ doman pound.8
+ doman poundctl.8
+ dodoc README FAQ
+
+ dodir /etc/init.d
+ newinitd ${FILESDIR}/pound.init-1.9 pound
+
+ insinto /etc
+ newins ${FILESDIR}/pound-2.2.cfg pound.cfg
+}
+
+pkg_postinst() {
+ elog "No demo-/sample-configfile is included in the distribution -"
+ elog "read the man-page for more info."
+ elog "A sample (localhost:8888 -> localhost:80) for gentoo is given in \"/etc/pound.cfg\"."
+ echo
+ ewarn "You will have to upgrade you configuration file, if you are"
+ ewarn "upgrading from a version <= 2.0."
+ echo
+ ewarn "The 'WebDAV' config statement is no longer supported!"
+ ewarn "Please adjust your configuration, if necessary."
+ echo
+}