summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2013-06-17 06:49:58 +0000
committerTim Harder <radhermit@gentoo.org>2013-06-17 06:49:58 +0000
commit318bc451813448348dbb3019083ed4ea65c538b3 (patch)
tree18d78dd0c5db88bc1fba07a30583ec05feb0fd4d /www-servers/pathod
parentVersion bump. (diff)
downloadgentoo-2-318bc451813448348dbb3019083ed4ea65c538b3.tar.gz
gentoo-2-318bc451813448348dbb3019083ed4ea65c538b3.tar.bz2
gentoo-2-318bc451813448348dbb3019083ed4ea65c538b3.zip
Version bump.
(Portage version: 2.2.0_alpha180/cvs/Linux x86_64, signed Manifest commit with key 4AB3E85B4F064CA3)
Diffstat (limited to 'www-servers/pathod')
-rw-r--r--www-servers/pathod/ChangeLog7
-rw-r--r--www-servers/pathod/pathod-0.9.1.ebuild29
2 files changed, 35 insertions, 1 deletions
diff --git a/www-servers/pathod/ChangeLog b/www-servers/pathod/ChangeLog
index ca6682f24e3e..9ecefc721cfe 100644
--- a/www-servers/pathod/ChangeLog
+++ b/www-servers/pathod/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for www-servers/pathod
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-servers/pathod/ChangeLog,v 1.1 2013/05/16 08:15:47 radhermit Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-servers/pathod/ChangeLog,v 1.2 2013/06/17 06:49:58 radhermit Exp $
+
+*pathod-0.9.1 (17 Jun 2013)
+
+ 17 Jun 2013; Tim Harder <radhermit@gentoo.org> +pathod-0.9.1.ebuild:
+ Version bump.
*pathod-0.9 (16 May 2013)
diff --git a/www-servers/pathod/pathod-0.9.1.ebuild b/www-servers/pathod/pathod-0.9.1.ebuild
new file mode 100644
index 000000000000..c3f3beb9f89a
--- /dev/null
+++ b/www-servers/pathod/pathod-0.9.1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-servers/pathod/pathod-0.9.1.ebuild,v 1.1 2013/06/17 06:49:58 radhermit Exp $
+
+EAPI=5
+PYTHON_COMPAT=( python{2_6,2_7} )
+
+inherit distutils-r1
+
+DESCRIPTION="A collection of pathological tools for testing and torturing HTTP clients and servers"
+HOMEPAGE="https://github.com/cortesi/pathod/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND=">=dev-python/netlib-0.9[${PYTHON_USEDEP}]
+ >=dev-python/requests-1.1.0[${PYTHON_USEDEP}]
+ dev-python/flask[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ test? ( dev-python/nose[${PYTHON_USEDEP}] )"
+
+RESTRICT="test"
+
+python_test() {
+ nosetests -v || die "Tests fail with ${EPYTHON}"
+}