summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKonstantin V. Arkhipov <voxus@gentoo.org>2005-10-05 07:29:10 +0000
committerKonstantin V. Arkhipov <voxus@gentoo.org>2005-10-05 07:29:10 +0000
commitf83c8b7f8673fee56ecb20b8ffd5a3b6114cdad9 (patch)
tree1f15f9c7ced58d553ccd8e87c797fb3e92c6bf30 /www-servers/nginx
parentAdded stdcxx_incdir to eselect conf. (diff)
downloadgentoo-2-f83c8b7f8673fee56ecb20b8ffd5a3b6114cdad9.tar.gz
gentoo-2-f83c8b7f8673fee56ecb20b8ffd5a3b6114cdad9.tar.bz2
gentoo-2-f83c8b7f8673fee56ecb20b8ffd5a3b6114cdad9.zip
* bump again
(Portage version: 2.0.53_rc3)
Diffstat (limited to 'www-servers/nginx')
-rw-r--r--www-servers/nginx/ChangeLog7
-rw-r--r--www-servers/nginx/Manifest2
-rw-r--r--www-servers/nginx/files/digest-nginx-0.2.51
-rw-r--r--www-servers/nginx/nginx-0.2.5.ebuild70
4 files changed, 79 insertions, 1 deletions
diff --git a/www-servers/nginx/ChangeLog b/www-servers/nginx/ChangeLog
index 83b10dc8e75b..fabb9739703b 100644
--- a/www-servers/nginx/ChangeLog
+++ b/www-servers/nginx/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for www-servers/nginx
# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-servers/nginx/ChangeLog,v 1.46 2005/10/03 17:41:48 voxus Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-servers/nginx/ChangeLog,v 1.47 2005/10/05 07:29:10 voxus Exp $
+
+*nginx-0.2.5 (05 Oct 2005)
+
+ 05 Oct 2005; Konstantin Arkhipov <voxus@gentoo.org> +nginx-0.2.5.ebuild:
+ Version bump.
*nginx-0.2.4 (03 Oct 2005)
diff --git a/www-servers/nginx/Manifest b/www-servers/nginx/Manifest
index 397d08faafa4..0b3c5b00bd52 100644
--- a/www-servers/nginx/Manifest
+++ b/www-servers/nginx/Manifest
@@ -3,6 +3,7 @@ MD5 e8474104898712edc8575c940152bbd3 files/digest-nginx-0.1.45 64
MD5 ed882ba7b3d8655035ab7b1df383cb1e files/digest-nginx-0.2.1 63
MD5 5a800d15945631995ab77315c11b7e46 files/digest-nginx-0.2.3 63
MD5 ef1dbbfda1d3c319e8a22c89f8618241 files/digest-nginx-0.2.4 63
+MD5 e9ba279cc8e53f4cfea90ff7387a059a files/digest-nginx-0.2.5 63
MD5 d8f7e621e098b58848a6b5fb045c49c3 files/nginx 994
MD5 fecedd05099122b1f8169152e5bc9462 files/nginx.conf 1400
MD5 822f3c821527e6a34f23a6a92a884766 metadata.xml 220
@@ -10,3 +11,4 @@ MD5 62f46895e63da25c83512f589b9e61cb nginx-0.1.45.ebuild 1935
MD5 3c18bb527b67288a5978c43962bfd4bc nginx-0.2.1.ebuild 1936
MD5 60ddd97ebfc099421ce6cd3bef5020dd nginx-0.2.3.ebuild 1936
MD5 723f51ae02e02bb74b68a7d189f1b43f nginx-0.2.4.ebuild 1936
+MD5 723f51ae02e02bb74b68a7d189f1b43f nginx-0.2.5.ebuild 1936
diff --git a/www-servers/nginx/files/digest-nginx-0.2.5 b/www-servers/nginx/files/digest-nginx-0.2.5
new file mode 100644
index 000000000000..0a7fce206497
--- /dev/null
+++ b/www-servers/nginx/files/digest-nginx-0.2.5
@@ -0,0 +1 @@
+MD5 f2fb0fa5631546097fb09ca22d16902a nginx-0.2.5.tar.gz 329202
diff --git a/www-servers/nginx/nginx-0.2.5.ebuild b/www-servers/nginx/nginx-0.2.5.ebuild
new file mode 100644
index 000000000000..338d58234277
--- /dev/null
+++ b/www-servers/nginx/nginx-0.2.5.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-servers/nginx/nginx-0.2.5.ebuild,v 1.1 2005/10/05 07:29:10 voxus Exp $
+
+inherit eutils
+
+DESCRIPTION="Robust, small and high performance http and reverse proxy server"
+
+HOMEPAGE="http://sysoev.ru/nginx/"
+SRC_URI="http://sysoev.ru/nginx/${P}.tar.gz"
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="debug fastcgi imap pcre threads ssl zlib"
+
+DEPEND="dev-lang/perl
+ pcre? ( >=dev-libs/libpcre-4.2 )
+ ssl? ( dev-libs/openssl )
+ zlib? ( sys-libs/zlib )"
+
+src_compile() {
+ local myconf
+
+ if use threads; then
+ einfo
+ ewarn "threads support is experimental at the moment"
+ ewarn "do not use it on production systems - you've been warned"
+ einfo
+ myconf="${myconf} --with-threads"
+ fi
+
+ use fastcgi || myconf="${myconf} --without-http_fastcgi_module"
+ use zlib || myconf="${myconf} --without-http_gzip_module"
+ use pcre || {
+ myconf="${myconf} --without-pcre --without-http_rewrite_module"
+ }
+ use debug && myconf="${myconf} --with-debug"
+ use ssl && myconf="${myconf} --with-http_ssl_module"
+ use imap && myconf="${myconf} --with-imap" # pop3/imap4 proxy support
+
+ ./configure \
+ --prefix=/usr \
+ --conf-path=/etc/${PN}/${PN}.conf \
+ --http-log-path=/var/log/${PN}/access_log \
+ --error-log-path=/var/log/${PN}/error_log \
+ --pid-path=/var/run/${PN}.pid \
+ --http-client-body-temp-path=/var/tmp/${PN}/client \
+ --http-proxy-temp-path=/var/tmp/${PN}/proxy \
+ --http-fastcgi-temp-path=/var/tmp/${PN}/fastcgi \
+ --with-md5-asm \
+ ${myconf} || die "configure failed"
+
+ emake || die "failed to compile"
+}
+
+src_install() {
+ keepdir /var/log/${PN} /var/tmp/${PN}/{client,proxy,fastcgi}
+
+ dodir /etc/${PN}
+
+ dosbin objs/nginx
+ doinitd ${FILESDIR}/nginx
+
+ insinto /etc/${PN}
+ rm conf/nginx.conf
+ doins -r conf/*
+ doins ${FILESDIR}/nginx.conf
+
+ dodoc CHANGES{,.ru} LICENSE README
+}