summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTiziano Müller <dev-zero@gentoo.org>2010-04-11 19:52:34 +0000
committerTiziano Müller <dev-zero@gentoo.org>2010-04-11 19:52:34 +0000
commited853bdfcc48908ef2f336842f00414ebea03932 (patch)
tree6c98b10895d784c8e999a72d94969f93b0ead772 /www-servers/nginx
parentAdded push USE flag for nginx. (diff)
downloadgentoo-2-ed853bdfcc48908ef2f336842f00414ebea03932.tar.gz
gentoo-2-ed853bdfcc48908ef2f336842f00414ebea03932.tar.bz2
gentoo-2-ed853bdfcc48908ef2f336842f00414ebea03932.zip
Version bump. Added the http_push module. Moved libatomic_ops dep to DEPEND. Added myself as maintainer. Added upstream changelog URL.
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'www-servers/nginx')
-rw-r--r--www-servers/nginx/ChangeLog9
-rw-r--r--www-servers/nginx/metadata.xml7
-rw-r--r--www-servers/nginx/nginx-0.8.35.ebuild291
3 files changed, 306 insertions, 1 deletions
diff --git a/www-servers/nginx/ChangeLog b/www-servers/nginx/ChangeLog
index fc68519a07c5..e1db8fee35bf 100644
--- a/www-servers/nginx/ChangeLog
+++ b/www-servers/nginx/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for www-servers/nginx
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-servers/nginx/ChangeLog,v 1.254 2010/03/26 14:10:32 hollow Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-servers/nginx/ChangeLog,v 1.255 2010/04/11 19:52:34 dev-zero Exp $
+
+*nginx-0.8.35 (11 Apr 2010)
+
+ 11 Apr 2010; Tiziano Müller <dev-zero@gentoo.org> +nginx-0.8.35.ebuild,
+ metadata.xml:
+ Version bump. Added the http_push module. Moved libatomic_ops dep to
+ DEPEND. Added myself as maintainer. Added upstream changelog URL.
26 Mar 2010; Benedikt Böhm <hollow@gentoo.org> nginx-0.7.65-r1.ebuild,
nginx-0.8.34-r1.ebuild:
diff --git a/www-servers/nginx/metadata.xml b/www-servers/nginx/metadata.xml
index 02610eeac333..392b1835497b 100644
--- a/www-servers/nginx/metadata.xml
+++ b/www-servers/nginx/metadata.xml
@@ -9,6 +9,10 @@
<maintainer>
<email>voxus@gentoo.org</email>
</maintainer>
+ <maintainer>
+ <email>dev-zero@gentoo.org</email>
+ <name>Tiziano Müller</name>
+ </maintainer>
<use>
<flag name='addition'>Enables HTTP addition filter module</flag>
<flag name='aio'>Enables file AIO support</flag>
@@ -25,4 +29,7 @@
<flag name='sub'>Enables sub_filter module</flag>
<flag name='webdav'>Enable webdav support</flag>
</use>
+ <upstream>
+ <changelog>http://nginx.org/en/CHANGES</changelog>
+ </upstream>
</pkgmetadata>
diff --git a/www-servers/nginx/nginx-0.8.35.ebuild b/www-servers/nginx/nginx-0.8.35.ebuild
new file mode 100644
index 000000000000..8de65183d8e3
--- /dev/null
+++ b/www-servers/nginx/nginx-0.8.35.ebuild
@@ -0,0 +1,291 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-servers/nginx/nginx-0.8.35.ebuild,v 1.1 2010/04/11 19:52:34 dev-zero Exp $
+
+EAPI="2"
+
+USE_RUBY="ruby18"
+RUBY_OPTIONAL="yes"
+PASSENGER_PV="2.2.11"
+HTTP_PUSH_MODULE_P="nginx_http_push_module-0.692"
+
+inherit eutils ssl-cert toolchain-funcs perl-module ruby-ng flag-o-matic
+
+DESCRIPTION="Robust, small and high performance http and reverse proxy server"
+HOMEPAGE="http://nginx.net/ http://pushmodule.slact.net/"
+SRC_URI="http://sysoev.ru/nginx/${P}.tar.gz
+ nginx_modules_http_passenger? ( mirror://rubyforge/passenger/passenger-${PASSENGER_PV}.tar.gz )
+ nginx_modules_http_push? ( http://pushmodule.slact.net/downloads/${HTTP_PUSH_MODULE_P}.tar.gz )"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~x86-fbsd"
+
+NGINX_MODULES_STD="access auth_basic autoindex browser charset empty_gif fastcgi
+geo gzip limit_req limit_zone map memcached proxy referer rewrite ssi
+upstream_ip_hash userid"
+NGINX_MODULES_OPT="addition dav degradation flv geoip gzip_static image_filter
+perl random_index realip secure_link stub_status sub xslt"
+NGINX_MODULES_MAIL="imap pop3 smtp"
+NGINX_MODULES_3RD="http_passenger http_push"
+
+IUSE="aio debug +http +http-cache ipv6 libatomic +pcre ssl"
+
+for mod in $NGINX_MODULES_STD; do
+ IUSE="${IUSE} +nginx_modules_http_${mod}"
+done
+
+for mod in $NGINX_MODULES_OPT; do
+ IUSE="${IUSE} nginx_modules_http_${mod}"
+done
+
+for mod in $NGINX_MODULES_MAIL; do
+ IUSE="${IUSE} nginx_modules_mail_${mod}"
+done
+
+for mod in $NGINX_MODULES_3RD; do
+ IUSE="${IUSE} nginx_modules_${mod}"
+done
+
+CDEPEND="
+ pcre? ( >=dev-libs/libpcre-4.2 )
+ ssl? ( dev-libs/openssl )
+ http-cache? ( userland_GNU? ( dev-libs/openssl ) )
+ nginx_modules_http_geo? ( dev-libs/geoip )
+ nginx_modules_http_gzip? ( sys-libs/zlib )
+ nginx_modules_http_gzip_static? ( sys-libs/zlib )
+ nginx_modules_http_image_filter? ( media-libs/gd )
+ nginx_modules_http_perl? ( >=dev-lang/perl-5.8 )
+ nginx_modules_http_rewrite? ( >=dev-libs/libpcre-4.2 )
+ nginx_modules_http_secure_link? ( userland_GNU? ( dev-libs/openssl ) )
+ nginx_modules_http_xslt? ( dev-libs/libxml2 dev-libs/libxslt )
+ nginx_modules_http_passenger? (
+ $(ruby_implementation_depend ruby18)
+ >=dev-ruby/rubygems-0.9.0
+ >=dev-ruby/rake-0.8.1
+ >=dev-ruby/fastthread-1.0.1
+ >=dev-ruby/rack-1.0.0
+ )
+"
+RDEPEND="${CDEPEND}"
+DEPEND="${CDEPEND}
+ arm? ( dev-libs/libatomic_ops )
+ libatomic? ( dev-libs/libatomic_ops )"
+
+# Maintainer notes:
+# - http_rewrite-independent pcre-support makes sense for matching locations without an actual rewrite
+# - any http-module activates the main http-functionality and overrides USE=-http
+# - keep the following 3 requirements in mind before adding external modules:
+# * alive upstream
+# * sane packaging
+# * builds cleanly
+# - TODO: passenger currently builds some stuff in src_configure
+# - TODO: test the google-perftools module (included in vanilla tarball)
+
+pkg_setup() {
+ ebegin "Creating nginx user and group"
+ enewgroup ${PN}
+ enewuser ${PN} -1 -1 -1 ${PN}
+ eend ${?}
+
+ if use ipv6; then
+ ewarn "Note that ipv6 support in nginx is still experimental."
+ ewarn "Be sure to read comments on gentoo bug #274614"
+ ewarn "http://bugs.gentoo.org/show_bug.cgi?id=274614"
+ fi
+
+ if use libatomic; then
+ ewarn "GCC 4.1+ features built-in atomic operations."
+ ewarn "Using libatomic_ops is only needed if using"
+ ewarn "a different compiler or a GCC prior to 4.1"
+ fi
+
+ if [[ -n $NGINX_ADD_MODULES ]]; then
+ ewarn "You are building custom modules via \$NGINX_ADD_MODULES!"
+ ewarn "This nginx installation is not supported!"
+ ewarn "Make sure you can reproduce the bug without those modules"
+ ewarn "_before_ reporting bugs."
+ fi
+
+ if use nginx_modules_http_passenger; then
+ ruby-ng_pkg_setup
+ use debug && append-flags -DPASSENGER_DEBUG
+ fi
+
+ if use !http ; then
+ ewarn "To actually disable all http-functionality you also have to disable"
+ ewarn "all nginx http modules."
+ fi
+}
+
+src_unpack() {
+ # prevent ruby-ng.eclass from messing with src_unpack
+ default
+}
+
+src_prepare() {
+ sed -i 's/ make/ \\$(MAKE)/' "${S}"/auto/lib/perl/make
+
+ if use nginx_modules_http_passenger; then
+ cd "${WORKDIR}"/passenger-${PASSENGER_PV}
+ epatch "${FILESDIR}"/passenger-CFLAGS.patch
+ fi
+}
+
+src_configure() {
+ local myconf= http_enabled= mail_enabled=
+
+ use aio && myconf="${myconf} --with-file-aio --with-aio_module"
+ use debug && myconf="${myconf} --with-debug"
+ use ipv6 && myconf="${myconf} --with-ipv6"
+ use libatomic && myconf="${myconf} --with-libatomic"
+ use pcre && myconf="${myconf} --with-pcre"
+
+ # HTTP modules
+ for mod in $NGINX_MODULES_STD; do
+ if use nginx_modules_http_${mod}; then
+ http_enabled=1
+ else
+ myconf="${myconf} --without-http_${mod}_module"
+ fi
+ done
+
+ for mod in $NGINX_MODULES_OPT; do
+ if use nginx_modules_http_${mod}; then
+ http_enabled=1
+ myconf="${myconf} --with-http_${mod}_module"
+ fi
+ done
+
+ if use nginx_modules_http_fastcgi; then
+ myconf="${myconf} --with-http_realip_module"
+ fi
+
+ if use nginx_modules_http_passenger; then
+ http_enabled=1
+ myconf="${myconf} --add-module=${WORKDIR}/passenger-${PASSENGER_PV}/ext/nginx"
+ fi
+
+ if use nginx_modules_http_push ; then
+ http_enabled=1
+ myconf="${myconf} --add-module=${WORKDIR}/${HTTP_PUSH_MODULE_P}"
+ fi
+
+ if use http || use http-cache; then
+ http_enabled=1
+ fi
+
+ if [ $http_enabled ]; then
+ use http-cache || myconf="${myconf} --without-http-cache"
+ use ssl && myconf="${myconf} --with-http_ssl_module"
+ else
+ myconf="${myconf} --without-http --without-http-cache"
+ fi
+
+ # MAIL modules
+ for mod in $NGINX_MODULES_MAIL; do
+ if use nginx_modules_mail_${mod}; then
+ mail_enabled=1
+ else
+ myconf="${myconf} --without-mail_${mod}_module"
+ fi
+ done
+
+ if [ $mail_enabled ]; then
+ myconf="${myconf} --with-mail"
+ use ssl && myconf="${myconf} --with-mail_ssl_module"
+ fi
+
+ # custom modules
+ for mod in $NGINX_ADD_MODULES; do
+ myconf="${myconf} --add-module=${mod}"
+ done
+
+ # http://bugs.gentoo.org/show_bug.cgi?id=286772
+ export LANG=C LC_ALL=C
+ tc-export CC
+
+ ./configure \
+ --prefix=/usr \
+ --sbin-path=/usr/sbin/nginx \
+ --conf-path=/etc/${PN}/${PN}.conf \
+ --error-log-path=/var/log/${PN}/error_log \
+ --pid-path=/var/run/${PN}.pid \
+ --lock-path=/var/lock/nginx.lock \
+ --user=${PN} --group=${PN} \
+ --with-cc-opt="-I${ROOT}usr/include" \
+ --with-ld-opt="-L${ROOT}usr/lib" \
+ --http-log-path=/var/log/${PN}/access_log \
+ --http-client-body-temp-path=/var/tmp/${PN}/client \
+ --http-proxy-temp-path=/var/tmp/${PN}/proxy \
+ --http-fastcgi-temp-path=/var/tmp/${PN}/fastcgi \
+ ${myconf} || die "configure failed"
+}
+
+src_compile() {
+ # http://bugs.gentoo.org/show_bug.cgi?id=286772
+ export LANG=C LC_ALL=C
+ emake LINK="${CC} ${LDFLAGS}" OTHERLDFLAGS="${LDFLAGS}" || die "emake failed"
+}
+
+src_install() {
+ keepdir /var/log/${PN} /var/tmp/${PN}/{client,proxy,fastcgi}
+
+ dosbin objs/nginx
+ newinitd "${FILESDIR}"/nginx.init-r2 nginx
+
+ cp "${FILESDIR}"/nginx.conf-r4 conf/nginx.conf
+ rm conf/win-utf conf/koi-win conf/koi-utf
+
+ dodir /etc/${PN}
+ insinto /etc/${PN}
+ doins conf/*
+
+ dodoc CHANGES* README
+
+ # logrotate
+ insinto /etc/logrotate.d
+ newins "${FILESDIR}"/nginx.logrotate nginx
+
+ if use nginx_modules_http_perl; then
+ cd "${S}"/objs/src/http/modules/perl/
+ einstall DESTDIR="${D}" INSTALLDIRS=vendor || die "failed to install perl stuff"
+ fixlocalpod
+ fi
+
+ if use nginx_modules_http_push ; then
+ docinto ${HTTP_PUSH_MODULE_P}
+ dodoc "${WORKDIR}/${HTTP_PUSH_MODULE_P}"/{changelog.txt,protocol.txt,README}
+ fi
+
+ if use nginx_modules_http_passenger; then
+ # passengers Rakefile is so horribly broken that we have to do it
+ # manually
+ cd "${WORKDIR}"/passenger-${PASSENGER_PV}
+
+ export RUBY="ruby18"
+
+ insinto $(${RUBY} -rrbconfig -e 'print Config::CONFIG["archdir"]')/phusion_passenger
+ insopts -m 0755
+ doins ext/phusion_passenger/*.so
+ doruby -r lib/phusion_passenger
+
+ exeinto /usr/bin
+ doexe bin/passenger-memory-stats bin/passenger-status
+
+ exeinto /usr/libexec/passenger/bin
+ doexe bin/passenger-spawn-server
+
+ exeinto /usr/libexec/passenger/ext/nginx
+ doexe ext/nginx/HelperServer
+ fi
+}
+
+pkg_postinst() {
+ if use ssl; then
+ if [ ! -f "${ROOT}"/etc/ssl/${PN}/${PN}.key ]; then
+ install_cert /etc/ssl/${PN}/${PN}
+ chown ${PN}:${PN} "${ROOT}"/etc/ssl/${PN}/${PN}.{crt,csr,key,pem}
+ fi
+ fi
+}