summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKonstantin V. Arkhipov <voxus@gentoo.org>2006-06-01 12:31:00 +0000
committerKonstantin V. Arkhipov <voxus@gentoo.org>2006-06-01 12:31:00 +0000
commitab1248f7534deb89425f5c4f4754ecaba8189798 (patch)
tree4128c242465f94d312a63ff324fc90bc36ddbdbc /www-servers/nginx
parentVersion bump. Fixed init script to work on SMP systems, thanks to Sebastien L... (diff)
downloadgentoo-2-ab1248f7534deb89425f5c4f4754ecaba8189798.tar.gz
gentoo-2-ab1248f7534deb89425f5c4f4754ecaba8189798.tar.bz2
gentoo-2-ab1248f7534deb89425f5c4f4754ecaba8189798.zip
* bump
(Portage version: 2.1_rc3-r3)
Diffstat (limited to 'www-servers/nginx')
-rw-r--r--www-servers/nginx/ChangeLog8
-rw-r--r--www-servers/nginx/files/digest-nginx-0.3.493
-rw-r--r--www-servers/nginx/nginx-0.3.49.ebuild72
3 files changed, 82 insertions, 1 deletions
diff --git a/www-servers/nginx/ChangeLog b/www-servers/nginx/ChangeLog
index db8cfa049c60..7030ce7e89ae 100644
--- a/www-servers/nginx/ChangeLog
+++ b/www-servers/nginx/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for www-servers/nginx
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-servers/nginx/ChangeLog,v 1.94 2006/05/24 11:04:36 voxus Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-servers/nginx/ChangeLog,v 1.95 2006/06/01 12:31:00 voxus Exp $
+
+*nginx-0.3.49 (01 Jun 2006)
+
+ 01 Jun 2006; Konstantin Arkhipov <voxus@gentoo.org> +nginx-0.3.49.ebuild,
+ -nginx-0.3.47.ebuild:
+ Bump.
*nginx-0.3.47 (24 May 2006)
diff --git a/www-servers/nginx/files/digest-nginx-0.3.49 b/www-servers/nginx/files/digest-nginx-0.3.49
new file mode 100644
index 000000000000..1269dbba9757
--- /dev/null
+++ b/www-servers/nginx/files/digest-nginx-0.3.49
@@ -0,0 +1,3 @@
+MD5 8caeffc4eafc2fb961232798137aee64 nginx-0.3.49.tar.gz 399449
+RMD160 36a5268f88c76fe95d23d122e9ce85ed1ed16577 nginx-0.3.49.tar.gz 399449
+SHA256 eb6d5d240aafe1a232c1d4b330a4b218299bd905a8aa511d72a199ebbd158dd0 nginx-0.3.49.tar.gz 399449
diff --git a/www-servers/nginx/nginx-0.3.49.ebuild b/www-servers/nginx/nginx-0.3.49.ebuild
new file mode 100644
index 000000000000..05d2fdea745b
--- /dev/null
+++ b/www-servers/nginx/nginx-0.3.49.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-servers/nginx/nginx-0.3.49.ebuild,v 1.1 2006/06/01 12:31:00 voxus Exp $
+
+inherit eutils
+
+DESCRIPTION="Robust, small and high performance http and reverse proxy server"
+
+HOMEPAGE="http://sysoev.ru/nginx/"
+SRC_URI="http://sysoev.ru/nginx/${P}.tar.gz"
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="debug fastcgi imap pcre perl threads ssl zlib"
+
+DEPEND="dev-lang/perl
+ pcre? ( >=dev-libs/libpcre-4.2 )
+ ssl? ( dev-libs/openssl )
+ zlib? ( sys-libs/zlib )
+ perl? ( >=dev-lang/perl-5.8 )"
+
+src_compile() {
+ local myconf
+
+ if use threads; then
+ einfo
+ ewarn "threads support is experimental at the moment"
+ ewarn "do not use it on production systems - you've been warned"
+ einfo
+ myconf="${myconf} --with-threads"
+ fi
+
+ use fastcgi || myconf="${myconf} --without-http_fastcgi_module"
+ use zlib || myconf="${myconf} --without-http_gzip_module"
+ use pcre || {
+ myconf="${myconf} --without-pcre --without-http_rewrite_module"
+ }
+ use debug && myconf="${myconf} --with-debug"
+ use ssl && myconf="${myconf} --with-http_ssl_module"
+ use imap && myconf="${myconf} --with-imap" # pop3/imap4 proxy support
+ use perl && myconf="${myconf} --with-http_perl_module"
+
+ ./configure \
+ --prefix=/usr \
+ --conf-path=/etc/${PN}/${PN}.conf \
+ --http-log-path=/var/log/${PN}/access_log \
+ --error-log-path=/var/log/${PN}/error_log \
+ --pid-path=/var/run/${PN}.pid \
+ --http-client-body-temp-path=/var/tmp/${PN}/client \
+ --http-proxy-temp-path=/var/tmp/${PN}/proxy \
+ --http-fastcgi-temp-path=/var/tmp/${PN}/fastcgi \
+ --with-md5-asm --with-md5=/usr/include \
+ ${myconf} || die "configure failed"
+
+ emake || die "failed to compile"
+}
+
+src_install() {
+ keepdir /var/log/${PN} /var/tmp/${PN}/{client,proxy,fastcgi}
+
+ dosbin objs/nginx
+ doinitd ${FILESDIR}/nginx
+
+ rm conf/nginx.conf
+ cp ${FILESDIR}/nginx.conf-r2 ${T}/nginx.conf
+
+ dodir /etc/${PN}
+ insinto /etc/${PN}
+ doins conf/* ${T}/nginx.conf
+
+ dodoc CHANGES{,.ru} LICENSE README
+}