summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKonstantin V. Arkhipov <voxus@gentoo.org>2006-05-06 16:37:55 +0000
committerKonstantin V. Arkhipov <voxus@gentoo.org>2006-05-06 16:37:55 +0000
commit53bf192cc59ba28fe456bff16e66cbaf9d62f5b5 (patch)
tree647d5340e2803bd85e30c5f326ebfc0ed5e7ea6c /www-servers/nginx
parentReplace malloc.h with stdlib.h when building on FreeBSD libc. (diff)
downloadgentoo-2-53bf192cc59ba28fe456bff16e66cbaf9d62f5b5.tar.gz
gentoo-2-53bf192cc59ba28fe456bff16e66cbaf9d62f5b5.tar.bz2
gentoo-2-53bf192cc59ba28fe456bff16e66cbaf9d62f5b5.zip
* bump
(Portage version: 2.1_pre10-r3)
Diffstat (limited to 'www-servers/nginx')
-rw-r--r--www-servers/nginx/ChangeLog10
-rw-r--r--www-servers/nginx/files/digest-nginx-0.3.453
-rw-r--r--www-servers/nginx/nginx-0.3.45.ebuild72
3 files changed, 83 insertions, 2 deletions
diff --git a/www-servers/nginx/ChangeLog b/www-servers/nginx/ChangeLog
index 225ed313e393..01e9b1fc95e8 100644
--- a/www-servers/nginx/ChangeLog
+++ b/www-servers/nginx/ChangeLog
@@ -1,11 +1,17 @@
# ChangeLog for www-servers/nginx
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-servers/nginx/ChangeLog,v 1.91 2006/05/04 15:59:53 voxus Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-servers/nginx/ChangeLog,v 1.92 2006/05/06 16:37:54 voxus Exp $
+
+*nginx-0.3.45 (06 May 2006)
+
+ 06 May 2006; Konstantin Arkhipov <voxus@gentoo.org> +nginx-0.3.45.ebuild,
+ -nginx-0.3.44.ebuild:
+ Version bump.
*nginx-0.3.44 (03 May 2006)
03 May 2006; Konstantin Arkhipov <voxus@gentoo.org> +nginx-0.3.44.ebuild,
- -nginx-0.3.44.ebuild:
+ -nginx-0.3.43.ebuild:
Version bump.
*nginx-0.3.43 (26 Apr 2006)
diff --git a/www-servers/nginx/files/digest-nginx-0.3.45 b/www-servers/nginx/files/digest-nginx-0.3.45
new file mode 100644
index 000000000000..97a7b5586f28
--- /dev/null
+++ b/www-servers/nginx/files/digest-nginx-0.3.45
@@ -0,0 +1,3 @@
+MD5 3593cd8531e553756007ce4898a8eda8 nginx-0.3.45.tar.gz 393378
+RMD160 eece4f4a792e18f994fc519bc29ab9a09ae89308 nginx-0.3.45.tar.gz 393378
+SHA256 96daa0c9704f39730c3c9926af89d2f24daa2e415c0838ef379faf3a049e3b3c nginx-0.3.45.tar.gz 393378
diff --git a/www-servers/nginx/nginx-0.3.45.ebuild b/www-servers/nginx/nginx-0.3.45.ebuild
new file mode 100644
index 000000000000..69f231e87f48
--- /dev/null
+++ b/www-servers/nginx/nginx-0.3.45.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-servers/nginx/nginx-0.3.45.ebuild,v 1.1 2006/05/06 16:37:54 voxus Exp $
+
+inherit eutils
+
+DESCRIPTION="Robust, small and high performance http and reverse proxy server"
+
+HOMEPAGE="http://sysoev.ru/nginx/"
+SRC_URI="http://sysoev.ru/nginx/${P}.tar.gz"
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="debug fastcgi imap pcre perl threads ssl zlib"
+
+DEPEND="dev-lang/perl
+ pcre? ( >=dev-libs/libpcre-4.2 )
+ ssl? ( dev-libs/openssl )
+ zlib? ( sys-libs/zlib )
+ perl? ( >=dev-lang/perl-5.8 )"
+
+src_compile() {
+ local myconf
+
+ if use threads; then
+ einfo
+ ewarn "threads support is experimental at the moment"
+ ewarn "do not use it on production systems - you've been warned"
+ einfo
+ myconf="${myconf} --with-threads"
+ fi
+
+ use fastcgi || myconf="${myconf} --without-http_fastcgi_module"
+ use zlib || myconf="${myconf} --without-http_gzip_module"
+ use pcre || {
+ myconf="${myconf} --without-pcre --without-http_rewrite_module"
+ }
+ use debug && myconf="${myconf} --with-debug"
+ use ssl && myconf="${myconf} --with-http_ssl_module"
+ use imap && myconf="${myconf} --with-imap" # pop3/imap4 proxy support
+ use perl && myconf="${myconf} --with-http_perl_module"
+
+ ./configure \
+ --prefix=/usr \
+ --conf-path=/etc/${PN}/${PN}.conf \
+ --http-log-path=/var/log/${PN}/access_log \
+ --error-log-path=/var/log/${PN}/error_log \
+ --pid-path=/var/run/${PN}.pid \
+ --http-client-body-temp-path=/var/tmp/${PN}/client \
+ --http-proxy-temp-path=/var/tmp/${PN}/proxy \
+ --http-fastcgi-temp-path=/var/tmp/${PN}/fastcgi \
+ --with-md5-asm --with-md5=/usr/include \
+ ${myconf} || die "configure failed"
+
+ emake || die "failed to compile"
+}
+
+src_install() {
+ keepdir /var/log/${PN} /var/tmp/${PN}/{client,proxy,fastcgi}
+
+ dosbin objs/nginx
+ doinitd ${FILESDIR}/nginx
+
+ rm conf/nginx.conf
+ cp ${FILESDIR}/nginx.conf-r2 ${T}/nginx.conf
+
+ dodir /etc/${PN}
+ insinto /etc/${PN}
+ doins conf/* ${T}/nginx.conf
+
+ dodoc CHANGES{,.ru} LICENSE README
+}