summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKonstantin V. Arkhipov <voxus@gentoo.org>2008-04-11 14:06:07 +0000
committerKonstantin V. Arkhipov <voxus@gentoo.org>2008-04-11 14:06:07 +0000
commit0fba19e721200e84a6856d5d6719a3a9a610cddc (patch)
tree7851fa93f611190e1dc0d84aed49b4301350a947 /www-servers/nginx
parent* bump (diff)
downloadgentoo-2-0fba19e721200e84a6856d5d6719a3a9a610cddc.tar.gz
gentoo-2-0fba19e721200e84a6856d5d6719a3a9a610cddc.tar.bz2
gentoo-2-0fba19e721200e84a6856d5d6719a3a9a610cddc.zip
* stabilization
(Portage version: 2.1.5_rc2)
Diffstat (limited to 'www-servers/nginx')
-rw-r--r--www-servers/nginx/ChangeLog7
-rw-r--r--www-servers/nginx/nginx-0.5.34.ebuild102
-rw-r--r--www-servers/nginx/nginx-0.5.35.ebuild4
-rw-r--r--www-servers/nginx/nginx-0.6.24.ebuild104
-rw-r--r--www-servers/nginx/nginx-0.6.29.ebuild4
5 files changed, 10 insertions, 211 deletions
diff --git a/www-servers/nginx/ChangeLog b/www-servers/nginx/ChangeLog
index 0777e64384fc..2a545bd26569 100644
--- a/www-servers/nginx/ChangeLog
+++ b/www-servers/nginx/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for www-servers/nginx
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-servers/nginx/ChangeLog,v 1.175 2008/03/24 10:29:41 voxus Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-servers/nginx/ChangeLog,v 1.176 2008/04/11 14:06:07 voxus Exp $
+
+ 11 Apr 2008; Konstantin V. Arkhipov <voxus@gentoo.org>
+ -nginx-0.5.34.ebuild, nginx-0.5.35.ebuild, -nginx-0.6.24.ebuild,
+ nginx-0.6.29.ebuild:
+ Stabilization.
*nginx-0.6.29 (24 Mar 2008)
diff --git a/www-servers/nginx/nginx-0.5.34.ebuild b/www-servers/nginx/nginx-0.5.34.ebuild
deleted file mode 100644
index dedbcd5b0fd7..000000000000
--- a/www-servers/nginx/nginx-0.5.34.ebuild
+++ /dev/null
@@ -1,102 +0,0 @@
-# Copyright 1999-2007 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-servers/nginx/nginx-0.5.34.ebuild,v 1.2 2007/12/31 19:54:24 voxus Exp $
-
-inherit eutils ssl-cert
-
-DESCRIPTION="Robust, small and high performance http and reverse proxy server"
-
-HOMEPAGE="http://sysoev.ru/nginx/"
-SRC_URI="http://sysoev.ru/nginx/${P}.tar.gz"
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="amd64 ~ppc x86"
-IUSE="debug fastcgi flv imap pcre perl ssl status sub webdav zlib"
-
-DEPEND="dev-lang/perl
- pcre? ( >=dev-libs/libpcre-4.2 )
- ssl? ( dev-libs/openssl )
- zlib? ( sys-libs/zlib )
- perl? ( >=dev-lang/perl-5.8 )"
-
-pkg_setup() {
- ebegin "Creating nginx user and group"
- enewgroup nginx
- enewuser nginx -1 -1 /dev/null nginx
- eend ${?}
-}
-
-src_compile() {
- local myconf
-
- # threads support is broken atm.
- #
- # if use threads; then
- # einfo
- # ewarn "threads support is experimental at the moment"
- # ewarn "do not use it on production systems - you've been warned"
- # einfo
- # myconf="${myconf} --with-threads"
- # fi
-
- use fastcgi || myconf="${myconf} --without-http_fastcgi_module"
- use fastcgi && myconf="${myconf} --with-http_realip_module"
- use flv && myconf="${myconf} --with-http_flv_module"
- use zlib || myconf="${myconf} --without-http_gzip_module"
- use pcre || {
- myconf="${myconf} --without-pcre --without-http_rewrite_module"
- }
- use debug && myconf="${myconf} --with-debug"
- use ssl && myconf="${myconf} --with-http_ssl_module"
- use imap && myconf="${myconf} --with-imap" # pop3/imap4 proxy support
- use perl && myconf="${myconf} --with-http_perl_module"
- use status && myconf="${myconf} --with-http_stub_status_module"
- use webdav && myconf="${myconf} --with-http_dav_module"
- use sub && myconf="${myconf} --with-http_sub_module"
-
- ./configure \
- --prefix=/usr \
- --conf-path=/etc/${PN}/${PN}.conf \
- --http-log-path=/var/log/${PN}/access_log \
- --error-log-path=/var/log/${PN}/error_log \
- --pid-path=/var/run/${PN}.pid \
- --http-client-body-temp-path=/var/tmp/${PN}/client \
- --http-proxy-temp-path=/var/tmp/${PN}/proxy \
- --http-fastcgi-temp-path=/var/tmp/${PN}/fastcgi \
- --with-md5-asm --with-md5=/usr/include \
- ${myconf} || die "configure failed"
-
- emake || die "failed to compile"
-}
-
-src_install() {
- keepdir /var/log/${PN} /var/tmp/${PN}/{client,proxy,fastcgi}
-
- dosbin objs/nginx
- cp "${FILESDIR}"/nginx-r1 "${T}"/nginx
- doinitd "${T}"/nginx
-
- cp "${FILESDIR}"/nginx.conf-r4 conf/nginx.conf
-
- dodir "${ROOT}"/etc/${PN}
- insinto "${ROOT}"/etc/${PN}
- doins conf/*
-
- dodoc CHANGES{,.ru} LICENSE README
-
- use perl && {
- cd "${S}"/objs/src/http/modules/perl/
- einstall DESTDIR="${D}"|| die "failed to install perl stuff"
- }
-}
-
-pkg_postinst() {
- use ssl && {
- if [ ! -f "${ROOT}"/etc/ssl/${PN}/${PN}.key ]; then
- dodir "${ROOT}"/etc/ssl/${PN}
- insinto "${ROOT}"etc/ssl/${PN}/
- insopts -m0644 -o nginx -g nginx
- install_cert /etc/ssl/nginx/nginx
- fi
- }
-}
diff --git a/www-servers/nginx/nginx-0.5.35.ebuild b/www-servers/nginx/nginx-0.5.35.ebuild
index 54efad9c2f25..add6ee4de6e6 100644
--- a/www-servers/nginx/nginx-0.5.35.ebuild
+++ b/www-servers/nginx/nginx-0.5.35.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-servers/nginx/nginx-0.5.35.ebuild,v 1.1 2008/01/10 10:26:49 voxus Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-servers/nginx/nginx-0.5.35.ebuild,v 1.2 2008/04/11 14:06:07 voxus Exp $
inherit eutils ssl-cert
@@ -10,7 +10,7 @@ HOMEPAGE="http://sysoev.ru/nginx/"
SRC_URI="http://sysoev.ru/nginx/${P}.tar.gz"
LICENSE="BSD"
SLOT="0"
-KEYWORDS="~amd64 ~ppc ~x86"
+KEYWORDS="amd64 ~ppc x86"
IUSE="debug fastcgi flv imap pcre perl ssl status sub webdav zlib"
DEPEND="dev-lang/perl
diff --git a/www-servers/nginx/nginx-0.6.24.ebuild b/www-servers/nginx/nginx-0.6.24.ebuild
deleted file mode 100644
index 5dc327f806eb..000000000000
--- a/www-servers/nginx/nginx-0.6.24.ebuild
+++ /dev/null
@@ -1,104 +0,0 @@
-# Copyright 1999-2007 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-servers/nginx/nginx-0.6.24.ebuild,v 1.2 2007/12/31 19:54:24 voxus Exp $
-
-inherit eutils ssl-cert
-
-DESCRIPTION="Robust, small and high performance http and reverse proxy server"
-
-HOMEPAGE="http://nginx.net/"
-SRC_URI="http://sysoev.ru/nginx/${P}.tar.gz"
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="amd64 ~ppc x86"
-IUSE="addition debug fastcgi flv imap pcre perl ssl status sub webdav zlib"
-
-DEPEND="dev-lang/perl
- pcre? ( >=dev-libs/libpcre-4.2 )
- ssl? ( dev-libs/openssl )
- zlib? ( sys-libs/zlib )
- perl? ( >=dev-lang/perl-5.8 )"
-
-pkg_setup() {
- ebegin "Creating nginx user and group"
- enewgroup nginx
- enewuser nginx -1 -1 /dev/null nginx
- eend ${?}
-}
-
-src_compile() {
- local myconf
-
- # threads support is broken atm.
- #
- # if use threads; then
- # einfo
- # ewarn "threads support is experimental at the moment"
- # ewarn "do not use it on production systems - you've been warned"
- # einfo
- # myconf="${myconf} --with-threads"
- # fi
-
- use addition && myconf="${myconf} --with-http_addition_module"
- use fastcgi || myconf="${myconf} --without-http_fastcgi_module"
- use fastcgi && myconf="${myconf} --with-http_realip_module"
- use flv && myconf="${myconf} --with-http_flv_module"
- use zlib || myconf="${myconf} --without-http_gzip_module"
- use pcre || {
- myconf="${myconf} --without-pcre --without-http_rewrite_module"
- }
- use debug && myconf="${myconf} --with-debug"
- use ssl && myconf="${myconf} --with-http_ssl_module"
- use imap && myconf="${myconf} --with-imap" # pop3/imap4 proxy support
- use perl && myconf="${myconf} --with-http_perl_module"
- use status && myconf="${myconf} --with-http_stub_status_module"
- use webdav && myconf="${myconf} --with-http_dav_module"
- use sub && myconf="${myconf} --with-http_sub_module"
-
- ./configure \
- --prefix=/usr \
- --conf-path=/etc/${PN}/${PN}.conf \
- --http-log-path=/var/log/${PN}/access_log \
- --error-log-path=/var/log/${PN}/error_log \
- --pid-path=/var/run/${PN}.pid \
- --http-client-body-temp-path=/var/tmp/${PN}/client \
- --http-proxy-temp-path=/var/tmp/${PN}/proxy \
- --http-fastcgi-temp-path=/var/tmp/${PN}/fastcgi \
- --with-md5-asm --with-md5=/usr/include \
- --with-sha1-asm --with-sha1=/usr/include \
- ${myconf} || die "configure failed"
-
- emake || die "failed to compile"
-}
-
-src_install() {
- keepdir /var/log/${PN} /var/tmp/${PN}/{client,proxy,fastcgi}
-
- dosbin objs/nginx
- cp "${FILESDIR}"/nginx-r1 "${T}"/nginx
- doinitd "${T}"/nginx
-
- cp "${FILESDIR}"/nginx.conf-r4 conf/nginx.conf
-
- dodir "${ROOT}"/etc/${PN}
- insinto "${ROOT}"/etc/${PN}
- doins conf/*
-
- dodoc CHANGES{,.ru} LICENSE README
-
- use perl && {
- cd "${S}"/objs/src/http/modules/perl/
- einstall DESTDIR="${D}"|| die "failed to install perl stuff"
- }
-}
-
-pkg_postinst() {
- use ssl && {
- if [ ! -f "${ROOT}"/etc/ssl/${PN}/${PN}.key ]; then
- dodir "${ROOT}"/etc/ssl/${PN}
- insinto "${ROOT}"etc/ssl/${PN}/
- insopts -m0644 -o nginx -g nginx
- install_cert /etc/ssl/nginx/nginx
- fi
- }
-}
diff --git a/www-servers/nginx/nginx-0.6.29.ebuild b/www-servers/nginx/nginx-0.6.29.ebuild
index a3fca409ef88..dac251868313 100644
--- a/www-servers/nginx/nginx-0.6.29.ebuild
+++ b/www-servers/nginx/nginx-0.6.29.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-servers/nginx/nginx-0.6.29.ebuild,v 1.1 2008/03/24 10:29:41 voxus Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-servers/nginx/nginx-0.6.29.ebuild,v 1.2 2008/04/11 14:06:07 voxus Exp $
inherit eutils ssl-cert
@@ -10,7 +10,7 @@ HOMEPAGE="http://nginx.net/"
SRC_URI="http://sysoev.ru/nginx/${P}.tar.gz"
LICENSE="BSD"
SLOT="0"
-KEYWORDS="~amd64 ~ppc ~x86"
+KEYWORDS="amd64 ~ppc x86"
IUSE="addition debug fastcgi flv imap pcre perl ssl status sub webdav zlib"
DEPEND="dev-lang/perl