summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2012-02-21 11:37:10 +0000
committerTim Harder <radhermit@gentoo.org>2012-02-21 11:37:10 +0000
commitd38295a173ad1984bcf18814badb52a42b474065 (patch)
treef7d27a1dc5be06bb15727fffe78aecf674bb5cf8 /www-servers/monkeyd
parentRevbump to 0.8.2-r2, fix bug 405117 (diff)
downloadgentoo-2-d38295a173ad1984bcf18814badb52a42b474065.tar.gz
gentoo-2-d38295a173ad1984bcf18814badb52a42b474065.tar.bz2
gentoo-2-d38295a173ad1984bcf18814badb52a42b474065.zip
Version bump.
(Portage version: 2.2.0_alpha87/cvs/Linux x86_64)
Diffstat (limited to 'www-servers/monkeyd')
-rw-r--r--www-servers/monkeyd/ChangeLog7
-rw-r--r--www-servers/monkeyd/monkeyd-0.33.0.ebuild68
2 files changed, 74 insertions, 1 deletions
diff --git a/www-servers/monkeyd/ChangeLog b/www-servers/monkeyd/ChangeLog
index 54220a2e479a..29f4958781f2 100644
--- a/www-servers/monkeyd/ChangeLog
+++ b/www-servers/monkeyd/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for www-servers/monkeyd
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-servers/monkeyd/ChangeLog,v 1.26 2012/02/11 03:07:39 radhermit Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-servers/monkeyd/ChangeLog,v 1.27 2012/02/21 11:37:10 radhermit Exp $
+
+*monkeyd-0.33.0 (21 Feb 2012)
+
+ 21 Feb 2012; Tim Harder <radhermit@gentoo.org> +monkeyd-0.33.0.ebuild:
+ Version bump.
11 Feb 2012; Tim Harder <radhermit@gentoo.org> -monkeyd-0.9.2.ebuild,
-monkeyd-0.9.2-r1.ebuild,
diff --git a/www-servers/monkeyd/monkeyd-0.33.0.ebuild b/www-servers/monkeyd/monkeyd-0.33.0.ebuild
new file mode 100644
index 000000000000..b8f1d103483f
--- /dev/null
+++ b/www-servers/monkeyd/monkeyd-0.33.0.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-servers/monkeyd/monkeyd-0.33.0.ebuild,v 1.1 2012/02/21 11:37:10 radhermit Exp $
+
+EAPI="4"
+
+inherit toolchain-funcs depend.php multilib
+
+WEBROOT=/var/www/localhost
+
+MY_P="${PN/d}-${PV}"
+DESCRIPTION="A small, fast, and scalable web server"
+HOMEPAGE="http://www.monkey-project.com/"
+SRC_URI="http://monkey-project.com/releases/${PV:0:4}/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~mips ~ppc ~sparc ~x86"
+IUSE="php"
+
+RDEPEND="php? ( virtual/httpd-php )"
+
+S="${WORKDIR}/${MY_P}"
+
+pkg_setup() {
+ use php && require_php_cgi
+}
+
+src_prepare() {
+ # Don't install the banana script, it is broken as is anyway and the
+ # functionality is provided by the ${FILESDIR}/monkeyd.init.d script.
+ sed -i '/install -m 755 bin\/banana/d' configure || die "sed banana"
+
+ # Don't explicitly strip files
+ sed -i -e '/$STRIP /d' -e 's/install -s -m 644/install -m 755/' configure || die
+}
+
+src_configure() {
+ # Non-autotools configure
+ ./configure \
+ --prefix=/usr \
+ --bindir=/usr/bin \
+ --datadir=${WEBROOT}/htdocs \
+ --logdir=/var/log/${PN} \
+ --mandir=/usr/share/man \
+ --plugdir=/usr/$(get_libdir)/monkeyd/plugins \
+ --sysconfdir=/etc/${PN} \
+ || die
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)" CFLAGS="${CFLAGS}"
+}
+
+src_install() {
+ default
+
+ if use php ; then
+ sed -i -e '/^#AddScript application\/x-httpd-php/s:^#::' "${D}"/etc/monkeyd/monkey.conf || die
+ sed -i -e 's:/home/my_home/php/bin/php:/usr/bin/php-cgi:' "${D}"/etc/monkeyd/monkey.conf || die
+ fi
+
+ mv "${D}"${WEBROOT}/htdocs/{index,index-monkey}.html
+
+ sed -i -e "s:/var/log/monkeyd/monkey.pid:/var/run/monkey.pid:" "${D}"/etc/monkeyd/monkey.conf || die
+ newinitd "${FILESDIR}"/monkeyd.init.d monkeyd
+ newconfd "${FILESDIR}"/monkeyd.conf.d monkeyd
+}