summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTom Wijsman <tomwij@gentoo.org>2013-02-08 19:10:49 +0000
committerTom Wijsman <tomwij@gentoo.org>2013-02-08 19:10:49 +0000
commitc4b256d9b72a5471017800a9e12afcfa6f523fa3 (patch)
tree2c012ad695397c04ada68d7f58d1d76d302a5a0b /www-servers/meteor
parent[bump] dev-perl/Path-Class-0.310.0 (diff)
downloadgentoo-2-c4b256d9b72a5471017800a9e12afcfa6f523fa3.tar.gz
gentoo-2-c4b256d9b72a5471017800a9e12afcfa6f523fa3.tar.bz2
gentoo-2-c4b256d9b72a5471017800a9e12afcfa6f523fa3.zip
Added patch that removes updater from meteor, therefore a revision bump to meteor-0.5.4-r1 such that users won't try to update manually. Added live ebuild that installs the devel branch of meteor, for easier development and testing. Done small fixes which make the ebuilds more reliable. Added gentoo suffix to version output.
(Portage version: 2.1.11.50/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'www-servers/meteor')
-rw-r--r--www-servers/meteor/ChangeLog14
-rw-r--r--www-servers/meteor/files/meteor-0.5.4.remove_updater.patch79
-rw-r--r--www-servers/meteor/meteor-0.5.4-r1.ebuild69
-rw-r--r--www-servers/meteor/meteor-9999.ebuild69
4 files changed, 230 insertions, 1 deletions
diff --git a/www-servers/meteor/ChangeLog b/www-servers/meteor/ChangeLog
index 9e390eee6c8b..c0d803374716 100644
--- a/www-servers/meteor/ChangeLog
+++ b/www-servers/meteor/ChangeLog
@@ -1,6 +1,18 @@
# ChangeLog for www-servers/meteor
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-servers/meteor/ChangeLog,v 1.2 2013/02/07 22:54:36 ulm Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-servers/meteor/ChangeLog,v 1.3 2013/02/08 19:10:49 tomwij Exp $
+
+*meteor-9999 (08 Feb 2013)
+*meteor-0.5.4-r1 (08 Feb 2013)
+
+ 08 Feb 2013; Tom Wijsman <TomWij@gentoo.org>
+ +files/meteor-0.5.4.remove_updater.patch, +meteor-0.5.4-r1.ebuild,
+ +meteor-9999.ebuild:
+ Added patch that removes updater from meteor, therefore a revision bump to
+ meteor-0.5.4-r1 such that users won't try to update manually. Added live
+ ebuild that installs the devel branch of meteor, for easier development and
+ testing. Done small fixes which make the ebuilds more reliable. Added gentoo
+ suffix to version output.
07 Feb 2013; Ulrich Müller <ulm@gentoo.org> meteor-0.5.4.ebuild:
Move Creative Commons licenses to shorter names.
diff --git a/www-servers/meteor/files/meteor-0.5.4.remove_updater.patch b/www-servers/meteor/files/meteor-0.5.4.remove_updater.patch
new file mode 100644
index 000000000000..e01c1cb5c77d
--- /dev/null
+++ b/www-servers/meteor/files/meteor-0.5.4.remove_updater.patch
@@ -0,0 +1,79 @@
+diff -ur a/app/meteor/meteor.js b/app/meteor/meteor.js
+--- a/app/meteor/meteor.js 2013-02-07 22:56:06.000000000 +0100
++++ b/app/meteor/meteor.js 2013-02-08 18:35:42.665734143 +0100
+@@ -249,23 +249,6 @@
+ });
+
+ Commands.push({
+- name: "update",
+- help: "Upgrade to the latest version of Meteor",
+- func: function (argv) {
+- if (argv.help) {
+- process.stdout.write(
+- "Usage: meteor update\n" +
+- "\n" +
+- "Checks to see if a new version of Meteor is available, and if so,\n" +
+- "downloads and installs it. You must be connected to the internet.\n");
+- process.exit(1);
+- }
+-
+- require(path.join(__dirname, 'update.js'));
+- }
+- });
+-
+- Commands.push({
+ name: "add",
+ help: "Add a package to this project",
+ func: function (argv) {
+diff -ur a/app/meteor/run.js b/app/meteor/run.js
+--- a/app/meteor/run.js 2013-02-07 22:56:06.000000000 +0100
++++ b/app/meteor/run.js 2013-02-08 18:33:28.135715176 +0100
+@@ -7,7 +7,6 @@
+ var httpProxy = require('http-proxy');
+
+ var files = require(path.join(__dirname, '..', 'lib', 'files.js'));
+-var updater = require(path.join(__dirname, '..', 'lib', 'updater.js'));
+ var bundler = require(path.join(__dirname, '..', 'lib', 'bundler.js'));
+ var mongo_runner = require(path.join(__dirname, '..', 'lib', 'mongo_runner.js'));
+ var mongoExitCodes = require(path.join(__dirname, '..', 'lib', 'mongo_exit_codes.js'));
+@@ -492,32 +491,6 @@
+ }
+ });
+
+-////////// Upgrade check //////////
+-
+-// XXX this should move to main meteor command-line, probably?
+-var start_update_checks = function () {
+- var update_check = function () {
+- updater.get_manifest(function (manifest) {
+- if (!files.in_checkout() && manifest &&
+- updater.needs_upgrade(manifest)) {
+- console.log("////////////////////////////////////////");
+- console.log("////////////////////////////////////////");
+- console.log();
+- console.log("meteor is out of date. Please run:");
+- console.log();
+- console.log(" meteor update");
+- console.log();
+- console.log("////////////////////////////////////////");
+- console.log("////////////////////////////////////////");
+- }
+- });
+- };
+- setInterval(update_check, 12*60*60*1000); // twice a day
+- update_check(); // and now.
+-}
+-
+-///////////////////////////////////////////////////////////////////////////////
+-
+ // Also used by "meteor deploy" in meteor.js.
+
+ exports.getSettings = function (filename) {
+@@ -765,7 +738,6 @@
+ process.stdout.write("Running on: http://localhost:" + outer_port + "/\n");
+ };
+
+- start_update_checks();
+ launch();
+ });
+ };
diff --git a/www-servers/meteor/meteor-0.5.4-r1.ebuild b/www-servers/meteor/meteor-0.5.4-r1.ebuild
new file mode 100644
index 000000000000..97a2336f1221
--- /dev/null
+++ b/www-servers/meteor/meteor-0.5.4-r1.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-servers/meteor/meteor-0.5.4-r1.ebuild,v 1.1 2013/02/08 19:10:49 tomwij Exp $
+
+EAPI=5
+
+inherit eutils vcs-snapshot
+
+METEOR_BUNDLEV="0.2.12"
+
+DESCRIPTION="An open-source platform for building top-quality web apps in a fraction of the time."
+HOMEPAGE="http://meteor.com/"
+SRC_URI="https://github.com/meteor/meteor/tarball/v${PV} -> ${P}.tar.gz
+ x86? ( https://d3sqy0vbqsdhku.cloudfront.net/dev_bundle_Linux_i686_${METEOR_BUNDLEV}.tar.gz -> ${P}_bundle-${METEOR_BUNDLEV}.tar.gz )
+ amd64? ( https://d3sqy0vbqsdhku.cloudfront.net/dev_bundle_Linux_x86_64_${METEOR_BUNDLEV}.tar.gz -> ${P}_bundle-${METEOR_BUNDLEV}.tar.gz )"
+
+LICENSE="AGPL-3
+ Apache-2.0
+ Boost-1.0
+ BSD
+ BSD-2
+ CC-BY-SA-2.0
+ HPND
+ MIT
+ npm
+ ODbL-1.0
+ openssl
+ public-domain
+ Unlicense
+ ZLIB || ( BSD-2 GPL-2+ )
+ WTFPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+src_prepare() {
+ local DEV_BUNDLE_DIR="${WORKDIR}/${P}_bundle-${METEOR_BUNDLEV}"
+
+ einfo "Moving development bundle ..."
+ mv "${DEV_BUNDLE_DIR}"/* "${DEV_BUNDLE_DIR}"/.bundle_version.txt . || die "Couldn't move development bundle."
+
+ einfo "Patching files ..."
+ sed -i 's/DEV_BUNDLE=$(dirname "$SCRIPT_DIR")/DEV_BUNDLE="$SCRIPT_DIR"/g' meteor || die "Couldn't patch DEV_BUNDLE script dir."
+ sed -i -e "s/^exports\.CURRENT_VERSION.*/exports.CURRENT_VERSION = \"${PV}-gentoo\";/g" app/lib/updater.js || die "Couldn't add gentoo suffix to version."
+
+ einfo "Removing updater since Portage covers this ..."
+ epatch "${FILESDIR}"/${P}.remove_updater.patch
+ rm app/meteor/update.js || die "Couldn't remove updater."
+
+ # We don't care if these fail, just get rid of them if they exist.
+ einfo "Removing unnecessary files ..."
+ rm -rf admin
+ rm -rf {examples,packages}/*/.meteor/local
+ rm -rf examples/unfinished
+}
+
+src_install() {
+ dodir /opt/meteor
+
+ insinto /opt/meteor
+ doins -r *
+ doins .bundle_version.txt
+
+ dosym /opt/meteor/meteor /usr/bin/meteor
+
+ fperms +x /opt/meteor/meteor
+ fperms +x /opt/meteor/bin/node
+ fperms +x /opt/meteor/mongodb/bin/mongo
+ fperms +x /opt/meteor/mongodb/bin/mongod
+}
diff --git a/www-servers/meteor/meteor-9999.ebuild b/www-servers/meteor/meteor-9999.ebuild
new file mode 100644
index 000000000000..457d9789574f
--- /dev/null
+++ b/www-servers/meteor/meteor-9999.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-servers/meteor/meteor-9999.ebuild,v 1.1 2013/02/08 19:10:49 tomwij Exp $
+
+EAPI=5
+
+inherit eutils git-2
+
+METEOR_BUNDLEV="0.2.17"
+
+DESCRIPTION="An open-source platform for building top-quality web apps in a fraction of the time."
+HOMEPAGE="http://meteor.com/"
+SRC_URI="x86? ( https://d3sqy0vbqsdhku.cloudfront.net/dev_bundle_Linux_i686_${METEOR_BUNDLEV}.tar.gz -> ${P}_bundle-${METEOR_BUNDLEV}.tar.gz )
+ amd64? ( https://d3sqy0vbqsdhku.cloudfront.net/dev_bundle_Linux_x86_64_${METEOR_BUNDLEV}.tar.gz -> ${P}_bundle-${METEOR_BUNDLEV}.tar.gz )"
+
+S="${WORKDIR}"
+
+EGIT_REPO_URI="git://github.com/meteor/meteor.git"
+EGIT_BRANCH="devel"
+EGIT_SOURCEDIR="${S}"
+
+LICENSE="AGPL-3
+ Apache-2.0
+ Boost-1.0
+ BSD
+ BSD-2
+ CC-BY-SA-2.0
+ HPND
+ MIT
+ npm
+ ODbL-1.0
+ openssl
+ public-domain
+ Unlicense
+ ZLIB || ( BSD-2 GPL-2+ )
+ WTFPL-2"
+SLOT="0"
+KEYWORDS=""
+
+src_prepare() {
+ einfo "Patching files ..."
+ sed -i 's/DEV_BUNDLE=$(dirname "$SCRIPT_DIR")/DEV_BUNDLE="$SCRIPT_DIR"/g' meteor || die "Couldn't patch DEV_BUNDLE script dir."
+ sed -i -e 's/^exports\.CURRENT_VERSION.*/exports.CURRENT_VERSION = "devel-gentoo";/g' app/lib/updater.js || die "Couldn't patch version to devel branch."
+
+ einfo "Removing updater since Portage covers this ..."
+ epatch "${FILESDIR}"/${PN}-0.5.4.remove_updater.patch
+ rm app/meteor/update.js || die "Couldn't remove updater."
+
+ # We don't care if these fail, just get rid of them if they exist.
+ einfo "Removing unnecessary files ..."
+ rm -rf admin
+ rm -rf {examples,packages}/*/.meteor/local
+ rm -rf examples/unfinished
+}
+
+src_install() {
+ dodir /opt/meteor
+
+ insinto /opt/meteor
+ doins -r *
+ doins .bundle_version.txt
+
+ dosym /opt/meteor/meteor /usr/bin/meteor
+
+ fperms +x /opt/meteor/meteor
+ fperms +x /opt/meteor/bin/node
+ fperms +x /opt/meteor/mongodb/bin/mongo
+ fperms +x /opt/meteor/mongodb/bin/mongod
+}