summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRafael Martins <rafaelmartins@gentoo.org>2011-05-20 04:34:46 +0000
committerRafael Martins <rafaelmartins@gentoo.org>2011-05-20 04:34:46 +0000
commit180e8ce50c1c839e250c961a139302da7b8dd7fa (patch)
treef5820a0f2bcd46896a397ef89f7135f4ee4f776f /www-servers/gunicorn
parentApplied Zac's path in bug 113298 to get stages building again. (diff)
downloadgentoo-2-180e8ce50c1c839e250c961a139302da7b8dd7fa.tar.gz
gentoo-2-180e8ce50c1c839e250c961a139302da7b8dd7fa.tar.bz2
gentoo-2-180e8ce50c1c839e250c961a139302da7b8dd7fa.zip
Version bump.
(Portage version: 2.2.0_alpha32/cvs/Linux x86_64)
Diffstat (limited to 'www-servers/gunicorn')
-rw-r--r--www-servers/gunicorn/ChangeLog8
-rw-r--r--www-servers/gunicorn/gunicorn-0.12.2.ebuild40
2 files changed, 47 insertions, 1 deletions
diff --git a/www-servers/gunicorn/ChangeLog b/www-servers/gunicorn/ChangeLog
index e96410984ce1..d5630dc35ddf 100644
--- a/www-servers/gunicorn/ChangeLog
+++ b/www-servers/gunicorn/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for www-servers/gunicorn
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-servers/gunicorn/ChangeLog,v 1.5 2011/04/10 06:51:23 phajdan.jr Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-servers/gunicorn/ChangeLog,v 1.6 2011/05/20 04:34:46 rafaelmartins Exp $
+
+*gunicorn-0.12.2 (20 May 2011)
+
+ 20 May 2011; Rafael G. Martins <rafaelmartins@gentoo.org>
+ +gunicorn-0.12.2.ebuild:
+ Version bump.
10 Apr 2011; Pawel Hajdan jr <phajdan.jr@gentoo.org>
gunicorn-0.12.0.ebuild:
diff --git a/www-servers/gunicorn/gunicorn-0.12.2.ebuild b/www-servers/gunicorn/gunicorn-0.12.2.ebuild
new file mode 100644
index 000000000000..d0e085cdb0ee
--- /dev/null
+++ b/www-servers/gunicorn/gunicorn-0.12.2.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-servers/gunicorn/gunicorn-0.12.2.ebuild,v 1.1 2011/05/20 04:34:46 rafaelmartins Exp $
+
+EAPI="3"
+PYTHON_DEPEND="2:2.5"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="2.4 3.* *-jython"
+
+inherit distutils
+
+DESCRIPTION="A WSGI HTTP Server for UNIX, fast clients and nothing else"
+HOMEPAGE="http://gunicorn.org http://pypi.python.org/pypi/gunicorn"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+IUSE="doc examples test"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="dev-python/setproctitle"
+DEPEND="dev-python/setuptools
+ test? ( dev-python/nose )"
+
+DOCS="README.rst"
+
+src_install() {
+ distutils_src_install
+ use doc && dohtml -r doc/htdocs/*
+ insinto "/usr/share/doc/${PF}"
+ use examples && doins -r examples
+}
+
+src_test() {
+ # distutils_src_test doesn't works if gunicorn isn't installed yet
+ testing() {
+ PYTHONPATH="build-${PYTHON_ABI}/lib" "$(PYTHON)" setup.py test
+ }
+ python_execute_function testing
+}