summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBenedikt Boehm <hollow@gentoo.org>2009-07-07 09:50:43 +0000
committerBenedikt Boehm <hollow@gentoo.org>2009-07-07 09:50:43 +0000
commitd41ef618632e7ee4a71b56f86f1cada5b2298cb5 (patch)
treeceae18d2ff80e057018ad9d3010b2557c1f8e3e1 /www-servers/apache
parentx11-drivers/xf86-video-intel: add updated 2.8 RC 1 snapshot (diff)
downloadgentoo-2-d41ef618632e7ee4a71b56f86f1cada5b2298cb5.tar.gz
gentoo-2-d41ef618632e7ee4a71b56f86f1cada5b2298cb5.tar.bz2
gentoo-2-d41ef618632e7ee4a71b56f86f1cada5b2298cb5.zip
fix #276707, #276792
(Portage version: 2.2_rc33/cvs/Linux i686)
Diffstat (limited to 'www-servers/apache')
-rw-r--r--www-servers/apache/ChangeLog7
-rw-r--r--www-servers/apache/apache-2.2.11-r2.ebuild110
2 files changed, 116 insertions, 1 deletions
diff --git a/www-servers/apache/ChangeLog b/www-servers/apache/ChangeLog
index 1f1164a2fa77..3fceb3497630 100644
--- a/www-servers/apache/ChangeLog
+++ b/www-servers/apache/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for www-servers/apache
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-servers/apache/ChangeLog,v 1.108 2009/07/07 00:31:21 rich0 Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-servers/apache/ChangeLog,v 1.109 2009/07/07 09:50:43 hollow Exp $
+
+*apache-2.2.11-r2 (07 Jul 2009)
+
+ 07 Jul 2009; Benedikt Böhm <hollow@gentoo.org> +apache-2.2.11-r2.ebuild:
+ fix #276707, #276792
07 Jul 2009; Richard Freeman <rich0@gentoo.org> apache-2.2.11-r1.ebuild:
amd64 stable - 276589
diff --git a/www-servers/apache/apache-2.2.11-r2.ebuild b/www-servers/apache/apache-2.2.11-r2.ebuild
new file mode 100644
index 000000000000..aa34b8c8c247
--- /dev/null
+++ b/www-servers/apache/apache-2.2.11-r2.ebuild
@@ -0,0 +1,110 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-servers/apache/apache-2.2.11-r2.ebuild,v 1.1 2009/07/07 09:50:43 hollow Exp $
+
+# latest gentoo apache files
+GENTOO_PATCHSTAMP="20090707"
+GENTOO_DEVELOPER="hollow"
+
+# IUSE/USE_EXPAND magic
+IUSE_MPMS_FORK="itk peruser prefork"
+IUSE_MPMS_THREAD="event worker"
+
+IUSE_MODULES="actions alias asis auth_basic auth_digest authn_alias authn_anon
+authn_dbd authn_dbm authn_default authn_file authz_dbm authz_default
+authz_groupfile authz_host authz_owner authz_user autoindex cache cern_meta
+charset_lite dav dav_fs dav_lock dbd deflate dir disk_cache dumpio env expires
+ext_filter file_cache filter headers ident imagemap include info log_config
+log_forensic logio mem_cache mime mime_magic negotiation proxy proxy_ajp
+proxy_balancer proxy_connect proxy_ftp proxy_http rewrite setenvif speling
+status substitute unique_id userdir usertrack version vhost_alias"
+
+# inter-module dependencies
+# TODO: this may still be incomplete
+MODULE_DEPENDS="
+ dav_fs:dav
+ dav_lock:dav
+ deflate:filter
+ disk_cache:cache
+ ext_filter:filter
+ file_cache:cache
+ log_forensic:log_config
+ logio:log_config
+ mem_cache:cache
+ mime_magic:mime
+ proxy_ajp:proxy
+ proxy_balancer:proxy
+ proxy_connect:proxy
+ proxy_ftp:proxy
+ proxy_http:proxy
+ substitute:filter
+"
+
+# module<->define mappings
+MODULE_DEFINES="
+ auth_digest:AUTH_DIGEST
+ authnz_ldap:AUTHNZ_LDAP
+ cache:CACHE
+ dav:DAV
+ dav_fs:DAV
+ dav_lock:DAV
+ disk_cache:CACHE
+ file_cache:CACHE
+ info:INFO
+ ldap:LDAP
+ mem_cache:CACHE
+ proxy:PROXY
+ proxy_ajp:PROXY
+ proxy_balancer:PROXY
+ proxy_connect:PROXY
+ proxy_ftp:PROXY
+ proxy_http:PROXY
+ ssl:SSL
+ status:STATUS
+ suexec:SUEXEC
+ userdir:USERDIR
+"
+
+# critical modules for the default config
+MODULE_CRITICAL="
+ authz_host
+ dir
+ mime
+"
+
+inherit apache-2
+
+DESCRIPTION="The Apache Web Server."
+HOMEPAGE="http://httpd.apache.org/"
+
+# some helper scripts are Apache-1.1, thus both are here
+LICENSE="Apache-2.0 Apache-1.1"
+SLOT="2"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~sparc-fbsd ~x86 ~x86-fbsd"
+IUSE="sni"
+
+DEPEND="${DEPEND}
+ apache2_modules_deflate? ( sys-libs/zlib )"
+
+RDEPEND="${RDEPEND}
+ apache2_modules_mime? ( app-misc/mime-types )"
+
+src_unpack() {
+ if ! use sni ; then
+ EPATCH_EXCLUDE="04_all_mod_ssl_tls_sni.patch"
+ fi
+
+ apache-2_src_unpack
+}
+
+pkg_preinst() {
+ # note regarding IfDefine changes
+ if has_version "<${CATEGORY}/${PN}-2.2.6-r1"; then
+ elog
+ elog "When upgrading from versions 2.2.6 or earlier, please be aware"
+ elog "that the define for mod_authnz_ldap has changed from AUTH_LDAP"
+ elog "to AUTHNZ_LDAP. Additionally mod_auth_digest needs to be enabled"
+ elog "with AUTH_DIGEST now."
+ elog
+ fi
+}