summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJim Ramsay <lack@gentoo.org>2009-07-20 19:21:44 +0000
committerJim Ramsay <lack@gentoo.org>2009-07-20 19:21:44 +0000
commit5b88b3f604849b90c9b86992b30bad0513009cbc (patch)
treea5692b977c2497208733ef2d088a1f2be548577b /www-plugins
parentold (diff)
downloadgentoo-2-5b88b3f604849b90c9b86992b30bad0513009cbc.tar.gz
gentoo-2-5b88b3f604849b90c9b86992b30bad0513009cbc.tar.bz2
gentoo-2-5b88b3f604849b90c9b86992b30bad0513009cbc.zip
Use ^C-getCC for compiling the wrapper
(Portage version: 2.1.6.13/cvs/Linux x86_64)
Diffstat (limited to 'www-plugins')
-rw-r--r--www-plugins/adobe-flash/ChangeLog6
-rw-r--r--www-plugins/adobe-flash/adobe-flash-10.0.22.87-r2.ebuild6
2 files changed, 8 insertions, 4 deletions
diff --git a/www-plugins/adobe-flash/ChangeLog b/www-plugins/adobe-flash/ChangeLog
index 6aed8071cec8..b8c4a879fc8f 100644
--- a/www-plugins/adobe-flash/ChangeLog
+++ b/www-plugins/adobe-flash/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for www-plugins/adobe-flash
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-plugins/adobe-flash/ChangeLog,v 1.4 2009/07/20 13:54:59 lack Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-plugins/adobe-flash/ChangeLog,v 1.5 2009/07/20 19:21:44 lack Exp $
+
+ 20 Jul 2009; Jim Ramsay <lack@gentoo.org>
+ adobe-flash-10.0.22.87-r2.ebuild:
+ Use ^C-getCC for compiling the wrapper
*adobe-flash-10.0.22.87-r2 (20 Jul 2009)
diff --git a/www-plugins/adobe-flash/adobe-flash-10.0.22.87-r2.ebuild b/www-plugins/adobe-flash/adobe-flash-10.0.22.87-r2.ebuild
index 04a72487baf9..0ba0af181e76 100644
--- a/www-plugins/adobe-flash/adobe-flash-10.0.22.87-r2.ebuild
+++ b/www-plugins/adobe-flash/adobe-flash-10.0.22.87-r2.ebuild
@@ -1,9 +1,9 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-plugins/adobe-flash/adobe-flash-10.0.22.87-r2.ebuild,v 1.1 2009/07/20 13:54:59 lack Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-plugins/adobe-flash/adobe-flash-10.0.22.87-r2.ebuild,v 1.2 2009/07/20 19:21:44 lack Exp $
EAPI=1
-inherit nsplugins rpm multilib
+inherit nsplugins rpm multilib toolchain-funcs
MY_32B_URI="http://fpdownload.macromedia.com/get/flashplayer/current/flash-plugin-${PV}-release.i386.rpm"
MY_64B_URI="http://download.macromedia.com/pub/labs/flashplayer10/libflashplayer-${PV}.linux-x86_64.so.tar.gz"
@@ -87,7 +87,7 @@ src_compile() {
if [[ $need_lahf_wrapper ]]; then
# This experimental wrapper, from Maks Verver via bug #268336 should
# emulate the missing lahf instruction affected platforms.
- cc -fPIC -shared -nostdlib -lc -oflashplugin-lahf-fix.so \
+ $(tc-getCC) -fPIC -shared -nostdlib -lc -oflashplugin-lahf-fix.so \
"${FILESDIR}/flashplugin-lahf-fix.c" \
|| die "Compile of flashplugin-lahf-fix.so failed"
fi