summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2009-12-05 16:42:56 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2009-12-05 16:42:56 +0000
commit4c51e6d9913ef911944fbb726e6ea423d2aa612c (patch)
tree751f3c22020c30ae6b3e52685ff5385b7244a1aa /www-plugins
parentMark this ebuild as the highest that can work with xen-sources and should not... (diff)
downloadgentoo-2-4c51e6d9913ef911944fbb726e6ea423d2aa612c.tar.gz
gentoo-2-4c51e6d9913ef911944fbb726e6ea423d2aa612c.tar.bz2
gentoo-2-4c51e6d9913ef911944fbb726e6ea423d2aa612c.zip
Add patch to not crash firefox if built with --as-needed. PulseAudio is used at build time as well.
(Portage version: 2.2_rc55/cvs/Linux x86_64)
Diffstat (limited to 'www-plugins')
-rw-r--r--www-plugins/libflashsupport/ChangeLog7
-rw-r--r--www-plugins/libflashsupport/files/libflashsupport-1.2-asneeded.patch16
-rw-r--r--www-plugins/libflashsupport/libflashsupport-1.2.ebuild10
3 files changed, 28 insertions, 5 deletions
diff --git a/www-plugins/libflashsupport/ChangeLog b/www-plugins/libflashsupport/ChangeLog
index b95146cb7e7b..ff1f2b7df839 100644
--- a/www-plugins/libflashsupport/ChangeLog
+++ b/www-plugins/libflashsupport/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for www-plugins/libflashsupport
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-plugins/libflashsupport/ChangeLog,v 1.1 2009/04/10 13:15:11 ulm Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-plugins/libflashsupport/ChangeLog,v 1.2 2009/12/05 16:42:56 flameeyes Exp $
+
+ 05 Dec 2009; Diego E. Pettenò <flameeyes@gentoo.org>
+ libflashsupport-1.2.ebuild, +files/libflashsupport-1.2-asneeded.patch:
+ Add patch to not crash firefox if built with --as-needed. PulseAudio is
+ used at build time as well.
10 Apr 2009; Ulrich Mueller <ulm@gentoo.org> +metadata.xml,
+libflashsupport-1.2.ebuild:
diff --git a/www-plugins/libflashsupport/files/libflashsupport-1.2-asneeded.patch b/www-plugins/libflashsupport/files/libflashsupport-1.2-asneeded.patch
new file mode 100644
index 000000000000..c2ff7717e1b5
--- /dev/null
+++ b/www-plugins/libflashsupport/files/libflashsupport-1.2-asneeded.patch
@@ -0,0 +1,16 @@
+Index: libflashsupport-1.2/Makefile
+===================================================================
+--- libflashsupport-1.2.orig/Makefile
++++ libflashsupport-1.2/Makefile
+@@ -50,9 +50,9 @@ all: libflashsupport.so
+
+ libflashsupport.so: flashsupport.c
+ $(CC) $(CFLAGS) $(LIBS) -DLIBDIR=$(LIBDIR) \
++ flashsupport.c -o libflashsupport.so \
+ $(ALSA) $(ALSALIBS) $(PULSE) $(LIBPULSEPATH) $(ESD) $(LIBESDPATH) \
+- $(OSS) $(SSL) $(SSLLIBS) $(V4L) $(ICULIBS)\
+- flashsupport.c -o libflashsupport.so
++ $(OSS) $(SSL) $(SSLLIBS) $(V4L) $(ICULIBS)
+
+ install: all
+ mkdir -p ${LIBDIR}
diff --git a/www-plugins/libflashsupport/libflashsupport-1.2.ebuild b/www-plugins/libflashsupport/libflashsupport-1.2.ebuild
index ead16de57e8d..f5027bdd6b98 100644
--- a/www-plugins/libflashsupport/libflashsupport-1.2.ebuild
+++ b/www-plugins/libflashsupport/libflashsupport-1.2.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-plugins/libflashsupport/libflashsupport-1.2.ebuild,v 1.1 2009/04/10 13:15:11 ulm Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-plugins/libflashsupport/libflashsupport-1.2.ebuild,v 1.2 2009/12/05 16:42:56 flameeyes Exp $
-inherit multilib
+inherit multilib eutils
DESCRIPTION="Adds pulseaudio/esd/oss audio output and HTTPS/RTMPS support to
Adobe Flash 9"
@@ -18,10 +18,10 @@ KEYWORDS="~amd64 ~x86"
IUSE="pulseaudio esd oss ssl gnutls"
DEPEND="gnutls? ( net-libs/gnutls )
- !gnutls? ( ssl? ( dev-libs/openssl ) )"
+ !gnutls? ( ssl? ( dev-libs/openssl ) )
+ pulseaudio? ( media-sound/pulseaudio )"
RDEPEND="${DEPEND}
- pulseaudio? ( media-sound/pulseaudio )
esd? ( media-sound/esound )"
src_unpack() {
@@ -29,6 +29,8 @@ src_unpack() {
cd "${S}"
sed -i -e 's:/var/lib/run/pulse/native:/var/run/pulse/native:' \
README flashsupport.c || die "sed failed"
+
+ epatch "${FILESDIR}"/${P}-asneeded.patch
}
src_compile() {